[Stable Update] 2021-04-28 - Kernels, Wine, Ruby, JDK, KDE-Dev, Mesa 21.0.3, KDE Apps 21.04, Python, Haskell, Mate 1.24.2, Virtualbox, Thunderbird

Hi there!

Ran into a problem of black screen at boot (after plymouth screen).

I’m using KDE and sddm seems to have a little bug now that it doesn’t open in the right tty, so some users might be able to switch tty (most like to the second with Ctrl+Alt+F2) to go into graphical interface.

For my part, I couldn’t switch ttys. It simply stayed a black screen.

Disabling sddm-plymouth and enabling sddm didn’t help, but when I downgraded sddm to one version back, it finally booted for me (as the new bug has been introduced in the now-upstream version).

I did this with chrooting into my installation and execute these commands inside my manjaro-chroot:

wget https://archive.archlinux.org/packages/s/sddm/sddm-0.19.0-4-x86_64.pkg.tar.zst
pacman -U sddm-0.19.0-4-x86_64.pkg.tar.zst
rm sddm-0.19.0-4-x86_64.pkg.tar.zst

Then exiting chroot and rebooting into my installed system. Worked fine then. I currently have work to do, so I can’t further investigate this issue (whether it really solved it or it was just a lucky boot). I might investigate more these days.

I hope I could help another user with the same problem. :slight_smile:

This was the site which gave me the idea to downgrade this package: bugs . archlinux.org /task/70528

I had to install Kernel 5.12 from the Terminal. The Manjaro Settings Manager will not install 5.12.

MSM did the business for me on Testing.

Everything looks ok excepts the AMD GPU Driver issue I’ve been facing the later 3 updates. Changing Kernels and kernel/Mesa updates din’t fix the issue wet.

Got this error 5min ago, and as pointed previously, it crashes my PC and requires reset button to be pushed.

Let me know how and where I could better report this issue, I’ve been using linux for 2 months

29/04/2021 07:46 kernel [drm:amdgpu_dm_atomic_commit_tail [amdgpu]] ERROR Waiting for fences timed out!

This release broke Virtualbox, tried to fix, no success.

It shows NS_ERROR_FAILURE (0x80004005)
Kernel 5.10 and 5.4. Headers updated, all packages updated, worked fine before this release.

KDE with kernel 5.10.32 LTS, systemd-boot and SDDM. Everything seems to work, but I noticed some strange things during startup after upgrade (rebooted multiple times, the issue exists):

  1. After entering volume decryption password at boot (got encrypted main drive with custom partitioning + encrypted RAID1), boot manager starts displaying all the usual messages, including UUID of disk drives. And now one of UUID is displayed incorrectly - a question mark is added instead of one of characters. Before update:


After update:
UUID=a1b92429-9eda-?260-8099-204a151d8e3f (notice ? instead of “normal” character).

both fstab and crypttab contain valid entries and RAID is automatically decrypted during boot just fine. It’s just that glitch with ? mark…

  1. When boot ends and it’s time to start GUI (I have auto-login enabled in SDDM) instead of displaying KDE desktop immediately, system displays black window that has blinking _ symbol at the top. Just like command line. After a second or two, it disappears and desktop is displayed.

  2. Not sure if this is issue with Manjaro or KDE/SDDM itself, but I have it for 2 months already, and it’s still not fixed. If there are multiple keyboard input languages installed and lock screen is displayed (either after screensaver or manual locking), keyboard icon is displayed at the bottom as usually, but language icon is missing; therefore, it’s impossible to know which language you use to enter password. The only way to find out - enter password and “reveal” it by clicking the corresponding icon in password field. Not a very big problem, but language selector worked for years and it’s now broken.

Upgraded today with “pacman -Suy”, without issues, and after reboot the system seems to be fine, BUT:
when I try to access (i.e. mount) a partition on an internal HDD (which is not used right-away, but is just a destination for occasional backups) Thunar refuses with error message

“Der Datenträger >xxx< konnte nicht eingehängt werden. No object for D-Bus interface.”

Mounting partionitions on this HDD manually with mount -t ext4 /dev/sdc1 /mnt it works, without errors.
Apparently no log entries relating to this issue (tried journalctl -f), no boot issues (tried dmesg)
Any ideas?? Thx.

System:    Host: PC3 Kernel: 5.10.32-1-MANJARO x86_64 bits: 64 Desktop: Xfce 4.16.0 Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: MSI model: H170A GAMING PRO (MS-7978) v: 1.0 serial: <superuser required> 
           UEFI-[Legacy]: American Megatrends v: 2.E0 date: 07/04/2018 
CPU:       Info: Quad Core model: Intel Core i7-7700K bits: 64 type: MT MCP cache: L2: 8 MiB 
           Speed: 800 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
Graphics:  Device-1: NVIDIA TU106 [GeForce RTX 2070] driver: nvidia v: 460.73.01 
           Display: x11 server: X.Org 1.20.11 driver: loaded: nvidia resolution: 3440x1440 
           OpenGL: renderer: GeForce RTX 2070/PCIe/SSE2 v: 4.6.0 NVIDIA 460.73.01 
Audio:     Device-1: Intel 100 Series/C230 Series Family HD Audio driver: snd_hda_intel 
           Device-2: NVIDIA TU106 High Definition Audio driver: snd_hda_intel 
           Sound Server-1: ALSA v: k5.10.32-1-MANJARO running: yes 
           Sound Server-2: PulseAudio v: 14.2 running: yes 
Network:   Device-1: Intel Ethernet I219-V driver: e1000e 
           IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: d8:cb:8a:9d:f8:cc 
Drives:    Local Storage: total: 2.63 TiB used: 184.98 GiB (6.9%) 
           ID-1: /dev/sda vendor: Crucial model: CT525MX300SSD1 size: 489.05 GiB 
           ID-2: /dev/sdb vendor: SanDisk model: SDSSDHII240G size: 223.57 GiB 
           ID-3: /dev/sdc vendor: Western Digital model: WD20EARX-00PASB0 size: 1.82 TiB 
           ID-4: /dev/sdd vendor: SanDisk model: SD8SBAT128G1122 size: 119.24 GiB 
Partition: ID-1: / size: 38.92 GiB used: 28.61 GiB (73.5%) fs: ext4 dev: /dev/sdd3 
           ID-2: /home size: 481.25 GiB used: 156.38 GiB (32.5%) fs: ext4 dev: /dev/sda1 
Swap:      ID-1: swap-1 type: partition size: 2 GiB used: 0 KiB (0.0%) dev: /dev/sdd4 
Sensors:   System Temperatures: cpu: 37.5 C mobo: 29.8 C gpu: nvidia temp: 37 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 31% 

Smooth operator, everything went smooth as usual.

Kernel: 5.12.0-1-MANJARO
DE: Plasma 5.21.4
WM: KWin

As always (for me anyway) everything went smooth on my laptop with KDE. Thanks again to all the gang at Manjaro.
:+1: :+1: :+1: :beers: :beers:


LightDM will no longer start reliably with the 5.10 kernel on my AMD 3900x with AMD 5600xt graphics. I’ve reverted to the 5.4 LTS, but now I’m also having issues with the audio output being very distorted, tinny and scratchy. Killing pulseaudio seems to work for a while. Anyone else having audio issues?

@Adramyttium Enable early KMS:

After the update, including kernel 5.12 update, all of my VirtualBox guests, Windows and Linux, now have distorted, crackling, reverberant sound.
EDIT: Same with kernel 5.11, so it is caused by regular software update.
EDIT2: It’s an issue of VirtualBox 6.1.20 as stated in VirtualBox forum. After I downgraded to 6.1.18, the sound is normal again.


All good, except that the first time I opened a Konsole, I was greeted with a very unwelcome and intrusive new toolbar, which also had the effect of forcing the window to be much wider than usual.
After a lot of random right-clicking and trying options, I found that I could get rid of it, though annoyingly I can’t remember the precise sequence so can’t leave a solution here. But it was to do with showing toolbars in some way…

I’ll give this a try. Thanks.

I have issue with Firefox Developer Edition. When I start it, it crashes graphically, I see just fragments of the image shown in it. I downgraded it for now to a previous version…

Settings > Toolbars Shown > disable the checkboxes to both (all) toolbars listed

Major problem on one machine.

After the update, the login manager does not start, and I can’t switch to a text console (e.g. Ctrl-Alt-F2 doesn’t work). I’ve tried several of the kernels installed on that machine (5.12, 5.11, 5.10 and 5.11 fallback), with no joy.

I know it has Intel graphics and a 4-core Intel processor, but since I can’t get in I don’t have other details. (It’s an old-style Zareason media station for what that’s worth).

I’ll try to find an install USB stick and try to boot it off that, and check the H/W.

On initial reboot, I had a similar issue with my primary machine (AMD/Radeon hardware) but after pressing reset it came up fine the second time.

Edit: nvm it was right there in the screenshot 🤦🏼

Additional information:

I rebooted with Linux kernel 5.4.114-1, and Thunar now mounts the partitions on my spare drive without errors.
Strange :roll_eyes:
After that, I rebooted with 5.10.32-1 again, and now the error has gone away. Didn’t change anything, apart from 2 reboots.
Should anybody have an idea: more than welcome. Will keep it “under further investigation” :sunglasses:

Now I can’t get the system running off the USB, comes up with the boot menu but just gives a black screen on booting. Even though it was working just fine for the update (and was booted for that so it seem unlikely to be a harware issue).
Running memtest anyway.