[Stable Update] 2021-04-28 - Kernels, Wine, Ruby, JDK, KDE-Dev, Mesa 21.0.3, KDE Apps 21.04, Python, Haskell, Mate 1.24.2, Virtualbox, Thunderbird

What do you mean, “Nah.”? I’m saying I preserved my MAKEFLAGS value, which says this: MAKEFLAGS="-j3"

I preserve my MAKEFLAGS value as well. Your preference is fine for whatever works best for you. Not being serious as you can tell by the emoji. :wink:

I meant, “Nah, I max out all my cores and queue the next job for when a core is available. Why would I only want to use three?”

1 Like

Oh, that makes more sense. I thought you were trying to say, “Nah, if you merged makepkg.conf.pacnew, which has this line that I’m showing you, it’ll use more than 3 threads, so good luck thinking that’ll work!”. Now I get you. Thanks for explaining.

1 Like

Having this issue with GNOME 40 after the update.

GDM no longer starts on it’s own. I need to press ctrl+alt+F2 to get to the terminal and then I can immediately switch back (w/o logging on the text login) and GDM will start normally. I was able to log in. This problem happens now on every boot of this install.

This is the first time in years I installed GNOME; used Manjaro from the iso. Today’s update was my first (large) update with it. Did not have this issue before. Basically I am saying this a fresh new GNOME 40 install + I am not familiar with new GNOME.

1 Like

I had to set KMS to start early to fix it for me.

A post was merged into an existing topic: [ARM Stable Update] 2021-04-27 - Firefox, KDE Frameworks, RPI Imager, Uboots and Kernels

…so far …everything is just okay with me :grin:

Why is (Kernel Mode Setting?) it not working now?

It worked fine before the update.

I always run sudo update-grub before startup to check if kernels are still there.

With this update the kernels where gone in grub. Manjaro settings was also gone from the app menu.

After reinstalling manjaro settings, I installed a non used kernel and that showed up after sudo update-grub.

After reboot I reinstalled the last LTS kernel, that was being used before reboot.

Thanks Manjaro team!

Has anybody experienced issues with cheese after the update? Video flickers just like if the app was working on a persistent burst mode or something …

Unfortunately, I’m not able to reproduce the issue anymore since I decided to roll back to my previous snapshot. There should be many journal entries related to cheese with a gstreamer error, if somebody is willing to reproduce it.

Just decided to step up and try the update again. :slightly_smiling_face:
This is what I get so far whenever I run cheese:

(cheese:1901): cheese-WARNING **: 13:16:10.322: Internal GStreamer error: code not implemented.  Please file a bug at https://gitlab.freedesktop.org/gstreamer/gstreamer/issues/new.: ../gst-plugins-base/gst-libs/gst/video/gstvideofilter.c(296): gst_video_filter_transform (): /GstCameraBin:camerabin/GstViewfinderBin:vf-bin/GstVideoConvert:vfbin-csp:
invalid video buffer received

My full inxi as per How to provide good information:

  Kernel: 5.11.16-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.11-x86_64 
  root=UUID=233a5452-b94a-4a1b-8c35-7f624aa41d2f rw apparmor=1 
  security=apparmor resume=UUID=4d80ab37-1d51-4a60-87b6-71ba1c774f85 
  udev.log_priority=3 systemd.unified_cgroup_hierarchy=true 
  Desktop: GNOME 3.38.4 tk: GTK 3.24.29 wm: gnome-shell dm: GDM 40.0 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: Dell product: Inspiron 7559 v: 1.3.1 serial: <filter> 
  Chassis: type: 10 serial: <filter> 
  Mobo: Dell model: 0H0CC0 v: A00 serial: <filter> UEFI: Dell v: 1.3.1 
  date: 12/02/2018 
  ID-1: BAT0 charge: 33.4 Wh (100.0%) condition: 33.4/74.0 Wh (45.1%) 
  volts: 12.5 min: 11.1 model: SDI Dell type: Li-ion serial: <filter> 
  status: Full 
  RAM: total: 15.5 GiB used: 2.27 GiB (14.7%) 
  Array-1: capacity: 16 GiB slots: 2 EC: None max-module-size: 8 GiB 
  note: est. 
  Device-1: ChannelA-DIMM0 size: 8 GiB speed: 1600 MT/s type: DDR3 
  detail: synchronous bus-width: 64 bits total: 64 bits 
  manufacturer: 019800000198 part-no: KN2M64-ETB serial: <filter> 
  Device-2: ChannelB-DIMM0 size: 8 GiB speed: 1600 MT/s type: DDR3 
  detail: synchronous bus-width: 64 bits total: 64 bits 
  manufacturer: 859B0000802C part-no: CT102464BF160B.M16 serial: <filter> 
  Info: Quad Core model: Intel Core i7-6700HQ socket: U3E1 bits: 64 
  type: MT MCP arch: Skylake-S family: 6 model-id: 5E (94) stepping: 3 
  microcode: E2 cache: L1: 256 KiB L2: 6 MiB L3: 6 MiB bogomips: 41621 
  Speed: 800 MHz min/max: 800/3500 MHz base/boost: 2500/3500 volts: 0.9 V 
  ext-clock: 100 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 
  6: 800 7: 800 8: 800 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art 
  avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid 
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est 
  f16c flexpriority flush_l1d fma fpu fsgsbase fxsr hle ht hwp hwp_act_window 
  hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm 
  mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat 
  pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts 
  rdrand rdseed rdtscp rep_good rtm sdbg sep smap smep ss ssbd sse sse2 sse4_1 
  sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
  tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt 
  xsaves xtopology xtpr 
  Device-1: Intel HD Graphics 530 vendor: Dell driver: i915 v: kernel 
  bus-ID: 00:02.0 chip-ID: 8086:191b class-ID: 0300 
  Device-2: NVIDIA GM107M [GeForce GTX 960M] vendor: Dell driver: nvidia 
  v: 460.73.01 alternate: nouveau,nvidia_drm bus-ID: 02:00.0 
  chip-ID: 10de:139b class-ID: 0302 
  Device-3: Sunplus Innovation Integrated_Webcam_HD type: USB driver: uvcvideo 
  bus-ID: 1-4:2 chip-ID: 1bcf:28b0 class-ID: 0e02 
  Display: server: X.Org 1.20.11 compositor: gnome-shell driver: 
  loaded: modesetting,nvidia alternate: fbdev,intel,nouveau,nv,vesa 
  display-ID: :1 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6") 
  diag: 395mm (15.5") 
  OpenGL: renderer: Mesa Intel HD Graphics 530 (SKL GT2) v: 4.6 Mesa 21.0.3 
  direct render: Yes 
  Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: Dell 
  driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a170 
  class-ID: 0403 
  Sound Server-1: ALSA v: k5.11.16-2-MANJARO running: yes 
  Sound Server-2: sndio v: N/A running: no 
  Sound Server-3: JACK v: 0.125.0 running: no 
  Sound Server-4: PulseAudio v: 14.2 running: yes 
  Sound Server-5: PipeWire v: 0.3.26 running: yes 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Dell driver: r8169 v: kernel port: d000 bus-ID: 04:00.0 
  chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp4s0 state: down mac: <filter> 
  Device-2: Intel Wireless 3165 driver: iwlwifi v: kernel port: d000 
  bus-ID: 05:00.0 chip-ID: 8086:3165 class-ID: 0280 
  IF: wlp5s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  IF-ID-1: virbr0 state: down mac: <filter> 
  IP v4: <filter> scope: global broadcast: <filter> 
  WAN IP: <filter> 
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 
  bus-ID: 1-5:3 chip-ID: 8087:0a2a class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends 
  Message: No logical block device data found. 
  Message: No RAID data found. 
  Local Storage: total: 465.76 GiB used: 66.73 GiB (14.3%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital 
  model: WDS500G2B0A-00SM50 size: 465.76 GiB block-size: physical: 512 B 
  logical: 512 B speed: 6.0 Gb/s rotation: SSD serial: <filter> rev: 00WD 
  scheme: GPT 
  Message: No optical or floppy data found. 
  ID-1: / raw-size: 64 GiB size: 63.97 GiB (99.95%) used: 27.33 GiB (42.7%) 
  fs: xfs block-size: 512 B dev: /dev/sda7 maj-min: 8:7 label: N/A 
  uuid: 233a5452-b94a-4a1b-8c35-7f624aa41d2f 
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%) 
  used: 332 KiB (0.1%) fs: vfat block-size: 512 B dev: /dev/sda5 maj-min: 8:5 
  label: N/A uuid: B5F2-85E9 
  ID-3: /home raw-size: 96 GiB size: 95.97 GiB (99.97%) used: 39.4 GiB (41.1%) 
  fs: xfs block-size: 512 B dev: /dev/sda8 maj-min: 8:8 label: N/A 
  uuid: eace5e8f-f159-44f1-8de3-51f301d3bb18 
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 16 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda6 maj-min: 8:6 label: N/A 
  uuid: 4d80ab37-1d51-4a60-87b6-71ba1c774f85 
  ID-1: /dev/sda1 maj-min: 8:1 size: 100 MiB fs: vfat label: N/A 
  uuid: 7A39-12B5 
  ID-2: /dev/sda10 maj-min: 8:10 size: 16 GiB fs: ext label: N/A uuid: N/A 
  ID-3: /dev/sda2 maj-min: 8:2 size: 16 MiB fs: N/A label: N/A uuid: N/A 
  ID-4: /dev/sda3 maj-min: 8:3 size: 127.4 GiB fs: ntfs label: N/A 
  uuid: 1EB23F81B23F5C89 
  ID-5: /dev/sda4 maj-min: 8:4 size: 499 MiB fs: ntfs label: N/A 
  uuid: FEFE90DDFE90900F 
  ID-6: /dev/sda9 maj-min: 8:9 size: 144 GiB fs: fat (12 bit) label: N/A 
  uuid: N/A 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 1-4:2 info: Sunplus Innovation Integrated_Webcam_HD type: Video 
  driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA 
  chip-ID: 1bcf:28b0 class-ID: 0e02 
  Device-2: 1-5:3 info: Intel Bluetooth wireless interface type: Bluetooth 
  driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA 
  chip-ID: 8087:0a2a class-ID: e001 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 8 rev: 3.0 speed: 5 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  System Temperatures: cpu: 60.0 C mobo: 29.8 C sodimm: SODIMM C 
  Fan Speeds (RPM): cpu: 0 
  Processes: 257 Uptime: 15m wakeups: 1 Init: systemd v: 247 tool: systemctl 
  Compilers: gcc: 10.2.0 Packages: 1441 pacman: 1427 lib: 419 flatpak: 11 
  snap: 3 Shell: Zsh (sudo) v: 5.8 default: Bash v: 5.1.0 running-in: kitty 
  inxi: 3.3.04

Same thing happens if I switch to kernel 5.10.32.
If I test with another webcam enabled app such as Skype, the video output works fine.

Any ideas on how to proceed with this?
I know this issue is not a big deal but IMO, you don’t expect minor things like that to happen in a Stable Release.


Issue Resolved.
Downgraded pipewire and pipewire-media-session to version 0.3.25-1

With this last update I noticed an improvements in ram usage at start on Manjaro XFCE. Before I had 700/800 mb of ram used and now around 500mb. Nice. :slight_smile:

No issues with cheese on my side

The firmware seems to be missing in the kernel tree: Kernel 5.11 warning about qat_4xxx firmware / Kernel & Hardware / Arch Linux Forums for more info. It’s the same for kernel 5.12. But it seems not to be a problem.

The update went smooth, except for one small, but very annoying issue – KDE PIM stopped working.

KMail spins up, but it won’t sync or send mail anymore, claiming IMAP and MailDir are broken.

Similarly, KOrganizer, Zanshin and KAddressBook all “work in general”, but their resources are offline.

I just checked Akonadi Console and all resources (even local ones) have:

  • status: Offline, Broken
  • status message: Unable to start.

I tried to restart Akonadi, even rebooted, but the problem persists.

Wait until Manjaro-Team Fix it. On a vanilla Arch Kernel you get some more firmware warnings.

Smooth update, the only thing I’ve noticed is that when clicking on Show Applications (GNOME) the number of columns of the application grid changed from 6 to 7. This was an issue because the first row was below my application dock (in the left side of the screen).

This might be in preparation for GNOME40, however I don’t want it, and the fix in this case is installing App Grid Tweaks (GNOME extension) and changing the amount of rows and columns manually.

Update ran on my Raspberry Pi 4 but now X only runs for about 30 seconds then my monitor looses the signal and goes to sleep. Both xfce and i3 experience the same problem. If I’m quick I can login but makes no difference. Now stuck using tty console only.

Some issues to report from me:

  1. There’s still an issue with resume from suspend and amdgpu at least on some Renoir (Ryzen 4xxx) systems, leading to the system hanging up when resuming from suspend. It works on 5.11.6 and it seems to work again on 5.10.32 (5.10 was affected for some subversions, too), but neither 5.11.16 nor 5.12.0 work, so I went back to 5.11.6 again.
    See my topic about this:
  1. After installing kernel 5.10.32, I checked whether it worked and it did. I then installed 5.12. When I rebooted into 5.11.6, I got an error message (“Failed to load Kernel modules…” or similar) and was thrown into fallback mode. I then installed 5.11.16 (which has the suspend bug) and rebooted into 5.10.32 after checking 5.11.16 - now 5.10.32 gave the same warning.
    Currently I’m on 5.11.6 again after downgrading.

try installing gdm-git instead from the AUR