[Stable Update] 2021-05-06 - Kernels, Mesa, VirtualBox, LxQt 0.17, Deepin, Gnome Apps 40.1

Thank you! (Also thank you servimo for your reply)

Update went fine :+1:


No problem

  • I have dualboot and os-prober was also not affected


T+ = See you later

It’s now fixed.


fine for me, try reinstalling your application

Can confirm,looks like the Arch Linux package has a bug,it was already filled here FS#70624 : [telegram-desktop] telegram-desktop segfaults when attempting to record audio

If you use the official package from desktop.telegram.org you can record audio without problems.

1 Like

This update fixed the “blank screen before desktop” issue introduced in previous update for me - [Stable Update] 2021-04-28 - Kernels, Wine, Ruby, JDK, KDE-Dev, Mesa 21.0.3, KDE Apps 21.04, Python, Haskell, Mate 1.24.2, Virtualbox, Thunderbird - #47 by toxpal

1 Like

The update

python-decorator              4.4.2-4              5.0.7-1

breaks application spyder for me.

$ spyder                                        
Traceback (most recent call last):
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 568, in _build_master
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 886, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 777, in resolve
    raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.ContextualVersionConflict: (decorator 5.0.7 (/usr/lib/python3.9/site-packages), Requirement.parse('decorator<5'), {'spyder-kernels'})

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/bin/spyder", line 33, in <module>
    sys.exit(load_entry_point('spyder==5.0.0', 'gui_scripts', 'spyder')())
  File "/usr/bin/spyder", line 25, in importlib_load_entry_point
    return next(matches).load()
  File "/usr/lib/python3.9/importlib/metadata.py", line 77, in load
    module = import_module(match.group('module'))
  File "/usr/lib/python3.9/importlib/__init__.py", line 127, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 1030, in _gcd_import
  File "<frozen importlib._bootstrap>", line 1007, in _find_and_load
  File "<frozen importlib._bootstrap>", line 986, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 680, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 790, in exec_module
  File "<frozen importlib._bootstrap>", line 228, in _call_with_frames_removed
  File "/usr/lib/python3.9/site-packages/spyder/app/start.py", line 34, in <module>
    from spyder.utils.external import lockfile
  File "/usr/lib/python3.9/site-packages/spyder/utils/external/lockfile.py", line 31, in <module>
    from spyder.utils.programs import is_spyder_process
  File "/usr/lib/python3.9/site-packages/spyder/utils/programs.py", line 29, in <module>
    import pkg_resources
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 3243, in <module>
    def _initialize_master_working_set():
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 3226, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 3255, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 570, in _build_master
    return cls._build_from_requirements(__requires__)
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 583, in _build_from_requirements
    dists = ws.resolve(reqs, Environment())
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 772, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'decorator<5' distribution was not found and is required by spyder-kernels

I’m investigating

Edit: Seems I’m screwed, see in Spyder code the comment on line 40:

Don’t know how to solve “magic” code.

I keep getting this error

error: mesa: signature from "Laurent Carlier <lordheavym@gmail.com>" is invalid
:: File /var/cache/pacman/pkg/mesa-21.0.3-3-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] 
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.

How do I fix this?

1 Like

See here @SmiteshP


See here @phippu


First, I did say yes to remove python2-twisted…

looking for conflicting packages...
:: python-twisted and python2-twisted are in conflict.
   Remove python2-twisted? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: installing nvidia-utils (460.73.01-1) breaks dependency
   'nvidia-utils=460.56' required by linux59-nvidia
:: removing python2-twisted breaks dependency 'python2-twisted'
   required by python2-incremental

Second, I said no the the question

looking for conflicting packages...
:: python-twisted and python2-twisted are in conflict.
   Remove python2-twisted? [y/N] n
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: python-twisted and python2-twisted are in conflict

Here’s my hardware info:

System:    Host: sphere-0 Kernel: 5.10.23-1-MANJARO x86_64 bits: 64 Desktop: Xfce 4.16.0 Distro: Manjaro Linux 
Machine:   Type: Laptop System: LENOVO product: Lenovo IdeaPad Y480 v: Lenovo IdeaPad Y480 serial: <superuser required> 
           Mobo: LENOVO model: Product Name v: Mainboard version serial: <superuser required> UEFI: LENOVO v: 5DCN34WW(V1.11) 
           date: 03/22/2012 
Battery:   ID-1: BAT1 charge: 3.2 Wh (59.3%) condition: 5.4/5.8 Wh (93.2%) 
CPU:       Info: Quad Core model: Intel Core i7-3610QM bits: 64 type: MT MCP cache: L2: 6 MiB 
           Speed: 1197 MHz min/max: 1200/3200 MHz Core speeds (MHz): 1: 1197 2: 1210 3: 1197 4: 1199 5: 1197 6: 1196 7: 1197 
           8: 1199 
Graphics:  Device-1: Intel 3rd Gen Core processor Graphics driver: i915 v: kernel 
           Device-2: NVIDIA GF108M [GeForce GT 620M/630M/635M/640M LE] driver: N/A 
           Device-3: Acer Lenovo EasyCamera type: USB driver: uvcvideo 
           Display: x11 server: X.Org 1.20.10 driver: loaded: modesetting unloaded: intel resolution: 1366x768~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2) v: 4.2 Mesa 20.3.4 
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio driver: snd_hda_intel 
           Device-2: NVIDIA GF108 High Definition Audio driver: snd_hda_intel 
           Sound Server-1: ALSA v: k5.10.23-1-MANJARO running: yes 
           Sound Server-2: PulseAudio v: 14.2 running: yes 
Network:   Device-1: Qualcomm Atheros AR8161 Gigabit Ethernet driver: alx 
           IF: enp2s0 state: down mac: dc:0e:a1:e5:e7:cd 
           Device-2: Qualcomm Atheros AR9285 Wireless Network Adapter driver: ath9k 
           IF: wlp3s0 state: up mac: 44:6d:57:41:59:59 
Bluetooth: Device-1: Qualcomm Atheros AR3011 Bluetooth type: USB driver: btusb 
           Report: This feature requires one of these tools: hciconfig/bt-adapter 
Drives:    Local Storage: total: 931.51 GiB used: 819.72 GiB (88.0%) 
           ID-1: /dev/sda vendor: Western Digital model: WD10JPVX-00JC3T0 size: 931.51 GiB 
Partition: ID-1: / size: 57.55 GiB used: 54.88 GiB (95.4%) fs: ext4 dev: /dev/sda2 
           ID-2: /boot/efi size: 499.7 MiB used: 640 KiB (0.1%) fs: vfat dev: /dev/sda1 
Swap:      ID-1: swap-1 type: partition size: 15.63 GiB used: 853.2 MiB (5.3%) dev: /dev/sda9 
Sensors:   System Temperatures: cpu: 59.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 250 Uptime: 3d 19h 51m Memory: 7.67 GiB used: 2.92 GiB (38.1%) Shell: Bash inxi: 3.3.03 

Xfce version here with legacy 340xx NVIDIA drivers.
After the latest update I have screen tearing even with compositor off.

Refreshing the keys didn’t work for me, but manually downloading and then the pacman -U command worked fine. After that the regular update went fine :smile:

You did rebuild those after kernel update?

Budgie desktop 10.5.3 soon?

After installing them using this guide it does this automatically with each update.

Uninstalling nvidia drivers (back to Nouveau) solved the problem. Maybe the 340.108 no longer get along with the latest updates like that of Mesa.

1 Like

I see, thanks for letting me know! Will subscribe there to see if I can contribute at some point.

Remove whatever package requires those packages, then run the update again.


After the latest stable update, I’m having this problem with my Activities function in Gnome. It wasn’t happening to me before the update. In the thread they point at dash to dock as the possible cause, so I’ll try disabling it for a while and see if the problem persists.

Gnome, 5.4, Intel

Evolution, terminal, virtualbox, timeshift so far will not open. Brave opens, chrome opens, pamac opens.