[Stable Update] 2021-04-18 - Kernels, Mesa, Wine, Plasma5, KDE Frameworks, LibreOffice, Bluez

Update has fixed Gnome WiFi menu from shell freeze and has also fixed nautilus root access problem. Thanks to the developers. Hoping to see Gnome 40 shell soon.

No newer problems have yet been discovered in my setup.

1 Like

here is such a nuisance appeared by itself

No issues with this update beyond the ones i already had with Mesa and Wine in the previous update, i have a very old Nvidia GPU, maybe that’s the cause.

All good with the update but I still have this bug with Pipewire, if a few people could test DP/HDMI audio:

Yes you can. Is a quirk in pacman-mirrors it seems. @linux-aarhus

1 Like

There is no splash to remove. I tried putting splash in, rebooted, still blank screen. Went back and then removed splash, now it works. Weird.

Well, it worked for a while then it’s back to blank.

That’s fixed with 1.48.0+13+gc615cfe1-1 which is now available on all branches. Did you reboot after updating?

My mesa packages don’t seem to have updated properly?
Below is the result of pacman -Q | grep mesa

lib32-libva-mesa-driver 21.0.2-1
lib32-mesa 21.0.2-1
lib32-mesa-demos 8.4.0-2
lib32-mesa-vdpau 21.0.2-1
lib32-vulkan-mesa-layers 21.0.2-1
libva-mesa-driver 21.0.1-1.0
mesa 21.0.1-1.0
mesa-demos 8.4.0-4
mesa-vdpau 21.0.1-1.0
vulkan-mesa-layers 21.0.1-1.0
1 Like

Did tty updating tested apps everything went fine except one small python was missed just letting you know that Gimp still works fine

Thanks for the Operating System it is Very Good

Ran the update and I am stuck at “Running post-transaction hooks…” 9/26 with grub-mkconfig. When looking at ps -A | grep grub I can see that grub-mkconfig is defunct. I am just not sure how to continue from this point. Do I reboot and deal with any fallout? Do I kill the pamac gui and try from the cli? Just not sure.

Everything went fine.
expect whenever I open code-oss it flashes the screen.

I think there is a problem with GDM. It stucks on Dell logo for me. Switch to terminal (Ctrl + Alt + F2) and issuing startx command is the way to start gnome. Removinng quiet splash from grub cmdline also helps.

1 Like

Usually an issue with KMS not being ready before the graphics server tries to start, enable early KMS for your kernel driver, i.e. amdgpu for the amd systems, and nvidia and nvidia_drm for the prop nvidia driver (arch forum)


Thanks a lot. That does also work for me.

I did some “tests” (with VLC and mplayer) and the VDPAU output seems not to work in both programs.

Modify /etc/default/grub and then use the command:

sudo grub-mkconfig -o /boot/grub/grub.cfg

I can confirm, I also have mesa 21.0.1-1 installed after this update.

Updating too this release now

I noticed that the gnome dash is now transparent and the upper’s bar selected “backlight” has been changed. May I ask what settings have been tweaked since last update, so I can restore it to the previous look?

The update went fine and mostly without any problem in my Manjaro-Gnome setup. In my case Kvantum is showing problems in setting up dark themes. I tried Qogir and Matchama dark variants. Both had problems.

Some texts in the settings are not clear.

Mostly good, just one unexpeted thing: I got most of the update yesterday (18th) but the mesa ones came in one day later this morning (except lib32 version of mesa). Is this normal?