Audio/video stops and resumes since [Stable Update] 2021-04-18


since [Stable Update] 2021-04-18 and kernel 5.11 I was getting sporadic audio crackling and video artifacts while playing video, [Stable Update] 2021-04-28/kernel 5.12 did not solve it: Now the audio/video pauses and after a few moments, it continues. It does not matter if it’s a youtube video in firefox or a video played from local hdd or smb network in mpv or vlc: the video+audio randomly stops, comes back after a few moments, audio is shortly crackling on resume and then it continues playing for a while until this repeats. Also, there is an occasionall faint single “tick” sound on my speakers when there is nothing playing.

After looking at PulseAudio/Troubleshooting - ArchWiki
I tried removing load-module module-udev-detect tsched=0 from /etc/pulse/
and also set

default-fragments = 5
default-fragment-size-msec = 2

in /etc/pulse/daemon.conf but it did not help either.

Since video is also affected, it might be something different, perhaps mesa 21 idk.

In System Setting - Compositor, there was an error message (possibly been there for some time):

OpenGL compositor (the default) has crashed KWin in the past. This was most likely to a driver bug. If you think that you have meanwhile upgraded to a stable driver, you can reset this protection but be aware that this might result in an immediate crash! Alternatively, you might want to use the XRender backend instead.

I re-enabled OpenGL detection but it did not help.

Rendering backend was set to “OpenGL 2.1”, but switching to 3.1 did not help either.


Kernel: 5.12.0-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0
parameters: BOOT_IMAGE=/boot/vmlinuz-5.12-x86_64
root=UUID=87961569-5974-4c86-8245-4556d8be49e5 rw quiet apparmor=1
security=apparmor udev.log_priority=3
Desktop: KDE Plasma 5.21.4 tk: Qt 5.15.2 wm: kwin_x11 vt: 2 dm: SDDM
Distro: Manjaro Linux base: Arch Linux
Type: Desktop System: Gigabyte product: N/A v: N/A serial: Chassis:
type: 3 serial:
Mobo: Gigabyte model: X79-UD3 v: x.x serial:
UEFI: American Megatrends v: F20 date: 03/19/2014

Device-1: AMD Cape Verde XT [Radeon HD 7770/8760 / R7 250X] vendor: ASUSTeK
driver: radeon v: kernel alternate: amdgpu bus-ID: 02:00.0
chip-ID: 1002:683d class-ID: 0300
Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver:
loaded: ati,radeon unloaded: modesetting alternate: fbdev,vesa
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1200 s-dpi: 96 s-size: 508x317mm (20.0x12.5")
s-diag: 599mm (23.6")
Monitor-1: DVI-0 res: 1920x1200 hz: 60 dpi: 82 size: 593x371mm (23.3x14.6")
diag: 699mm (27.5")
OpenGL: renderer: AMD VERDE (DRM 2.50.0 5.12.0-1-MANJARO LLVM 11.1.0)
v: 4.5 Mesa 21.0.3 direct render: Yes
Device-1: Intel C600/X79 series High Definition Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1d20
class-ID: 0403
Device-2: AMD Oland/Hainan/Cape Verde/Pitcairn HDMI Audio [Radeon HD 7000
vendor: ASUSTeK driver: snd_hda_intel v: kernel bus-ID: 02:00.1
chip-ID: 1002:aab0 class-ID: 0403
Sound Server-1: ALSA v: k5.12.0-1-MANJARO running: yes
Sound Server-2: sndio v: N/A running: no
Sound Server-3: JACK v: 1.9.18 running: no
Sound Server-4: PulseAudio v: 14.2 running: yes
Sound Server-5: PipeWire v: 0.3.26 running: yes

Please help.

Hello Anthony
A Few suggestion to try out if you want to , in this way you remove a lot of question of why and what
Create and log in as a different user , this eliminates or confirms if its just that user (you) or the fresh user also _ _ then
Try a live session to see if it’s happening there

I had massive audio problems about a year ago and an incessant break in the music that was playing only for a split instance sometimes very often other times only every few minutes just a ‘drop’ a few seconds later or minutes later ‘drop’ ‘drop’ ‘drop’ tried every suggestion that came in this went on over many weeks,
then running Htop found that the WiFi was working overtime and there was no let up if it was switched ON or OFF , yes even when modem was switched off the computer was running processes for the WiFi modem ( check item 4 )
took the offending machine (this one) to someone that I know who is very patient and loves a Linux challenge ( his day job is fixing Windoze machines ) and that solution was a cable connected from the modem to the computer , ha how simple , and since then it has behaved.

1.create and log in as new user

2.try a live session Htop and find if something is using all the power , run this several times with different apps running and also when completely Idle nothing running _ not even screensaver,

4.connect to modem via cable and modem installed ( and if found to work remove the WiFi apps on the computer ) and change the settings in both computer and setting in modem to not use the WiFi otherwise the machine and modem ‘should not but could’ revert back to kicking in the WiFi gear back in , peace of mind.
also helps security side.

If I remember more will let you know
Hope this helps even in a small way .

Doesn’t hurt to reboot after making changes , just a habit I got into is if
Make important changes then reboot .

I suspect this is because you have both PulseAudio and Pipewire running

Sound Server-4: PulseAudio v: 14.2 running: yes
Sound Server-5: PipeWire v: 0.3.26 running: yes

Pipewire does not work correctly unless it has some additional dependency packages installed, which requires removal of PulseAudio packages

Pipewire can be uninstalled from Xfce, but it is now a required dependency for KDE

The systemd socket and service can be disabled to prevent Pipewire interfering with PulseAudio

systemctl --user mask --now pipewire.socket && systemctl --user stop pipewire.service

If it is one click about 2 seconds after audio stops playing that is likely to be from a PulseAudio module suspending power to an idle audio device

Use this command to remove the module temporarily

pacmd unload-module module-suspend-on-idle

If this works to prevent the click noise (by not suspending the audio device) the module can be permanently disabled in PulseAudio configuration with this command

sudo sed -i '/load-module module-suspend-on-idle/s/^/#/' /etc/pulse/

Thank you for your suggestions!

  1. As the fresh user, the pauses and crackling are gone, but the sporadic tick is still present
  2. not tried yet
  3. no task is using a significant amount of cpu
  4. I’m not using wifi

Now the question is, what settings are shared between both users?
Did deactivating pipewire in the primary user account affect the new account or was it not enabled by default?

Thank you for your suggestions!

After executing this command, it seems like the pauses are shorter and the crackling is less pronounced.
But I think that PulseAudio and Pipewire have both been active without problem before the last two Manjaro upgrades. Testing on another Manjaro machine showed both are active and there is no audio issue, perhaps it is necessary depending on hardware.

The tick comes minutes after closing a video, even if audio is muted.

Why do we need so many audio servers?

A few things here if PulseAudio and Pipewire are in conflict with each other then I guess you know which one has to go ,

The above suggestion from nikgnomic would be the thing next on the to do list, it could rid you of the the pauses and the crackling sounds ,

and then

the tick is not affecting the performance of audio and video that could be from a later update that changed another thing in causing one or both PulseAudio and/or Pipewire and the speakers to power off

the speakers powering off will give that tick sound even when muted at the panel (does here )
and fixing the pauses and the crackling is the problem to go for

I already deactivated pipewire, sorry if this was not clear.

So should I / can I remove Pulse Audio and reactivate pipewire?
While searching for the topmost package to remove, I found that although pulse and pipewire are both installed, only manjaro-pulse is installed, as manjaro-pipewire would be conflicting.

But after the first couple of clicks, there was another one after some time without any audio output in between and after some time another tick and so on, e.g. while reading the forum.

Just from my own hassles with disrupted sounds ( um on other distros )
that is why I am Here
I found that when I can fix the major problem in your case the play pauses and the crackling sounds then Tux may will fix the smaller problem(s) tick sounds in your case,
yep focus on the big problem not the most irritating part of the problem,

is that same as

keep working on it and good luck