[Stable Update] 2021-02-09 - Kernels, Gnome 40-Alpha, KDE Apps 20.12.2, Systemd, Mesa, LibreOffice

Easy peasy lemon squeezy! Updated 4 laptops and 2 PCs with Intel and AMD video, Cinnamon DE, kernel 5.10, all via TTY. Everything’s hunky dory!

Is there a safe way to replace pulseaudio with pipewire in this update?

2 Likes

I had a problem with this update. This is the error message:

no se pudieron satisfacer las dependencias:
- incapaz de satisfacer la dependencia "fluidsynth=2.1.7" requerida por lib32-fluidsynth
- incapaz de satisfacer la dependencia "libinstpatch=1.1.6" requerida por lib32-libinstpatch
- incapaz de satisfacer la dependencia "libinstpatch=1.1.6" requerida por lib32-libinstpatch
- incapaz de satisfacer la dependencia "libplacebo.so=104-64" requerida por mpv

What should I do to fix it? :sleepy:

EDIT 2: I reinstalled libplacebo and I deleted MPV. But the problem persists…

no se pudieron satisfacer las dependencias:
- incapaz de satisfacer la dependencia "fluidsynth=2.1.7" requerida por lib32-fluidsynth
- incapaz de satisfacer la dependencia "libinstpatch=1.1.6" requerida por lib32-libinstpatch
- incapaz de satisfacer la dependencia "libinstpatch=1.1.6" requerida por lib32-libinstpatch

GNOME - Update went smoothly but GNOME Terminal won’t launch. I follow the guide from @Felukah and it worked. Just I had to remove (not do) step 3.

The new Papirus icons are UGLY (especially the Nautilus and Terminal ones)! Massive let down for me.

Also Telegram seems to have bugged shadow - white border / outline around the application.

3 Likes

I did, and it worked fine

Andreas

1 Like

This update fixed my WiFi problem :wink:

2 Likes

gnome-terminal isn’t starting. removed and reinstalled it from pamac. Not working. Any solution?
EDIT: FIX -
install “xterm” from pamac.
edit /etc/locale.gen.
uncomment - en_US.UTF8
Then run: sudo locale-gen from xterm

1 Like

Something funky with locale indeed, I have en_US.UTF-8 & nl_NL.UTF-8 installed.

For some reason after glibc update this happens:

Upgrading glibc (2.32-5 -> 2.33-3)...
Generating locales...
  de_DE.UTF-8... done
  en_US.UTF-8... done
Generation complete.
Upgrading gcc-libs (10.2.0-4 -> 10.2.0-6)...

Then further down:

  -> Running build hook: [keymap]
/etc/locale.conf: line 2: warning: setlocale: LC_NUMERIC: cannot change locale (nl_NL.UTF-8)
/etc/locale.conf: line 3: warning: setlocale: LC_TIME: cannot change locale (nl_NL.UTF-8)
  -> Running build hook: [plymouth]
$ cat /etc/locale.conf
LANG=en_US.utf8
LC_NUMERIC=nl_NL.UTF-8
LC_TIME=nl_NL.UTF-8
LC_COLLATE=C
LC_MONETARY=nl_NL.UTF-8
LC_PAPER=nl_NL.UTF-8
LC_MEASUREMENT=nl_NL.UTF-8

changing de_DE.UTF-8 to #de_DE.UTF-8 and #nl_NL.UTF-8 to nl_NL.UTF-8 in /etc/locale.gen & running $ sudo locale-gen solves this issue.

This seems wrong tho:

$ cat /etc/locale.conf
LANG=en_US.utf8
2 Likes

Have any pacnew files for virtmanager? I saw some go past in this update and actively processing them now.

Edit: skipped all pacnewfiles and have working QEMU/KVM virtuals
For reference, these are the ones I have as pacnew
==> pacnew file found for /etc/libvirt/nwfilter/allow-dhcp-server.xml
==> pacnew file found for /etc/libvirt/nwfilter/allow-dhcp.xml
==> pacnew file found for /etc/libvirt/qemu/networks/default.xml

Made a note to look up what to do with them this weekend.

2 Likes

Hi, thank you for all this.
Globally smooth but as I use PulseEffects, I discovered a partial implementation of PipeWire.
I didn’t want to go to pulseeffects-legacy, thus had to:

[2021-02-09T20:18:59+0100] [ALPM] installed gnome-settings-daemon (3.38.1-1)
[2021-02-09T20:16:54+0100] [ALPM] installed sof-firmware (1.6.1-1)
[2021-02-09T20:16:27+0100] [ALPM] installed libgweather (3.36.1-1)
[2021-02-09T20:15:26+0100] [ALPM] installed lib32-fluidsynth (2.1.7-1)
[2021-02-09T20:15:26+0100] [ALPM] installed lib32-sdl2 (2.0.14-1)
[2021-02-09T20:15:26+0100] [ALPM] installed lib32-libpulse (14.2-2)
[2021-02-09T20:15:26+0100] [ALPM] installed lib32-libasyncns (0.8+3+g68cd5af-2)
[2021-02-09T20:15:26+0100] [ALPM] installed lib32-libinstpatch (1.1.6-1)
[2021-02-09T20:12:38+0100] [ALPM] installed lib32-portaudio (1:19.6.0-4)
[2021-02-09T19:56:37+0100] [ALPM] installed gst-plugin-pipewire (1:0.3.21-1)
[2021-02-09T19:56:37+0100] [ALPM] installed manjaro-pipewire (20210109-1)
[2021-02-09T19:56:37+0100] [ALPM] installed pipewire-jack (1:0.3.21-1)
[2021-02-09T19:56:37+0100] [ALPM] installed pipewire-alsa (1:0.3.21-1)
[2021-02-09T19:56:37+0100] [ALPM] installed wireplumber (0.3.0-1)
[2021-02-09T19:56:37+0100] [ALPM] installed libpipewire02 (0.2.7-1)
[2021-02-09T19:56:37+0100] [ALPM] installed pipewire-pulse (1:0.3.21-1)
[2021-02-09T19:54:57+0100] [ALPM] removed pulseaudio (14.2-2)
[2021-02-09T19:54:57+0100] [ALPM] removed pulseaudio-alsa (1:1.2.2-2)
[2021-02-09T19:54:57+0100] [ALPM] removed libgweather (3.36.1-1)
[2021-02-09T19:54:56+0100] [ALPM] removed gnome-settings-daemon (3.38.1-1)
[2021-02-09T19:54:53+0100] [ALPM] removed eolie (0.9.101-1)
[2021-02-09T19:54:52+0100] [ALPM] removed pulseaudio-bluetooth (14.2-2)
[2021-02-09T19:54:52+0100] [ALPM] removed xfce4-pulseaudio-plugin (0.4.3-1.1)
[2021-02-09T19:54:51+0100] [ALPM] removed pulseaudio-ctl (1.67-1)
[2021-02-09T19:54:51+0100] [ALPM] removed pulseaudio-zeroconf (14.2-2)
[2021-02-09T19:54:51+0100] [ALPM] removed sof-firmware (1.6.1-1)
[2021-02-09T19:54:51+0100] [ALPM] removed pavucontrol (1:4.0-2)
[2021-02-09T19:54:50+0100] [ALPM] removed pulseaudio-lirc (14.2-2)
[2021-02-09T19:54:50+0100] [ALPM] removed lib32-libinstpatch (1.1.6-1)
[2021-02-09T19:54:50+0100] [ALPM] removed lib32-libasyncns (0.8+3+g68cd5af-2)
[2021-02-09T19:54:50+0100] [ALPM] removed lib32-libpulse (14.2-2)
[2021-02-09T19:54:50+0100] [ALPM] removed lib32-libcanberra-pulse (0.30+2+gc0620e4-3)
[2021-02-09T19:54:50+0100] [ALPM] removed pulseaudio-equalizer (14.2-2)
[2021-02-09T19:54:50+0100] [ALPM] removed pulseaudio-jack (14.2-2)
[2021-02-09T19:54:50+0100] [ALPM] removed lib32-sdl2 (2.0.14-1)
[2021-02-09T19:54:50+0100] [ALPM] removed lib32-portaudio (1:19.6.0-4)
[2021-02-09T19:54:50+0100] [ALPM] removed lib32-fluidsynth (2.1.7-1)
[2021-02-09T19:54:50+0100] [ALPM] removed pulseaudio-rtp (14.2-2)
[2021-02-09T19:54:50+0100] [ALPM] removed manjaro-pulse (20210109-1)
[2021-02-09T19:54:50+0100] [ALPM] removed xfce4-volumed-pulse (0.2.3-1)

As you can see is was sloppy.

Would have been better if informed or scripted ! :grimacing:

2 Likes

Does the talk about pulseaudio mean that it’s become outdated generally and we should replace it with something else? Or is this just about pulseeffects?

I mean I have pulseaudio installed, but not pulseeffects and not pipewire.

1 Like

Is there a reason for downgrading VIVALDI ?
Yesterday we got V3.6.2165.36-1. (SAFETY )
And now .34.
Testing and unstable are still at .36.
Vivaldi Homepage too.
Edit: stable-staging is still at .34. Maybe copy old over new version?
stable-staging feels often a little bit forgotten …

This update made OpenShot from the official repo work much better, thanks! :grin: :clap:

No issues found running Cinnamon and the 5.10 kernel

Gnome, Update:
All German language files are gone - everything is now English again (bevor was german). In the settings, no languages are displayed at all anymore.
Telegram also starts in English again and the chat background is default again.
After the installation of Gnome, about three weeks ago, the system constantly hung or froze. After deleting a few extensions, it suddenly worked.
I thought I’d look for another distro - but stayed after the crashes stopped. Now this…

Thanks for the update and the :heart: work!

Got it working. Removed Scale Display setting. Changed Video driver to virtio and 3d. Also made a few modifications on Display Spice… Type: Spice Server, Listen Type: None, and OpenGL to Auto. Hope this helps someone.

1 Like

Your german locale ended up on my machine :crazy_face:

  • Go to Manjaro Settings,
  • Add your language back in the regional settings,
  • Log off / log in

should solve it

All good on my end, except for the well-known issue “Gnome Terminal won’t load after update”.
FIXED: Sometimes the updates overwrite the locale settings and need to be regenerated.

Once again, thanks Manjaro team for another great rollout! :+1: :slightly_smiling_face:

Danke, Du hast mich eben davor bewahrt, GNOME zu installieren …

Thanks, you just saved me from installing GNOME …

Somehow the stable snap kicked out .36 that I had pushed.
(╯°□°)╯︵ ┻━┻

I just pushed it to stable again.
┬─┬ノ( º _ ºノ)

4 Likes