[Stable Update] 2020-12-30 - Kernels, KDE, Cinnamon, LibreOffice, Python 3.9, Mesa 20.3.1

Nice update on Gnome with linux54.

Thanks for the tip for the problem with shutdown delay, it’s work.


No problem to update Manjaro. But since I switched to the β€œsimplified” nvidia configuration, I have no more mouse cursor in wine applications.

*Solved : I just recreated the nvidia.conf in /etc/X11/mhwd.d

A scarily big upgrade, but almost 100% OK on my KDE system.

The only problem was due to the Python upgrade, which meant I needed to rebuild AUR packages that depend on Python, as ever when it’s upgraded.
I really must work out a method of automatically getting a list of these packages rather than having to look through my package manager.

I can’t update:

conflicting dependencies:
- conflict between catfish and zeitgeist
1 Like

For the python rebuild you can use rebuild detector (available in Manjaro repo)as suggested in the first post, after every update it will list the AUR packages that need rebuild in the pacman output.
You can also manually trigger it by running checkrebuild.

1 Like

For stuff i had to do see: My switch to the 5.10 kernel with update 2020-12-30, which is related to the nVidia drivers…

I’m getting black screen after this update. Tried using mhwd -a pci nonfree 0300 but it gives nvidia-utils and nvidia-430xx-utils are in conflict.

I was using a prime setup as per instruction given here. Can anyone help?

Having the same problem (stuck at boot on β€œfinished tlp system startup/shutdown”). Not sure what to do.

Excellent! I hadn’t spotted that. Many thanks.

β€œStart file indexer” did it for me, but now, one day later I notice that after reboot baloo breaks again :confused:

Which kernel? For me it only happened with 5.10, while 5.4 booted into DE just fine.

firefox- flatpak not starting, tried reinstalling.other gnome flatpaks i installed working fine.any idea whats wrong?

So basically same as me… hope this will fixed soon. Thanks anyway.

The kernel version says 5.9.16-1. I tried uninstalling nvidia-455xx-utils but its required by lib32-nvidia-utils. Should i use the -Rdd command?

sudo mhwd -a pci nonfree 0300
Warning: config '/var/lib/mhwd/local/pci/video-nvidia-455xx/MHWDCONFIG' is invalid!
> Skipping already installed config 'video-nvidia' for device: 0000:01:00.0 (0300:10de:13c2) Display controller nVidia Corporation GM204 [GeForce GTX 970]

sudo pacman --remove nvidia*
error: target not found: nvidia*


Sound issue with the 5.10 kernel on a laptop, solved by installed back the 5.9.16 kernel

more info see below

I removed lib32 stuff manually, and then uninstalled nvidia-455xx-utils. You will probably end without GUI, but then nvidia-utils re-instalation will work fine after reboot. At least it worked for me and fixed all the graphic problems.

[2020-12-31T…] [ALPM] upgraded linux54 (5.4.80-2 -> 5.4.85-1)
[2020-12-31T…] [ALPM] upgraded linux54-nvidia-390xx (390.132-88 -> 390.138-2)

It worked! After rebooting and running β€œmhwd -a pci nonfree 0300” the drivers started working again. I still have some problems with a window manager (bspwm), but the driver issue is fixed. Thank you!

I was able to install video-hybrid-intel-nvidia-prime but still SDDM is failing to load.