[Stable Update] 2020-11-22 - Kernels, Pamac, Gnome, Jade, OnlyOffice, Xorg-Server

A post was split to a new topic: Screen brightness issues

Just for quick feedback I no longer get the error message, after upgrading the mirror it no longer tries to upgrade the package qt5-xcb-private-headers.

I assume that is the correct fix, so thank you very much for the fast update!

Wasn’t there an update just like four days ago? Are there reasons for this?

1 Like

Hi, just a quick note. For some reason my last i3 config line which sets up a shortcut to change keyboard mapping is not enabled after the update:

exec "setxkbmap -option 'grp:win_space_toggle'"

i had to run setxkbmap -option 'grp:win_space_toggle separately and don’t know what caused this.


Yes. Another stable snap for the 20.2 ISO release.

If you’re allergic to updates you probably shouldn’t be using a rolling release distro. :wink:

Nope it was quicker then usual.

Not sure if anyone mentioned, but there doesn’t seem to be any linux510-virtualbox-host-modules in official repos and also the virtualbox-host-dkms fails to install for kernel 5.10.

No, not yet. 5.10 is still a Release Candidate, it’s not final yet.


No errors or warnings seen when the update was run using the GUI.

  • But i notice there is a /etc/default/grub.pacnew
    It must have been generated by a previous update i guess (looking at the date), so i just remove it and keep current one.
    (I don’t even use grub to boot, but instead use sd-boot :wink:)
    --- /etc/default/grub	2020-11-23 08:57:34.697374551 +0300
    +++ /etc/default/grub.pacnew	2020-11-13 00:06:56.000000000 +0300
    @@ -1,14 +1,13 @@
    -GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor udev.log_priority=3 sysrq_always_enabled=1"
    +GRUB_CMDLINE_LINUX_DEFAULT="quiet udev.log_priority=3"
     # If you want to enable the save default function, uncomment the following
     # line, and set GRUB_DEFAULT to saved.
     # Preload both GPT and MBR modules so that they are not missed
     GRUB_PRELOAD_MODULES="part_gpt part_msdos"
    @@ -30,21 +29,21 @@
     # Uncomment to allow the kernel use the same resolution used by grub
    -# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
    -# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
    +# Uncomment if you want GRUB to pass to the Linux kernel the old parameter 
    +# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx" 
     # Uncomment to disable generation of recovery mode menu entries
    -# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
    +# Uncomment and set to the desired menu colors.  Used by normal and wallpaper 
     # modes only.  Entries specified as foreground/background.
     # Uncomment one of them for the gfx desired, a image background or a gfxtheme
     # Uncomment to get a beep at GRUB start
     #GRUB_INIT_TUNE="480 440 1"

/reboot :crossed_fingers:
(seems to have booted :fireworks::rofl:)

Notable changes i had to perform since a fresh install from the LiveUSB image before all these updates:

  1. Related to keeping the system time in sync with my timezone:
    timedatectl set-ntp true
  2. Related to configuring ethernet network using SystemD instead of NetworkManager in combination with using [HowTo] DNS based advertising filter using Bind9 :
    sudo ln -sf /run/systemd/resolve/stub-resolv.conf /etc/resolv.conf
    systemctl enable --now systemd-resolved
  3. Related to nVidia in combination with Suspend/Resume/Hibernate:
    systemctl enable nvidia-{suspend,resume,hibernate}
  4. Steam issues:
    • Related to upgrade video-nvidia-440 -> video-nvidia-455
      [linux59] Steam games not working
    • Related to Shader Pre-Cacheing needing disabled.
      [BUG] Lingering and high CPU usage
      (Still hapening so still disabled)
    • Related to silent startup:
      Change the command line of “Startup and Shutdown -> Autostart -> Steam” to read /usr/bin/steam-runtime -silent %U
  5. Maybe more, will add if i remember.
    (I didn’t mention stuff needed to use sd-boot instead of grub)
1 Like

Does that last line contain a line break at the end?
I’ve seen config parsers in action which need “real” lines.

On GNOME, update went fine BUT I am pretty sure GDM is buggy (again).

Indeed, lockscreen does not work, neither split-right (but split-left does…?) nor toggle full screen.

This already happened but was fixed in one of the last updates. Any idea how to solve this?

I am sorry but nvidia-persistanced is not what you think it is. It will keep nothing after reboot.


A Linux daemon utility, nvidia-persistenced , addresses an undesirable side effect of the NVIDIA kernel driver behavior in certain computing environments. Whenever the NVIDIA device resources are no longer in use, the NVIDIA kernel driver will tear down the device state. Normally, this is the intended behavior of the device driver, but for some applications, the latencies incurred by repetitive device initialization can significantly impact performance.
To avoid this behavior, nvidia-persistenced provides a configuration option called “persistence mode” that can be set by NVIDIA management software, such as nvidia-smi . When persistence mode is enabled, the daemon holds the NVIDIA character device files open, preventing the NVIDIA kernel driver from tearing down device state when no other process is using the device. This utility does not actually use any device resources itself - it will simply sleep while maintaining a reference to the NVIDIA device state.

So if you have more than one Nvidia card in your system it is OK yo use it and latency is a problem.

May be it will be more useful to use nvidia-suspend.service, nvidia-resume.service, to save RAM of the card in Susepnd/Resume, but not reboot.

Thank you all envolved very much ! This was very nice and smooth update / upgrade for stable gnome! At first just accept new automatic packages from Pamac and then install new kernel 5.9.10-1 from Manjaro Settings Manager -> reboot and that’s it ! :slightly_smiling_face: :slightly_smiling_face: :slightly_smiling_face:

One of the previous updates enabled the “pop sholl extension” and gave me the behavior you describe.
Perhaps your issue is caused by that extension being enabled by the update?

1 Like

Ohhhh i see…interesting indeed.
I do have only 1 card in system, so indeed maybe i better make use of the suspend/resume services :+1:

Changed it into:

1 Like

Smooth in 2 Xfce machine (one old one new). Thanks!

I am still suffering from the issue with QT5 apps on gnome not showing dialogs. I digged deeper on the cause and the maintainer supplied a fix in commit:

How can I help to get this commit included in the next (un)stable/testing release?
qgnomeplatform is currently at version 0.6.90+3+gd5a01ea-1

Hello guys, all went fine kernel 5.4 xfce. :+1:

One question:
1. Where can I find a list of manjaro packages and their dependencies ?? like there is for arch

I have one orphan package software-center-web-jak(Install Software from Manjaro discover service).
Do I remove it or what ?? That’s way I want to see list of packages.


Thanks, it was indeed! Glad it’s not an actual bug.
Thank you a lot!

After this update(KDE, kenerl from 5.8 to 5.9.8-2), optimus manager can’t change to hybrid mode or Nvidia mode. Thought some thing wrong with Nvidia driver, what should I do? Currently I can’t change the lightness and can’t light up my second screen which may due to this problem.

1 Like