Screen brightness issues

Update went great, everything is working except I am unable to change my screen brightness. It is apparently fixed on 20% when running on battery, and fixed on 100% when running on power.

If you need any more information I’ll happily oblige!

Earlier today I had kernel 5.9.8-2 running which had the problem. The update towards 5.9.10 didn’t resolve the issue unfortunately.

In any case, here is my inxi -Fxxz output:

System:
  Kernel: 5.9.10-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0
  Desktop: Xfce 4.14.3 tk: Gtk 3.24.23 wm: xfwm4 dm: LightDM Distro: Manjaro Linux
Machine:
  Type: Laptop System: Dell product: XPS 13 9370 v: N/A serial: <filter> Chassis:
  type: 10 serial: <filter>
  Mobo: Dell model: 0F6P3V v: A00 serial: <filter> UEFI: Dell v: 1.13.1
  date: 07/08/2020
Battery:
  ID-1: BAT0 charge: 45.7 Wh condition: 50.3/52.0 Wh (97%) volts: 8.3/7.6
  model: SMP DELL G8VCF6C serial: <filter> status: Discharging
CPU:
  Info: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP arch: Kaby Lake
  rev: A L2 cache: 8192 KiB
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 32012
  Speed: 801 MHz min/max: 400/4000 MHz Core speeds (MHz): 1: 900 2: 900 3: 900
  4: 900 5: 900 6: 900 7: 900 8: 900
Graphics:
  Device-1: Intel UHD Graphics 620 vendor: Dell driver: i915 v: kernel
  bus ID: 00:02.0 chip ID: 8086:5917
  Device-2: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo bus ID: 1-5:3
  chip ID: 0bda:58f4
  Display: x11 server: X.Org 1.20.9 driver: intel unloaded: modesetting
  alternate: fbdev,vesa s-res: 1920x1080 s-dpi: 96
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.2.2
  direct render: Yes
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell driver: snd_hda_intel
  v: kernel bus ID: 00:1f.3 chip ID: 8086:9d71
  Sound Server: ALSA v: k5.9.10-1-MANJARO
Network:
  Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
  vendor: Bigfoot Networks Killer 1435 Wireless-AC driver: ath10k_pci v: kernel
  port: f040 bus ID: 02:00.0 chip ID: 168c:003e
  IF: wlp2s0 state: up mac: <filter>
  Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152
  bus ID: 2-1.2.1:5 chip ID: 0bda:8153
  IF: enp0s20f0u1u2u1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 476.94 GiB used: 12.70 GiB (2.7%)
  ID-1: /dev/nvme0n1 vendor: Toshiba model: KXG50ZNV512G NVMe 512GB size: 476.94 GiB
  speed: 31.6 Gb/s lanes: 4 serial: <filter>
Partition:
  ID-1: / size: 451.54 GiB used: 12.70 GiB (2.8%) fs: ext4 dev: /dev/nvme0n1p2
Swap:
  ID-1: swap-1 type: partition size: 16.88 GiB used: 0 KiB (0.0%) priority: -2
  dev: /dev/nvme0n1p3
Sensors:
  System Temperatures: cpu: 31.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 233 Uptime: 4m Memory: 15.34 GiB used: 1.28 GiB (8.4%) Init: systemd
  v: 246 Compilers: gcc: 10.2.0 Packages: pacman: 1121 Shell: Bash v: 5.0.18
  running in: alacritty inxi: 3.1.08
1 Like

Hello,
Had the same problem. Checked forums and found this solution. Use
i915.enable_dpcd_backlight=0 Boot parameter. In the file /etc/default/grub add that previous code into the quotation marks after GRUB_CMDLINE_LINUX_DEFAULT=

The run sudo update-grub

5 Likes

Much obliged! That did the trick! :smile: Very much appreciated!

1 Like

Do I have to add or replace the code?

Looks like this for me:

GRUB_CMDLINE_LINUX_DEFAULT=“quiet apparmor=1 security=apparmor resume=UUID=7f391a74-a843-4390-98a5-36e7b1d6322f udev.log_priority=3”

1 Like

Just add it after udev.log_priority=3 :slight_smile:

Example:

GRUB_CMDLINE_LINUX_DEFAULT=“quiet apparmor=1 security=apparmor resume=UUID=7f391a74-a843-4390-98a5-36e7b1d6322f udev.log_priority=3 i915.enable_dpcd_backlight=0”

Hope this works for you as well!

2 Likes

Yep, that solved it. Had to reboot to apply the changes. Thanks a lot!

2 Likes

Hi,

for me it didn’t do the trick :frowning:

As I’m quite a noob I don’t know if it’s totally random but I realized in the corellating line on my computer there is the “resume=…” info missing:

GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor udev.log_priority=3
i915.enable_dpcd_backlight=0"

It is missing indeed, however, this solution was provided by someone else so I am afraid I won’t be of much help here as to tell WHY you don’t have have the resume filled in.

I did however looked for you online for how to set the resume and here they say to use the command: sudo update-initramfs -u… BUT I don’t know myself exactly what that command does to the system.

It couldn’t hurt to see and discover what that command does before using it :slight_smile:

I am a noob in learning Linux still, but I help where I can!

2 Likes

Thanks I’ll look into it!

Hi @rswaagman @Jack1221 @reinheaven

I just realized the link you posted is about Ubuntu. There are differences between Ubuntu and Manjaro regarding (some?) commands, so I think I’ll search for something else.

I also realized that the UUID is referring to a partition, so it would be helpful to know which one it is on your system, or generally which it is supposed to be. I have the following to offer:

So if your computer boots at a a normal speed, (under a minute for most recent computers) without error messages than you probably do not need to fiddle with the UUIDs. As for the screen brightness, did you run sudo update-grub after you edited the file?

Hi Jack,

thanks for your reply!

There are no error messages during boot, but often the boot process doesn’t work (which I try to solve in another thread).

I ran sudo update-grub, but it didn’t help. So I looked again more closely and frankly inserted a paragraph (enter) instead of a space after “…prority=3”. Very much like a noob I guess.

Thank you very much for your help again!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.