[Bug] No intense colors in Konsole command prompt

I’m not sure when exactly this happened, but judging by my stored screenshots, it must have been around the time of the 2020.11.04 update. The thing is ─ and I’ve only just noticed this now ─ that my colorized prompt is no longer showing its colors in high-intensity anymore in Konsole. It still works perfectly in a character-mode virtual console, i.e. a tty.

I’m including a screenshot from 14 November 2020 to illustrate what I’m talking about… :arrow_down:

As you can see, the command prompt is in cyan, but it is not in the intense cyan that it used to be in, and I can confirm that it’s a Konsole problem because…

  1. … as I said, there is no problem with the colors inside a tty; and…

  2. … I have written a shell function for easily changing the prompt colors, and all of the selections offered by the function are now missing their intensity. My root prompt ─ which is red ─ also no longer has its bright attribute.

My cprompt shell function as defined in ~/.bashrc:arrow_down:

cprompt () {

  if [ ! -z $1 ]
    case $1 in

      "green"  )
         clrprompt="\[\e[1;32m\]\n[\h:\$(/usr/bin/tty)][\${PWD}]\n[\t][\u] \[\e[1;37m\]>\[\e[0m\] "
      "yellow" )
         clrprompt="\[\e[1;33m\]\n[\h:\$(/usr/bin/tty)][\${PWD}]\n[\t][\u] \[\e[1;37m\]>\[\e[0m\] "
      "blue"   )
         clrprompt="\[\e[1;34m\]\n[\h:\$(/usr/bin/tty)][\${PWD}]\n[\t][\u] \[\e[1;37m\]>\[\e[0m\] "
      "pink"   )
         clrprompt="\[\e[1;35m\]\n[\h:\$(/usr/bin/tty)][\${PWD}]\n[\t][\u] \[\e[1;37m\]>\[\e[0m\] "
      "cyan"   )
         clrprompt="\[\e[1;36m\]\n[\h:\$(/usr/bin/tty)][\${PWD}]\n[\t][\u] \[\e[1;37m\]>\[\e[0m\] "
      "white"  )
         clrprompt="\[\e[1;37m\]\n[\h:\$(/usr/bin/tty)][\${PWD}]\n[\t][\u] \[\e[1;37m\]>\[\e[0m\] "
      *        )
         echo "     The only options available are: "
         echo "         green | yellow | blue | pink | cyan | white"
         echo "     No color specified."


I do not know whether this is a Konsole bug, or a configuration bug that was introduced when the new Breath2 theme was pushed out ─ I suspect that this is when it happened, because after that particular update, my Konsole (and Yakuake) defaulted to the new Breath2 profile instead of to my custom profile.

Anyway, if anyone can offer some hints on how to get my Konsole to behave as before again, that would be nice. :slight_smile:

Hmm… Looks like it’s an upstream bug, already reported at bugs.kde.org by an Arch user.

1 Like
1 Like

This bug has now been resolved. :arrow_down:

KDE Plasma Version: 5.20.5
KDE Frameworks Version: 5.78.0
Qt Version: 5.15.2

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.