Lightdm breaks after latest kernel update

After upgrading to the packages linux-latest-5.8-1 linux-latest-virtualbox-guest-modules-5.8-1 linux-latest-virtualbox-host-modules-5.8-1 linux58-5.8.6-1 linux58-virtualbox-guest-modules-6.1.14-0 linux58-virtualbox-host-modules-6.1.14-0 the desktop boot process hanged at “Failed to start Light Display Manager” and the only way to get to boot again was to restore to a previous snapshot.

I tried running pacdiff but there was nothing related to lightdm.

I am running the linux kernel 5.7.19-2-MANJARO, NVIDIA driver 450.66, i3wm and lightdm-gtk-greeter

LightDM log
Xorg log

I have the same probem here. PC froze right after updating.
I already tried reinstalling xorg, lightdm (and tried gtk, sddm), and gpu drivers. Nothing. Still “Failed to start Light Display Manager”. Any ideas?

We need the Xorg and lightdm logs. It’s very hard to say anything without those.

Xorg log: sprungeDOTus/mfBhc0)
lightdm log: sprungeDOTus/Rm3INy)

That Xorg log sure doesn’t look good.

Any ideas?

Depending on how much you want to experiment, I’d install xorg-server-git and xf86-video-amdgpu-git from AUR with debugging symbols included and without optimizations to get a better picture of where this error happens and then file a bug report at xorg-server or xf86-video-amdgpu.

Sorry, I’ve just added the logs to the original post

Yours seems to be a more straightforward problem.

[     6.487] (EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the
[     6.487] (EE) NVIDIA:     system's kernel log for additional error messages and
[     6.487] (EE) NVIDIA:     consult the NVIDIA README for details.
[     6.489] (EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the
[     6.489] (EE) NVIDIA:     system's kernel log for additional error messages and
[     6.489] (EE) NVIDIA:     consult the NVIDIA README for details.
[     6.489] (EE) No devices detected.

I’d try reinstalling the gpu config with mhwd (use the -f flag to force it). But first, please run sudo dmesg | grep -i "nvidia"

Thanks! Reinstalling the drivers solved the issue for me.

The output of sudo dmesg | grep -i "nvidia":

[    1.902680] audit: type=1400 audit(1600022292.065:6): apparmor="STATUS" operation="profile_load" profile="unconfined" name="nvidia_modprobe" pid=313 comm="apparmor_parser"
[    1.903490] audit: type=1400 audit(1600022292.065:7): apparmor="STATUS" operation="profile_load" profile="unconfined" name="nvidia_modprobe//kmod" pid=313 comm="apparmor_parser"
[    2.580704] input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input4
[    2.580772] input: HDA NVidia HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input5
[    2.580847] input: HDA NVidia HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input6
[    2.580898] input: HDA NVidia HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input7
[    2.580953] input: HDA NVidia HDMI/DP,pcm=10 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input8
[    2.581001] input: HDA NVidia HDMI/DP,pcm=11 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input9
[    2.581048] input: HDA NVidia HDMI/DP,pcm=12 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input10
[    3.394632] nvidia-gpu 0000:01:00.3: i2c timeout error e0000000

And how would you do that? Installig with debugging symbols included and without optimizations?

Open a new topic please and mention me.

OK got it fixed somehow! Here is what i did after bootup/reboot:

systemctl disable lightdm
sudo pacman -Syu
sudo pacman -R lightdm lightdm-gtk-greeter
pamac install xorg-server-git xf86-video-amdgpu-git
sudo pacman -S lightdm lightdm-gtk-greeter
systemctl enable lightdm-gtk-greeter
systemctl enable lightdm


You are forcibly using development git packages from outside the repos that arent being handled by mhwd.
You are always going to be the one responsible for that - its not a normal functioning manjaro system.

I agree with @cscs, it’s usually not recommended to use -git packages if you don’t have a pressing reason. However, if the issue persists with the officially packages, I think you could keep the -git packages till the next update, and see if that’s already fixed the problem.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.