Unable to install module vboxhost/6.1.14_OSE for kernel 5.4.64-1-MANJARO: Missing kernel headers

Greetings. Whit this update I have problems with VirtualBox

My system:

KDE
Linux dark 5.4.64-1-MANJARO #1 SMP PREEMPT Wed Sep 9 18:26:19 UTC 2020 x86_64 GNU/Linux

I have problems with VirtualBox in two VMs, both have problems to start:

vm1: (This vm starts automatically)
Failed to open a session for the virtual machine pihole.

vm2: (This vm starts manually)
Failed to load R0 module /usr/lib/virtualbox/ExtensionPacks/Oracle_VM_VirtualBox_Extension_Pack/linux.amd64/VBoxEhciR0.r0: RTLdrGetBits failed (VERR_SYMBOL_VALUE_TOO_BIG).

Failed to load ring-0 module 'VBoxEhciR0.r0' for device 'usb-ehci' (VERR_SYMBOL_VALUE_TOO_BIG).

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: ConsoleWrap
Interface: IConsole {xxxx-yyyy-zzzz-}

Any advice?

image

My update log:

:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (32) appstream-glib-0.7.18-1  c-ares-1.16.1-2  catimg-2.7.0-1  dhcpcd-9.2.0-1  efibootmgr-17-2  etcher-1.5.108-1  gnome-desktop-1:3.36.6-1  go-2:1.15.2-1  imagemagick-7.0.10.29-1  kmod-27-2  lib32-util-linux-2.36-1  libpgm-5.3.128-1  libwps-0.4.12-1
              libxkbcommon-1.0.0-1  libxkbcommon-x11-1.0.0-1  linux54-5.4.64-1  linux54-nvidia-430xx-430.64-72  linux54-r8168-8.048.03-24  linux54-virtualbox-host-modules-6.1.14-2  manjaro-hello-0.6.5-14  manjaro-release-20.1-1  mhwd-0.6.5-1  shadow-4.8.1-4
              snappy-1.1.8-2  vim-8.2.1634-1  vim-runtime-8.2.1634-1  virtualbox-6.1.14-1  virtualbox-host-dkms-6.1.14-1  wildmidi-0.4.3-3  zeromq-4.3.2-3  archlinux-keyring-20200820-1  manjaro-keyring-20200603-1

Total Download Size:    341.41 MiB
Total Installed Size:  1182.32 MiB
Net Upgrade Size:         0.43 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
 mhwd-0.6.5-1-x86_64                                                                                                                81.6 KiB  1118 KiB/s 00:00 [##################################################################################################] 100%
 kmod-27-2-x86_64                                                                                                                  104.6 KiB  1433 KiB/s 00:00 [##################################################################################################] 100%
 shadow-4.8.1-4-x86_64                                                                                                            1194.2 KiB  1456 KiB/s 00:01 [##################################################################################################] 100%
 dhcpcd-9.2.0-1-x86_64                                                                                                             205.2 KiB  1655 KiB/s 00:00 [##################################################################################################] 100%
 efibootmgr-17-2-x86_64                                                                                                             27.4 KiB  8.92 MiB/s 00:00 [##################################################################################################] 100%
 linux54-5.4.64-1-x86_64                                                                                                            82.3 MiB  2.39 MiB/s 00:34 [##################################################################################################] 100%
 manjaro-release-20.1-1-any                                                                                                         14.9 KiB  0.00   B/s 00:00 [##################################################################################################] 100%
 libxkbcommon-1.0.0-1-x86_64                                                                                                       194.7 KiB   227 KiB/s 00:01 [##################################################################################################] 100%
 appstream-glib-0.7.18-1-x86_64                                                                                                    487.6 KiB  2.04 MiB/s 00:00 [##################################################################################################] 100%
 c-ares-1.16.1-2-x86_64                                                                                                            117.6 KiB   285 KiB/s 00:00 [##################################################################################################] 100%
 gnome-desktop-1:3.36.6-1-x86_64                                                                                                   542.7 KiB  1660 KiB/s 00:00 [##################################################################################################] 100%
 imagemagick-7.0.10.29-1-x86_64                                                                                                      2.5 MiB  1725 KiB/s 00:01 [##################################################################################################] 100%
 libwps-0.4.12-1-x86_64                                                                                                           1742.8 KiB  1846 KiB/s 00:01 [##################################################################################################] 100%
 libxkbcommon-x11-1.0.0-1-x86_64                                                                                                    21.6 KiB  0.00   B/s 00:00 [##################################################################################################] 100%
 linux54-nvidia-430xx-430.64-72-x86_64                                                                                              12.8 MiB  1860 KiB/s 00:07 [##################################################################################################] 100%
 linux54-r8168-8.048.03-24-x86_64                                                                                                  179.3 KiB  1348 KiB/s 00:00 [##################################################################################################] 100%
 linux54-virtualbox-host-modules-6.1.14-2-x86_64                                                                                   174.1 KiB   781 KiB/s 00:00 [##################################################################################################] 100%
 manjaro-hello-0.6.5-14-any                                                                                                        135.8 KiB  1069 KiB/s 00:00 [##################################################################################################] 100%
 snappy-1.1.8-2-x86_64                                                                                                              24.9 KiB  0.00   B/s 00:00 [##################################################################################################] 100%
 vim-runtime-8.2.1634-1-x86_64                                                                                                       6.3 MiB   509 KiB/s 00:13 [##################################################################################################] 100%
 vim-8.2.1634-1-x86_64                                                                                                            1745.7 KiB  1096 KiB/s 00:02 [##################################################################################################] 100%
 wildmidi-0.4.3-3-x86_64                                                                                                            89.9 KiB  1232 KiB/s 00:00 [##################################################################################################] 100%
 catimg-2.7.0-1-x86_64                                                                                                              42.5 KiB  4.15 MiB/s 00:00 [##################################################################################################] 100%
 etcher-1.5.108-1-x86_64                                                                                                            65.5 MiB  1162 KiB/s 00:58 [##################################################################################################] 100%
 go-2:1.15.2-1-x86_64                                                                                                              127.7 MiB  2.06 MiB/s 01:02 [##################################################################################################] 100%
 libpgm-5.3.128-1-x86_64                                                                                                           192.4 KiB   222 KiB/s 00:01 [##################################################################################################] 100%
 virtualbox-host-dkms-6.1.14-1-x86_64                                                                                              705.8 KiB  1778 KiB/s 00:00 [##################################################################################################] 100%
 virtualbox-6.1.14-1-x86_64                                                                                                         35.3 MiB  1883 KiB/s 00:19 [##################################################################################################] 100%
 zeromq-4.3.2-3-x86_64                                                                                                             604.2 KiB  1549 KiB/s 00:00 [##################################################################################################] 100%
 lib32-util-linux-2.36-1-x86_64                                                                                                    439.7 KiB  1780 KiB/s 00:00 [##################################################################################################] 100%
(32/32) checking keys in keyring                                                                                                                               [##################################################################################################] 100%
(32/32) checking package integrity                                                                                                                             [##################################################################################################] 100%
(32/32) loading package files                                                                                                                                  [##################################################################################################] 100%
(32/32) checking for file conflicts                                                                                                                            [##################################################################################################] 100%
(32/32) checking available disk space                                                                                                                          [##################################################################################################] 100%
:: Running pre-transaction hooks...
(1/2) Removing linux initcpios...
(2/2) Remove DKMS modules
==> Unable to remove module vboxhost/6.1.12_OSE for kernel 5.4.62-1-MANJARO: Not found in dkms status output.
:: Processing package changes...
( 1/32) reinstalling archlinux-keyring                                                                                                                         [##################################################################################################] 100%
==> Appending keys from archlinux.gpg...
==> Locally signing trusted keys in keyring...
  -> Locally signing key D8AFDDA07A5B6EDFA7D8CCDAD6D055F927843F1C...
  -> Locally signing key DDB867B92AA789C165EEFA799B729B06A680C281...
  -> Locally signing key 91FFE0700E80619CEB73235CA88E23E377514E00...
  -> Locally signing key 0E8B644079F599DFC1DDC3973348882F6AC6A4C2...
  -> Locally signing key AB19265E5D7D20687D303246BA1DFB64FFF979E7...
==> Importing owner trust values...
==> Disabling revoked keys in keyring...
  -> Disabling key 8F76BEEA0289F9E1D3E229C05F946DED983D4366...
  -> Disabling key 63F395DE2D6398BBE458F281F2DBB4931985A992...
  -> Disabling key 50F33E2E5B0C3D900424ABE89BDCF497A4BBCC7F...
  -> Disabling key 27FFC4769E19F096D41D9265A04F9397CDFD6BB0...
  -> Disabling key 39F880E50E49A4D11341E8F939E4F17F295AFBF4...
  -> Disabling key 8840BD07FC24CB7CE394A07CCF7037A4F27FB7DA...
  -> Disabling key 5559BC1A32B8F76B3FCCD9555FA5E5544F010D48...
  -> Disabling key 0B20CA1931F5DA3A70D0F8D2EA6836E1AB441196...
  -> Disabling key 07DFD3A0BC213FA12EDC217559B3122E2FA915EC...
  -> Disabling key 4FCF887689C41B09506BE8D5F3E1D5C5D30DB0AD...
  -> Disabling key 5A2257D19FF7E1E0E415968CE62F853100F0D0F0...
  -> Disabling key D921CABED130A5690EF1896E81AF739EC0711BF1...
  -> Disabling key 7FA647CD89891DEDC060287BB9113D1ED21E1A55...
  -> Disabling key BC1FBE4D2826A0B51E47ED62E2539214C6C11350...
  -> Disabling key 4A8B17E20B88ACA61860009B5CED81B7C2E5C0D2...
  -> Disabling key 5696C003B0854206450C8E5BE613C09CB4440678...
  -> Disabling key 684148BB25B49E986A4944C55184252D824B18E8...
  -> Disabling key 8CF934E339CAD8ABF342E822E711306E3C4F88BC...
  -> Disabling key F5A361A3A13554B85E57DDDAAF7EF7873CFD4BB6...
  -> Disabling key 5E7585ADFF106BFFBBA319DC654B877A0864983E...
  -> Disabling key 65EEFE022108E2B708CBFCF7F9E712E59AF5F22A...
  -> Disabling key 40440DC037C05620984379A6761FAD69BA06C6A9...
  -> Disabling key 34C5D94FE7E7913E86DC427E7FB1A3800C84C0A5...
  -> Disabling key 81D7F8241DB38BC759C80FCE3A726C6170E80477...
  -> Disabling key E7210A59715F6940CF9A4E36A001876699AD6E84...
  -> Disabling key 5357F3B111688D88C1D88119FCF2CB179205AC90...
  -> Disabling key 4D913AECD81726D9A6C74F0ADA6426DD215B37AD...
  -> Disabling key FB871F0131FEA4FB5A9192B4C8880A6406361833...
  -> Disabling key 66BD74A036D522F51DD70A3C7F2A16726521E06D...
  -> Disabling key B1F2C889CB2CCB2ADA36D963097D629E437520BD...
  -> Disabling key 9515D8A8EAB88E49BB65EDBCE6B456CAF15447D5...
  -> Disabling key 76B4192E902C0A52642C63C273B8ED52F1D357C1...
  -> Disabling key 40776A5221EF5AD468A4906D42A1DB15EC133BAD...
  -> Disabling key D4DE5ABDE2A7287644EAC7E36D1A9E70E19DAA50...
  -> Disabling key 44D4A033AC140143927397D47EFD567D4C7EA887...
==> Updating trust database...
gpg: next trustdb check due at 2021-01-01
( 2/32) reinstalling manjaro-keyring                                                                                                                           [##################################################################################################] 100%
==> Appending keys from manjaro.gpg...
==> Locally signing trusted keys in keyring...
  -> Locally signing key B4663188A692DB1E45A98EE95BD96CC4247B52CC...
  -> Locally signing key 76C6E477042BFE985CC220BD9C08A255442FAFF0...
  -> Locally signing key 7C89F4D439B2BFACF425107B62443D89B35859F8...
  -> Locally signing key 1E7908935AAB9A00D6B47503363DFFFD59152F77...
  -> Locally signing key 04BB537F5BC2D399BFA72F8F17C752B61B2F2E90...
  -> Locally signing key 5A97ED6B72418199F0C22B23137C934B5DCB998E...
  -> Locally signing key 75C1B95A4D9514A57EB2DAE71817DC63CD3B5DF5...
  -> Locally signing key 39F0EC1AE50B37E5F3196F09DAD3B211663CA268...
  -> Locally signing key 2D14560CDCE6A75BB186DB758238651DDF5E0594...
  -> Locally signing key 7A443CEE69B6B3777740E258084A7FC0035B1D49...
  -> Locally signing key F66AD0FF0E57C561615A0901CEE477135C5872B0...
  -> Locally signing key 35B4FF23EA9477582C2A0AF12B80869C5C0102A6...
  -> Locally signing key E4CDFE50A2DA85D58C8A8C70CAA6A59611C7F07E...
  -> Locally signing key 74C2F2CC05A0AB7D859839938934292D604F8BA2...
  -> Locally signing key 77DC01C9971AC3C39A0626F72C089F09AC97B894...
  -> Locally signing key 16DC688DF3EECC72323954237EC47C82A42D53A2...
  -> Locally signing key 2C688B52E3FC0144B7484BABE3B3F44AC45EE0AA...
  -> Locally signing key 22C903DE964E6FE321656E318DB9F8C18DF53602...
  -> Locally signing key 688E8F82879D0E25CE541426150C200743ED46D8...
==> Importing owner trust values...
==> Disabling revoked keys in keyring...
  -> Disabling key 540DE7083B89314CF70EA6F0C1B1AD0DA80EBF3E...
  -> Disabling key FAA6840E8C3FC7F89BEE0DC8AC7AB10BCB6CDD17...
==> Updating trust database...
gpg: next trustdb check due at 2021-01-01
( 3/32) upgrading libxkbcommon                                                                                                                                 [##################################################################################################] 100%
New optional dependencies for libxkbcommon
    libxkbcommon-x11: xkbcli interactive-x11 [installed]
    wayland: xkbcli interactive-wayland [installed]
( 4/32) upgrading mhwd                                                                                                                                         [##################################################################################################] 100%
xorg configuration symlink valid...
( 5/32) upgrading kmod                                                                                                                                         [##################################################################################################] 100%
( 6/32) upgrading shadow                                                                                                                                       [##################################################################################################] 100%
( 7/32) upgrading appstream-glib                                                                                                                               [##################################################################################################] 100%
( 8/32) upgrading c-ares                                                                                                                                       [##################################################################################################] 100%
( 9/32) upgrading catimg                                                                                                                                       [##################################################################################################] 100%
(10/32) upgrading dhcpcd                                                                                                                                       [##################################################################################################] 100%
warning: directory permissions differ on /var/lib/dhcpcd/
filesystem: 700  package: 755
(11/32) upgrading efibootmgr                                                                                                                                   [##################################################################################################] 100%
(12/32) upgrading etcher                                                                                                                                       [##################################################################################################] 100%
(13/32) upgrading gnome-desktop                                                                                                                                [##################################################################################################] 100%
(14/32) upgrading go                                                                                                                                           [##################################################################################################] 100%
(15/32) upgrading imagemagick                                                                                                                                  [##################################################################################################] 100%
(16/32) upgrading lib32-util-linux                                                                                                                             [##################################################################################################] 100%
(17/32) upgrading libpgm                                                                                                                                       [##################################################################################################] 100%
(18/32) upgrading libwps                                                                                                                                       [##################################################################################################] 100%
(19/32) upgrading libxkbcommon-x11                                                                                                                             [##################################################################################################] 100%
(20/32) upgrading linux54                                                                                                                                      [##################################################################################################] 100%
(21/32) upgrading linux54-nvidia-430xx                                                                                                                         [##################################################################################################] 100%
(22/32) upgrading linux54-r8168                                                                                                                                [##################################################################################################] 100%
(23/32) upgrading linux54-virtualbox-host-modules                                                                                                              [##################################################################################################] 100%
In order to use the new version, reload all virtualbox modules manually.
(24/32) upgrading manjaro-hello                                                                                                                                [##################################################################################################] 100%
(25/32) upgrading manjaro-release                                                                                                                              [##################################################################################################] 100%
(26/32) upgrading snappy                                                                                                                                       [##################################################################################################] 100%
(27/32) upgrading vim-runtime                                                                                                                                  [##################################################################################################] 100%
(28/32) upgrading vim                                                                                                                                          [##################################################################################################] 100%
(29/32) upgrading virtualbox-host-dkms                                                                                                                         [##################################################################################################] 100%
(30/32) upgrading virtualbox                                                                                                                                   [##################################################################################################] 100%
(31/32) upgrading wildmidi                                                                                                                                     [##################################################################################################] 100%
(32/32) upgrading zeromq                                                                                                                                       [##################################################################################################] 100%
:: Running post-transaction hooks...
( 1/14) Creating system user accounts...
( 2/14) Reloading system manager configuration...
( 3/14) Creating temporary files...
( 4/14) Reloading device manager configuration...
( 5/14) Arming ConditionNeedsUpdate...
( 6/14) Updating module dependencies...
( 7/14) Install DKMS modules
==> Unable to install module vboxhost/6.1.14_OSE for kernel 5.4.64-1-MANJARO: Missing kernel headers.
( 8/14) Updating linux initcpios...
==> Building image from preset: /etc/mkinitcpio.d/linux54.preset: 'default'
  -> -k /boot/vmlinuz-5.4-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.4-x86_64.img
==> Starting build: 5.4.64-1-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-5.4-x86_64.img
bsdtar: Failed to set default locale
bsdtar: Failed to set default locale
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux54.preset: 'fallback'
  -> -k /boot/vmlinuz-5.4-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.4-x86_64-fallback.img -S autodetect
==> Starting build: 5.4.64-1-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-5.4-x86_64-fallback.img
bsdtar: Failed to set default locale
bsdtar: Failed to set default locale
==> Image generation successful
( 9/14) Updating Kernel initcpios for Nvidia-DRM...
==> Building image from preset: /etc/mkinitcpio.d/linux54.preset: 'default'
  -> -k /boot/vmlinuz-5.4-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.4-x86_64.img
==> Starting build: 5.4.64-1-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-5.4-x86_64.img
bsdtar: Failed to set default locale
bsdtar: Failed to set default locale
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux54.preset: 'fallback'
  -> -k /boot/vmlinuz-5.4-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.4-x86_64-fallback.img -S autodetect
==> Starting build: 5.4.64-1-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-5.4-x86_64-fallback.img
bsdtar: Failed to set default locale
bsdtar: Failed to set default locale
==> Image generation successful
(10/14) Updating Grub-Bootmenu
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-5.4-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.4-x86_64.img
Found initrd fallback image: /boot/initramfs-5.4-x86_64-fallback.img
Found memtest86+ image: /boot/memtest86+/memtest.bin
done
(11/14) Warn about old perl modules
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "",
        LC_ALL = (unset),
        LC_ADDRESS = "en_US.UTF-8",
        LC_NAME = "en_US.UTF-8",
        LC_MONETARY = "en_US.UTF-8",
        LC_PAPER = "en_US.UTF-8",
        LC_IDENTIFICATION = "en_US.UTF-8",
        LC_TELEPHONE = "en_US.UTF-8",
        LC_MEASUREMENT = "en_US.UTF-8",
        LC_TIME = "en_US.UTF-8",
        LC_NUMERIC = "en_US.UTF-8",
        LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
(12/14) Updating icon theme caches...
(13/14) Updating the desktop file MIME type cache...
(14/14) Updating the MIME type database...

The log show this line:

==> Unable to install module vboxhost/6.1.14_OSE for kernel 5.4.64-1-MANJARO:
 Missing kernel headers.

How can be this fixed?

  • I wonder if I will need to install this: linux54-headers
  • I installed it, restarted it and the problem persists.
    :sweat:

Thanks in advance for the help.

As per announcement wiki, have you run that command or this command
sudo usermod -a -G vboxusers $USER
?

1 Like

from the announcement I got this message:

sudo usermod --append --groups virtualbox $USER
usermod: group 'virtualbox' does not exist

with your code, there is not output

Wait … there is something strange about that wiki. I also tested this command i provided

and is not working
but this should:
sudo gpasswd -a $USER vboxusers

Let me do more tests and also ask the other staff members about it.

1 Like

Something is unclear for me here … but let’s do it the old fashion way. Download the Oracle_VM_VirtualBox_Extension_Pack-6.1.14.vbox-extpack
Or from their site:
https://www.virtualbox.org/wiki/Downloads

From File Manager open Terminal in that place/folder where you save it then run this command:

sudo vboxmanage extpack install --replace Oracle_VM_VirtualBox_Extension_Pack-6.1.14.vbox-extpack

To make sure all is ok, also run this command:

Reboot the system and all should be back to normal.

3 Likes

:trophy: Thank you! Now they are working.

Bogdan,

Is this something I should add to the wiki ort is this specific to this user?

Ernie, :grin:

I’m the one who posted it to the wiki after feedback from another user. I myself do not have VirtualBox installed… :wink:

1 Like

The wikipost needs editing because
the group name should be ‘vboxusers’ not ‘virtualbox’.

According to https://wiki.archlinux.org/index.php/Users_and_groups
either of these commands should work:
sudo usermod -aG vboxusers $USER
sudo gpasswd -a $USER vboxusers
so it’s a mystery that one of them didn’t work for @bogdancovaciu

There doesn’t seem to be anything else you could say about what happened for @MrE

One problem was simply that he ran a command referencing the group ‘virtualbox’,
which does not (and should not) exist.

The original problem was

==> Unable to remove module vboxhost/6.1.12_OSE for kernel 5.4.62-1-MANJARO:
 Not found in dkms status output.
...
==> Unable to install module vboxhost/6.1.14_OSE for kernel 5.4.64-1-MANJARO:
 Missing kernel headers.

but it seems to be resolved, and I don’t see how.

Also he got:

(23/32) upgrading linux54-virtualbox-host-modules  ... 100%
In order to use the new version, reload all virtualbox modules manually.

I use the same kernel, but I got
(35/39) upgrading virtualbox-host-dkms
There was no mention of “linux54-virtualbox-host-modules”.

2 Likes

The wiki in the update announcement has virtualbox as group, while my command and arch wiki command has vboxusers as group …

Nope, i had no issue here. The OP did :slight_smile:

SInce Manjaro provides the modules for all kernels, there is no need for dkms one … but, each can do what they prefer and works best.

Thanks for the info.
I installed Manjaro 3.5 years ago, and vbox at the same time,
and never heard of virtualbox-host-modules before.

MrE has both in his package list, and virtualbox-host-modules is the one that’s used,
which might explain why “Unable to install module vboxhost…” was not a problem.

I guess @MrE should un-install virtualbox-host-dkms.

I wonder about “to use the new version, reload all virtualbox modules manually”,
as he didn’t mention doing it, but he says virtualbox works…

1 Like

Most likely the OP issue was not being in the vboxusers group and also trying to install the vbox-extpack failed because was not able to install it as there was no password prompt when doing it. All that was fixed once he did what i recommended.

My “issue” here, and confusion is that the wiki has, as i said

Done! @bogdancovaciu @j77h

(My information came from another user in the original update announcement)

1 Like

That was caused by having both ‘virtualbox-host-dkms’ and ‘virtualbox-host-modules’ installed at the same time.
The manjaro wiki does not mention dkms.
The arch wiki mentions both, and says you must choose one or the other.

(How it happened that you were not in the vboxusers group I have no idea – it’s a different issue.)

I figured that not having dkms will save me the unload/reload time that happens on every kernel update, so I switched.

I used the following commands.
They might help if you decide to uninstall virtualbox-host-dkms.

  1. sudo pacman -Rcu virtualbox-host-dkms

    This uninstalled 3 packages (we re-install 2 of them later) :
    virtualbox-6.1.14-1
    virtualbox-ext-oracle-6.1.14-1
    virtualbox-host-dkms-6.1.14-1

  2. sudo pacman -S linux54-virtualbox-host-modules
    sudo pacman -S virtualbox

  3. sudo modprobe vboxdrv
    sudo vboxreload

  4. pikaur -S virtualbox-ext-oracle-manjaro

EDIT:

Have changed “virtualbox-ext-oracle” above, to “virtualbox-ext-oracle-manjaro”,
because Arch’s ‘virtualbox-ext-oracle’ can have a later version than Manjaro’s virtualbox.
EDIT2: later I realized that “virtualbox-ext-oracle-manjaro” can be out-of-date sometimes, so we still need to check versions before installing.

pikaur is the AUR helper that I normally use.
You can use whichever AUR helper you normally use (pamac can do it).

None of the above affects your VMs (as long as they’re not running at the time).
I’ve used my Win10 VM since I made those changes, and installed the new Guest Additions.

2 Likes

I would discourage using aur/virtualbox-ext-oracle on stable.
The version of the extension pack should always match the version of VirtualBox, the AUR package assumes you have the same version that Arch has.

1 Like

I’ll try in a moment…

Maybe the reboot (recommended by @bogdancovaciu) did the trick.


Using octopi will remove dkms too
image
Can I proceed?

True. I mentioned this yesterday at [HowTo] VirtualBox - Installation - USB - Shared Folder, and it’s now covered in the main post there.

EDIT (3h later) :

Have just noticed “virtualbox-ext-oracle-manjaro” on that page.
Have edited it into my earlier post.

Also learned how to search with pikaur :

$ pikaur -Ssa virtualbox-ext-oracle
Searching... [--]##
aur/virtualbox-ext-oracle 6.1.14-1 [installed] (1305, 5.21)
    Oracle VM VirtualBox Extension Pack
aur/virtualbox-ext-oracle-manjaro 6.1.14-1 (4, 2.99)
    Oracle VM VirtualBox Extension Pack for Manjaro
aur/virtualbox-ext-oracle-5 5.2.x-1 (8, 0.07)
    Oracle VM VirtualBox Extension Pack 5.2.x (stable)
aur/virtualbox-ext-oracle-beta 6.1.0_RC1-1 (1, 0.00)
    Oracle VM VirtualBox Extension Pack (Beta)
aur/virtualbox-ext-oracle-5-test-build 5.2.35_135314-1 (0, 0.00)
    Oracle VM VirtualBox Extension Pack Test Build 5.2.35_135314
aur/virtualbox-ext-oracle-5.0 5.0.40-1 [outofdate: 2018/12/29] (6, 0.00)
    Oracle VM VirtualBox Extension Pack
1 Like

Pamac is a GUI for pacman, and is an AUR helper.
At the moment I think: use the pacman commands from my message,
as there’s less that could go wrong, and you’ll get clear feedback.
(post text here off your terminal if it didn’t go right.)
Pamac might do it OK, but I never use it myself, so I can’t be sure.

Where I wrote “use whatever AUR helper you normally use”, you can use pamac for that part (installing virtualbox-ext-oracle-manjaro from the AUR).

Good find. I hope it gets reflected in the wiki.

At home I have a system installed before 2015, at work one installed in January 2018.

In both I had problems to start virtualbox, although at home I did everything I could find to correct it (no very wise), in the end the solution was what @bogdancovaciu suggested above:

This worked for me today at work, here I didn’t need to reboot for it to work.

I barely remember that I found this dkms suggestion a long time ago when I installed virtualbox at home. In this new installation at work I don’t even have it.

As I’m not running virtualbox, I need some guidance as what needs to be changed in the wiki.

@j77h unless J77 can edit the wiki? (Unsure if you need to be TL2 or TL3)

:man_shrugging: