Sound from speakers no sound from 3.5mm jack-audio

amixer -c1 sset 'Auto-Mute Mode' 'Disabled'

see if that helps.

I have tried but unfortunately did not work.

hi,
i also have a cannon point audio interface and struggled with it in the beginning. here is how i made it work:

  1. be sure to run a kernel >= 5.6
  2. be sure that sof-firmware is installed
  3. you can disable the detection of the digital mic using either a kernel parameter or by creating an alsa config file in /etc/modprobe.d/alsa-base.conf. Be sure to not do any of these!
  4. install pulseaudio-git from the aur.
  5. run:
systemctl --user daemon-reload
systemctl --user enable pulseaudio pulseaudio.socket
systemctl --user restart pulseaudio pulseaudio.socket
  1. reboot
1 Like

Still not working.
Check image
As you can see it shows the output device. It even shows output is being sent. But, no audio from the headphones.

strange…
in order to see whether everything has worked correctly otherwise, could you please post another inxi -Fxxxz?
and maybe its worth trying it on the 5.7 kernel?

System:    Kernel: 5.7.15-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 Desktop: GNOME 3.36.5 
           tk: GTK 3.24.22 wm: gnome-shell dm: GDM 3.36.3 Distro: Manjaro Linux 
Machine:   Type: Laptop System: ASUSTeK product: GL503VD v: 1.0 serial: <filter> 
           Mobo: ASUSTeK model: GL503VD v: 1.0 serial: <filter> UEFI: American Megatrends 
           v: GL503VD.304 date: 10/03/2017 
Battery:   ID-1: BAT1 charge: 42.1 Wh condition: 46.8/64.4 Wh (73%) volts: 5.0/15.2 
           model: ASUS A32-K55 type: Li-ion serial: N/A status: Discharging 
CPU:       Topology: Quad Core model: Intel Core i7-7700HQ bits: 64 type: MT MCP arch: Kaby Lake 
           rev: 9 L2 cache: 6144 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 44817 
           Speed: 800 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 
           6: 800 7: 800 8: 800 
Graphics:  Device-1: Intel HD Graphics 630 vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:591b 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: ASUSTeK driver: nvidia v: 440.100 
           bus ID: 01:00.0 chip ID: 10de:1c8d 
           Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo bus ID: 1-7:4 
           chip ID: 13d3:5666 serial: <filter> 
           Display: x11 server: X.Org 1.20.8 compositor: gnome-shell driver: nvidia 
           unloaded: modesetting resolution: 1920x1080 s-dpi: 96 
           OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 20.1.5 
           direct render: Yes 
Audio:     Device-1: Intel CM238 HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 00:1f.3 chip ID: 8086:a171 
           Sound Server: ALSA v: k5.7.15-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK 
           driver: r8169 v: kernel port: d000 bus ID: 02:00.0 chip ID: 10ec:8168 
           IF: enp2s0 state: down mac: <filter> 
           Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel port: d000 bus ID: 04:00.0 
           chip ID: 8086:24fd 
           IF: wlp4s0 state: up mac: <filter> 
           IF-ID-1: br-252f518c6383 state: down mac: <filter> 
           IF-ID-2: docker0 state: down mac: <filter> 
Drives:    Local Storage: total: 1.03 TiB used: 30.62 GiB (2.9%) 
           ID-1: /dev/nvme0n1 vendor: Toshiba model: N/A size: 119.24 GiB speed: 31.6 Gb/s lanes: 4 
           serial: <filter> rev: 57XA4104 scheme: GPT 
           ID-2: /dev/sda vendor: HGST (Hitachi) model: HTS721010A9E630 size: 931.51 GiB 
           speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: A3V0 scheme: GPT 
RAID:      Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci v: 3.0 port: f060 
           bus ID: 00:17.0 chip ID: 8086.282a rev: 31 
Partition: ID-1: / size: 116.38 GiB used: 30.62 GiB (26.3%) fs: ext4 dev: /dev/nvme0n1p2 
Swap:      Alert: No Swap data was found. 
Sensors:   System Temperatures: cpu: 48.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 276 Uptime: 28m Memory: 7.66 GiB used: 2.01 GiB (26.3%) Init: systemd v: 245 
           Compilers: gcc: 10.1.0 clang: 10.0.1 Packages: pacman: 1589 Shell: fish v: 3.1.2 
           running in: alacritty inxi: 3.1.05 

I did try with both 5.7 & 5.8

Hi!

I tried your suggestion but nothing happened :frowning:

ok, i see… you do not seem to be the original poster, correct? at least the sound device you use (Intel CM238 HD) is different than what the original post was about ( Intel Cannon Lake PCH cAVS).

in any case, my solution works in case the device needs the sof-firmware. if it does and all the package is installed and the device is not forced to use the snd_hda_intel via some kernel or alsa settings, the driver should show up as driver: sof-audio-pci.

A strange thing happened.
Suddenly my audio and headphones started to work even with plug/unplug detection so I did new fresh install and it is not working again.
Here’s my output alsa-info.sh --upload from not working and working environments
Not working: http://alsa-project.org/db/?f=3ba93e1f934d1d4ac5ee318af0f91835a43f6010
Working: http://alsa-project.org/db/?f=d675d04e794efd4b310fbf044320fa7686532483
I do not know if this would be helpful to compare what is happening there, but still there is no consistent solution for this.

I found out that this problem is caused by small changes in the file “patch_realtek.c” in kernel 5.7.10, this change has been applied to all LTS and Stable versions of the kernel. The previous stable update from 2020-07-19 was on version 5.7.9, so with the next update from 2020-08-16, the sound disappeared. It is not clear why these changes broke the audio on the 3.5 jack port. The problem has been seen on ASUS GL703GM, GL703GE, GU502GW, GL503VM and GL503VD notebooks (all from this forum).


I found as many as four ways to solve this problem:

Way one (simple but crooked): paste this line “options snd-hda-intel model=headset-mode” into file “/etc/modprobe.d/alsa.conf” then SHUTDOWN the system, DO NOT reboot. Then turn on the system and the sound should appear, but the microphone in the headphones will probably no longer work.


Way two: install (or compile) kernel 5.7.9. The sound will work as before.


Way three: compile any fresh kernel with this patch. This patch is made for my GL703GM model with ALC295 audio chip, if you have the same audio chip you can change the values ​​"0x1043, 0x1011" according to the values ​​"SubVendor, SubDevice" from the “hwinfo --sound” command.

realtek-gl703gm-5.8.3.patch
--- a/sound/pci/hda/patch_realtek.c	2020-08-24 20:00:05.752727969 +0300
+++ b/sound/pci/hda/patch_realtek.c	2020-08-25 05:28:17.268845951 +0300
@@ -7641,6 +7641,7 @@
 	SND_PCI_QUIRK(0x103c, 0x8736, "HP", ALC285_FIXUP_HP_GPIO_AMP_INIT),
 	SND_PCI_QUIRK(0x103c, 0x877a, "HP", ALC285_FIXUP_HP_MUTE_LED),
 	SND_PCI_QUIRK(0x103c, 0x877d, "HP", ALC236_FIXUP_HP_MUTE_LED),
+	SND_PCI_QUIRK(0x1043, 0x1011, "ASUS GL703GM", ALC295_FIXUP_ASUS_MIC_NO_PRESENCE),
 	SND_PCI_QUIRK(0x1043, 0x103e, "ASUS X540SA", ALC256_FIXUP_ASUS_MIC),
 	SND_PCI_QUIRK(0x1043, 0x103f, "ASUS TX300", ALC282_FIXUP_ASUS_TX300),
 	SND_PCI_QUIRK(0x1043, 0x106d, "Asus K53BE", ALC269_FIXUP_LIMIT_INT_MIC_BOOST),

Way four (best): compile any fresh kernel with this patch. This patch undoes the problematic changes in the code and your sound will work as on the 5.7.9 kernel.

realtek-5.8.3.patch
--- a/sound/pci/hda/patch_realtek.c	2020-08-24 20:00:05.752727969 +0300
+++ b/sound/pci/hda/patch_realtek.c	2020-08-24 20:17:14.184536126 +0300
@@ -7132,7 +7132,7 @@
 			{ }
 		},
 		.chained = true,
-		.chain_id = ALC269_FIXUP_HEADSET_MIC
+		.chain_id = ALC269_FIXUP_HEADSET_MODE_NO_HP_MIC
 	},
 	[ALC294_FIXUP_ASUS_HEADSET_MIC] = {
 		.type = HDA_FIXUP_PINS,
@@ -7141,7 +7141,7 @@
 			{ }
 		},
 		.chained = true,
-		.chain_id = ALC269_FIXUP_HEADSET_MIC
+		.chain_id = ALC269_FIXUP_HEADSET_MODE_NO_HP_MIC
 	},
 	[ALC294_FIXUP_ASUS_SPK] = {
 		.type = HDA_FIXUP_VERBS,
@@ -7149,8 +7149,6 @@
 			/* Set EAPD high */
 			{ 0x20, AC_VERB_SET_COEF_INDEX, 0x40 },
 			{ 0x20, AC_VERB_SET_PROC_COEF, 0x8800 },
-			{ 0x20, AC_VERB_SET_COEF_INDEX, 0x0f },
-			{ 0x20, AC_VERB_SET_PROC_COEF, 0x7774 },
 			{ }
 		},
 		.chained = true,

Both last patches are made for the kernel version 5.8.3, for other versions the patches need to be adjusted.

8 Likes

I’'m not OP, but I had the same problem, I used the first way and it fixed the issue, thank you so much!

OP has a different Product ID shown in alsa-info.sh data 0x1043, 0x1bc0

!!HDA-Intel Codec information

Codec: Realtek ALC295

Subsystem Id: 0x10431bc0

I cannot find a patch added to kernel for 0x1043, 0x1bc0 or 0x1043, 0x1011
has this patch been reported to bugzilla or pushed to kernel developers?

i did find a recent patch for Asus GA702 - 0x1043, 0x1e11
https://lkml.org/lkml/2020/8/3/720

that patch is reconfiguring pin 0x19, that appears to be the same pin/node that is incorrectly detected on OP’s system as a speaker instead of a microphone

Node 0x19

Node 0x19 [Pin Complex] wcaps 0x40048b: Stereo Amp-In
Control: name=“Headset Mic Boost Volume”, index=0, device=0
ControlAmp: chs=3, dir=In, idx=0, ofs=0
Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
Amp-In vals: [0x00 0x00]
Pincap 0x00003724: IN Detect
Vref caps: HIZ 50 GRD 80 100
Pin Default 0x411111f0: [N/A] Speaker at Ext Rear
Conn = 1/8, Color = Black
DefAssociation = 0xf, Sequence = 0x0
Misc = NO_PRESENCE
Pin-ctls: 0x24: IN VREF_80
Unsolicited: tag=02, enabled=1
Power states: D0 D1 D2 D3 EPSS
Power: setting=D0, actual=D0

can you please share alsa-info.sh data for patched system

it might be possible to work out a solution using hdaverb or hdajackretask

My opinion is that the code that causes regression should be removed from the source code, instead of coming up with countless patches for each model. I showed you in my patch “realtek-5.8.3.patch” which changes cause regression. I have never submitted bug reports and do not know how to properly convey this to the developers.


Commit #1, commit #2, most likely the first commit is causing the problem.

Hi Takashi,

ASUS platform couldn’t need to use Headset Mode model.
Attach patch will change it.

BR,
Kailang

And everything broke, just fine.


My alsa-info.txt

1 Like

Just to know, is there a place (kernel bugs? alsa bugs? … bugs?) where can I report this issue too?

Unfortunately I need a working microphone and, sadly, I do not know how to compile the patch you kindly provided; for these reason I asked if there was a “place” where reporting bugs like this thus they could be solved “upstream”.

Edit:

Bug reported here https://bugzilla.kernel.org/show_bug.cgi?id=209045

1 Like

your alsa-info.sh data includes DMESG data to confirm that pin 0x19 relates to the headset microphone location
[ 6.261983] snd_hda_codec_realtek hdaudioC0D0: Headset Mic=0x19

I did some difference comparisons on the ALSA data for the 3 similar laptops identified so far
GL703GE @rovovav982 [1043:1bc0]
GL703GM @ZeroAnarchy [1043:1011]
GL503VD @pidz-b [1043:1bb0]

I expected to see a difference in the configuration for pin 0x19, but configurations for all 3 are identical

/sys/class/sound/hwC0D0/init_pin_configs:

0x12 0x90a60130
0x13 0x40000000
0x14 0x411111f0
0x16 0x411111f0
0x17 0x90170110
0x18 0x411111f0
0x19 0x411111f0
0x1a 0x411111f0
0x1b 0x411111f0
0x1d 0x40679a2d
0x1e 0x411111f0
0x21 0x03211020

main difference appears to be that your system has kernel v5.8.3 and the other systems have v5.8.1

I had the same problem and used method one. Thanks so much for posting your solution. Have a great day!

Method one works for me, for headphone AND microphone. Thank you !

Have a great days !

I tried the first solution, and my headset audio finally worked again, but as expected, the mic didn’t work anymore. After doing some research I tried pasting “options snd-hda-intel model=dell-headset-multi” to “/etc/modprobe.d/alsa.conf” instead, and this completely fixed the problem (I have a ASUS GL703VM). When booting with the headset plugged in, you often have to unplug and plug in again for it to work. (Actually, every time you plug in a device to the audio jack, it asks what kind of device it is).
Thank you for helping me find the solution!

5 Likes

I had no sound for months. Thanks for this thread. I suggest someone pin it, please.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.