Headphones do not pick up sound but speakers do

Hello! I’m having a problem with audio, for some (short, since I always put a lot of) context:

My school gave me a chromebook so I could speak during class instead of using the chat, these tipically come with Linux and Windows, when I tried Linux, it was so old it wouldn’t let me update it, and there was an error when using apt that to fix, I had to update the system.
I ask the person who gave me this machine if I could install a newer, more up to date version with the .iso file I have of manjaro from when I installed it on my machine, they gave me the go-ahead, I set it up as close as I could to the previous os, it installed correctly, microphone and camera worked but audio was silent.

I’ve tried many solutions online but none seem to work:

  • Tried setting the correct drivers in alsamixer
  • Tried changing devices on the audio mixer
  • Tried updating the os
  • Tried the solutions in a forum post: Those didn’t do anything, I haven’t tried the ones that require me to compile a kernel with a certain patch because I’m not sure how to do that, and if the patch is already on my kernel (5.10.42-1)

I’ve decided it’s probably better to make a post myself, in advance, here’s the output of inxi -Fuzy

  Kernel: 5.10.42-1-MANJARO x86_64 bits: 64 Desktop: Xfce 4.16.0 
  Distro: Manjaro Linux 
  Type: Laptop System: Coradir S.A. product: Coradir/ES10IS5 v: Clamshell 
  serial: <filter> 
  Mobo: Intel model: Intel powered classmate PC v: Clamshell serial: <filter> 
  UEFI-[Legacy]: Phoenix v: SPCDV10L.91A.0045.2013.0315.1545 date: 03/15/2013 
  ID-1: BAT1 charge: 44.3 Wh (100.0%) condition: 44.3/47.5 Wh (93.2%) 
  Info: Dual Core model: Intel Atom N2600 bits: 64 type: MT MCP cache: 
  L2: 512 KiB 
  Speed: 1110 MHz min/max: 600/1600 MHz Core speeds (MHz): 1: 1110 2: 1055 
  3: 672 4: 797 
  Device-1: Intel Atom Processor D2xxx/N2xxx Integrated Graphics 
  driver: gma500 v: N/A 
  Device-2: Acer USB Camera type: USB driver: uvcvideo 
  Display: x11 server: X.Org 1.20.11 driver: loaded: modesetting 
  s-res: 1024x600 
  OpenGL: renderer: llvmpipe (LLVM 12.0.0 128 bits) v: 4.5 Mesa 21.1.2 
  Device-1: Intel NM10/ICH7 Family High Definition Audio driver: snd_hda_intel 
  Sound Server-1: ALSA v: k5.10.42-1-MANJARO running: yes 
  Sound Server-2: PulseAudio v: 14.2 running: yes 
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169 
  IF: enp1s0 state: down mac: <filter> 
  Device-2: Realtek RTL8188CE 802.11b/g/n WiFi Adapter driver: rtl8192ce 
  IF: wlp2s0 state: up mac: <filter> 
  Local Storage: total: 298.09 GiB used: 7.44 GiB (2.5%) 
  ID-1: /dev/sda vendor: Western Digital model: WD3200BPVT-22JJ5T0 
  size: 298.09 GiB 
  ID-1: / size: 39.08 GiB used: 7.44 GiB (19.0%) fs: ext4 dev: /dev/sda1 
  uuid: cda7cc4d-2ae7-4d32-b637-641e24a85c70 
  Alert: No swap data was found. 
  System Temperatures: cpu: 48.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 205 Uptime: 1h 50m Memory: 1.92 GiB used: 1.45 GiB (75.2%) 
  Shell: Bash inxi: 3.3.04

While I’m at it, on the rules it says that commands with output should be in english, I’m not a native english speaker so some text is in spanish, there was a command to set them in english but I didn’t understand how to use it. If I need to run another command, I’d appreciate if you could tell me how to set the output to be in english.

Thanks, Teo.

Try this:

  1. In a terminal execute alsamixer
  2. Press F6: Choose the sound card:
  3. Check that Headphon does not show MM:
  4. If it does, use the left / right arrow keys to select it (text turns red).
  5. Press the m key. MM changes to 00.
  6. Use the up arrow key to increase the volume, or press the number keys (1 = 10; 2 = 20).

Maybe someone in the Spanish forum could help: Español - Manjaro Linux Forum

I had a similar problem on my pc and found the solution in a post from another forum

first try installing pavucontrol and check in outputs if headphone is detected, and if you can manually change to headphones from there.

If you hear sound from both outputs (speakers and headphones) then do this:

i just change one line of one file and done.

The file name is


and is located in


In the file find [Element Front] and Front is the name of my Speakers in my system, so in the line switch i change from mute to off:

Code: Select all

[Element Front]
switch = off
volume = zero

I installed pavucontrol to change my outputs manually and turned auto-mute off in alsamixer and it worked.

here is the original post if you want to read more

I know is Linux Mint but it worked :stuck_out_tongue:

If you are having to much trouble with your audio you could try pipewire. I am using it now and it works fine.

Hello, I apologize for the late reply, I got bussy irl and forgot to reply what I tested yesterday:

I forgot to mention that I did in fact check if headphon said “MM” in alsamixer, I checked again and it still doesn’t, in fact it was at 100 for some reason.

For Orognad’s reply, I can’t try this right now but I’ll update whenever I can.

Thanks for your patience.

I have no idea why it’s doing this, but setting it to speakers (marked as unavaiable when headphones are plugged in) just makes the sound work…
I’ll mark this as a solution, i guess?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.