Shared HDD (win e Manjaro) error read-only file system

Hi everybody, it’s the first time I need to ask a question on the Forum, i normally find an answer just serching! But after some week of research I can’t fix thiis problem.
I am on a laptop with Manjaro and Win installed, I use an internall SSD (NFTS) just for data and I share it between the 2 systems, now when I am on Mnjaro I can access the SSD only in Read mode, and I can not change the ownership neither the permissions…
Here what I tried:
first of all :


[color=red]sda 8:0 0 931,5G 0 disk
└─sda1 8:1 0 931,5G 0 part /run/media/canelesso/SSD250[/color]
sdb 8:16 0 1,8T 0 disk
└─sdb1 8:17 0 1,8T 0 part /run/media/canelesso/Seagate Expansion
nvme0n1 259:0 0 476,9G 0 disk
├─nvme0n1p1 259:1 0 100M 0 part
├─nvme0n1p2 259:2 0 16M 0 part
├─nvme0n1p3 259:3 0 476,3G 0 part /run/media/canelesso/1EC84C1EC84BF297
└─nvme0n1p4 259:4 0 509M 0 part
nvme1n1 259:5 0 238,5G 0 disk
├─nvme1n1p1 259:6 0 300M 0 part /boot/efi
└─nvme1n1p2 259:7 0 238,2G 0 part /

then I tried

sudo chown -R canelesso:canelesso /run/media/canelesso/SSD250/

but nothing, I ALWAYS get the same error read-only file system

I hope somebody can help me fix the problem!
thx in advance!

Have you disabled Fast Startup in Windows?,_refused_to_mount

NTFS is not a POSIX-compatible filesystem and does not store POSIX file ownership information or permissions. This means that the ownership and permissions must be emulated by the Linux kernel upon mounting the filesystem into the virtual filesystem layer.

Given that the filesystem is mounted somewhere under the /run hierarchy ─ which only exists in memory while the system is up and running, because /run itself is mounted as a tmpfs ─ you are obviously relying on the automagic from the udisks2 subsystem of systemd.

Better is to put up a static mountpoint for the filesystem and static mount options in /etc/fstab. Here’s how to do it… :arrow_down:

  • First, create a directory that this filesystem must be mounted on. Given that you’re most likely using the filesystem to store personal data for your user account ─ as opposed to data that must be shared between all accounts ─ I recommend that you create this directory inside of your own home directory, e.g. as /home/canelesso/ssd250, in lowercase (because that’s easier to type). :arrow_down:
mkdir /home/canelesso/ssd250
  • Next, you must set up the mount options for the filesystem in /etc/fstab. This requires root privileges, and as I don’t know what graphical environment and GUI editor you’d be using, I’ll describe the procedure by way of a terminal-based editor. :arrow_down:
lsblk -o UUID /dev/sda1

Write down that UUID or copy it to the clipboard.

sudo nano /etc/fstab

Add a line for the new filesystem… :arrow_down:

UUID=THE-UUID-YOU-COPIED  /home/canelesso/ssd250  ntfs-3g  auto,nofail,uid=1000,gid=1000,utf8,umask=022,defaults   0   0

Make sure there are no commas between the mount options. Save the file with Ctrl+O and Enter, and exit nano with Ctrl+X.

Exit the terminal by pressing Ctrl+D. If you reboot now, then the filesystem will automatically be mounted at /home/canelesso/ssd250 and will be writable to you. :wink:

Note: As @maycne.sonahoz said, Windows Fast Boot must be disabled, because it leaves the Windows filesystems in an open state, which the Linux kernel will interpret as potential filesystem damage, and then it will resort to a read-only mount to prevent further damage to said filesystem.


I mean guys…THANX a lot I finally manage to solve the problem! I would never got there by myself!


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.