Second Monitor problem

KDE Plasma. I have a laptop as the main screen and a second monitor and all has run well for many months.
Recently when I start the laptop the wallpaper on the plug in monitor appears half on one screen and half on the other. It I open the web browser which is set to the second monitor that opens correctly. I haven’t altered anything.
Any ideas please?
I have two screen shots of the problem, how do I post them up please?

Hi @heppy, and welcome!

In order for us, or anyone for that matter, to be able to provide assistance, more information is necessary. To that end, please see:

Hope you manage!

:bangbang: Tip: :bangbang:

To provide terminal output, copy the text you wish to share, and paste it here, surrounded by three (3) backticks, a.k.a grave accents. Like this:

pasted text

Or three (3) tilde signs, like this:

pasted text

This will just cause it to be rendered like this:

Portaest sed
cursus nisl nisi
hendrerit ac quis
tortor sit leo commodo.

Instead of like this:

Portaest sed elementum cursus nisl nisi hendrerit ac quis sit adipiscing tortor sit leo commodo.

Alternatively, paste the text you wish to format as terminal output, select all pasted text, and click the </> button on the taskbar. This will indent the whole pasted section with one TAB, causing it to render the same way as described above.

Thereby improving legibility and making it much easier for those trying to be of assistance.

:bangbang::bangbang: Additionally

If your language isn’t English, please prepend any and all terminal commands with LC_ALL=C. For example:

LC_ALL=C bluetoothctl

This will just cause the terminal output to be in English, making it easier to understand and debug.

Please edit your post accordingly.

Hope this is what you want

  Kernel: 5.10.161-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64
    root=UUID=d75e5371-b9a2-4008-8d0a-fb9951bb6e65 rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: KDE Plasma v: 5.26.4 tk: Qt v: 5.15.7 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Hewlett-Packard product: HP Pavilion g6 Notebook PC
    v: 068F130000204710000620100 serial: <superuser required> Chassis: type: 10
    serial: <superuser required>
  Mobo: Hewlett-Packard model: 166F v: 09.4C serial: <superuser required>
    BIOS: Insyde v: F.66 date: 01/24/2013
  ID-1: BAT0 charge: 41.5 Wh (100.0%) condition: 41.5/41.5 Wh (100.0%)
    volts: 12.3 min: 10.8 model: Hewlett-Packard Primary type: Li-ion serial: N/A
    status: full
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M315/M235
    serial: <filter> charge: 5% (should be ignored) rechargeable: yes
    status: discharging
  RAM: total: 5.75 GiB used: 3.27 GiB (56.8%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Pentium B960 bits: 64 type: MCP arch: Sandy Bridge
    level: v2 built: 2010-12 process: Intel 32nm family: 6 model-id: 0x2A (42)
    stepping: 7 microcode: 0x2F
  Topology: cpus: 1x cores: 2 smt: <unsupported> cache: L1: 128 KiB
    desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB L3: 2 MiB
    desc: 1x2 MiB
  Speed (MHz): avg: 841 high: 885 min/max: 800/2200 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 885 2: 798 bogomips: 8783
  Flags: acpi aperfmperf apic arat arch_perfmon bts clflush cmov
    constant_tsc cpuid cx16 cx8 de ds_cpl dtes64 dtherm dts epb est flush_l1d
    fpu fxsr ht ibpb ibrs lahf_lm lm mca mce md_clear mmx monitor msr mtrr
    nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pebs pge pln pni
    popcnt pse pse36 pti pts rdtscp rep_good sep ssbd sse sse2 sse4_1 sse4_2
    ssse3 stibp syscall tm tm2 tsc tsc_deadline_timer vme x2apic xsave
    xsaveopt xtopology xtpr
  Type: itlb_multihit status: KVM: VMX unsupported
  Type: l1tf mitigation: PTE Inversion
  Type: mds mitigation: Clear CPU buffers; SMT disabled
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: disabled, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
    vendor: Hewlett-Packard driver: i915 v: kernel arch: Gen-6
    process: Intel 32nm built: 2011 ports: active: LVDS-1,VGA-1
    empty: DP-1,HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:0106 class-ID: 0300
  Device-2: Primax webcam type: USB driver: uvcvideo bus-ID: 2-1.5:5
    chip-ID: 0461:4de7 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.6 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,vesa dri: crocus gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3936x1050 s-dpi: 96 s-size: 1038x277mm (40.87x10.91")
    s-diag: 1074mm (42.3")
  Monitor-1: LVDS-1 pos: primary,bottom-r model: LG Display 0x02f2
    built: 2010 res: 1366x768 hz: 60 dpi: 101 gamma: 1.2
    size: 344x194mm (13.54x7.64") diag: 395mm (15.5") ratio: 16:9
    modes: 1366x768
  Monitor-2: VGA-1 pos: top-left model: LE22A3 serial: <filter> built: 2007
    res: 1680x1050 hz: 60 dpi: 90 gamma: 1.2 size: 473x296mm (18.62x11.65")
    diag: 552mm (21.7") ratio: 16:10 modes: max: 1680x1050 min: 720x400
  API: OpenGL v: 3.3 Mesa 22.3.1 renderer: Mesa Intel HD Graphics 2000 (SNB
    GT1) direct render: Yes
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
    vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:1c20 class-ID: 0403
  Sound API: ALSA v: k5.10.161-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.63 running: yes
  Device-1: Ralink RT5390 Wireless 802.11n 1T/1R PCIe vendor: Hewlett-Packard
    U98Z077.00 Half-size Mini driver: rt2800pci v: 2.3.0 pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 01:00.0 chip-ID: 1814:5390 class-ID: 0280
  IF: wlp1s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet
    vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: 3000 bus-ID: 02:00.0 chip-ID: 10ec:8136 class-ID: 0200
  IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 63.15 GiB used: 41.52 GiB (65.7%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SV300S37A60G
    size: 55.9 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: BBF0 scheme: MBR
  ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Sony model: Storage Media
    size: 7.25 GiB block-size: physical: 512 B logical: 512 B type: N/A
    serial: <filter> rev: PMAP scheme: GPT
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  Optical-1: /dev/sr0 vendor: hp model: DVD RW AD-7740H rev: 1.80
    dev-links: cdrom
  Features: speed: 24 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
  ID-1: / raw-size: 55.9 GiB size: 54.72 GiB (97.89%) used: 39.18 GiB (71.6%)
    fs: ext4 dev: /dev/sda1 maj-min: 8:1 label: N/A
    uuid: d75e5371-b9a2-4008-8d0a-fb9951bb6e65
  ID-2: /home/<filter>/pCloudDrive raw-size: N/A size: 7 GiB
    used: 2.34 GiB (33.4%) fs: fuse source: ERR-102
  Alert: No swap data was found.
  ID-1: /dev/sdb1 maj-min: 8:17 size: 2.28 GiB fs: iso9660
  ID-2: /dev/sdb2 maj-min: 8:18 size: 4.1 MiB fs: vfat label: ESP
    uuid: 8D6C-A9F8
  ID-3: /dev/sdb3 maj-min: 8:19 size: 4.97 GiB fs: ext4 label: writable
    uuid: 01b4f95a-b64f-48de-be4a-0bca123707dd
  Hub-1: 1-0:1 info: Full speed or root hub ports: 2 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:0024 class-ID: 0900
  Hub-3: 2-0:1 info: Full speed or root hub ports: 2 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 2-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:0024 class-ID: 0900
  Hub-5: 2-1.1:3 info: Genesys Logic Hub ports: 4 rev: 2.0 speed: 480 Mb/s
    power: 100mA chip-ID: 05e3:0608 class-ID: 0900
  Device-1: 2-1.1.2:6 info: China Resource Semico USB Keyboard
    type: Keyboard,HID driver: hid-generic,usbhid interfaces: 2 rev: 1.1
    speed: 1.5 Mb/s power: 100mA chip-ID: 1a2c:0c23 class-ID: 0300
  Device-2: 2-1.1.3:7 info: Canon PIXMA iP3600 Printer type: Printer
    driver: usblp interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 2mA
    chip-ID: 04a9:10ca class-ID: 0701 serial: <filter>
  Device-3: 2-1.1.4:8 info: Logitech Unifying Receiver type: Mouse,HID
    driver: logitech-djreceiver,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s
    power: 98mA chip-ID: 046d:c52f class-ID: 0300
  Device-4: 2-1.2:4 info: Sony Storage Media type: Mass Storage
    driver: usb-storage interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 200mA
    chip-ID: 054c:05ba class-ID: 0806 serial: <filter>
  Device-5: 2-1.5:5 info: Primax webcam type: Video driver: uvcvideo
    interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 0461:4de7
    class-ID: 0e02 serial: <filter>
  System Temperatures: cpu: 45.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 193 Uptime: 5m wakeups: 3 Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman
  pkgs: 1435 libs: 409 tools: pamac pm: appimage pkgs: 0 pm: flatpak pkgs: 0
  Shell: Zsh v: 5.9 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.24
    ~                                                                                                                        ✔ 

Hopefully screen shots
Screenshot, 2023-01-12 20:05:20 - Paste.Pics
Screenshot, 2023-01-12 20:10:13 - Paste.Pics

I was going to ask: what have you tried to fix it?

Because I initially overlooked this:

not even tried?
just straight up asked?

just straight up asked?

I have found out if I use the Shutdown button rather than OK or the timer the screens load correctly on startup. Does that help?

Also found out if I turn Compositor off that also cures the problem. Obviously I also lose hot corners.

Humble apologies this was obviously a dumb question from an Oldie

Hi @heppy,

There is no such thing as a dumb question.

Unfortunately, I do not know what the cause can be. Except checking in System SettiingsHardwareDisplay and MonitorDisplay Configuration:

This is a screenshot from my setup, maybe it helps. Hope it does.

Thanks for the reply. I have tried altering display setting but no difference.
Looks like I shall just have to live with it and remember to use the Shutdown button. Just odd as I have been using Manjaro for a couple of years and the problem has only just occurred.
Thanks anyway.

1 Like

If it worked before, as you say, try a bit older kernel, maybe? Or a newer one? Or something.

Thanks again, I think I will just leave as is, I’m very good at messing things up.

Myself as well.

The important thing is just to learn something from the experience. Whether that something is how to recover from a disaster, or how to avoid it, or what to actually do is irrelevant.

For example, due to the many posts regarding specifically this here, on the forum, as well ass a recommendation by none other than @philm himself, as well as some personal experience, I’ve learned that using pamac to upgrade, instead of pacman is better. Especially for newcomers. Why would I say this? Because it takes care of a lot mor things that you’ve got to do manually if you use pacman. If you want to use pacman, then go right ahead. But then be aware of my point above, ‘is all I’m sayin’.


If you want to switch kernels, I recommend looking at the Wiki for instructions:

I see you’re using 5.10:

So perhaps try 5.4 as it was the LTS just before 5.10, or even 5.15 since it’s the one just after 5.10.

1 Like