Plasma Panel transparance is bugged, stays transparent

I have a relatively fresh Manjaro Plasma minimal install, however I believe since I logged in to a X11 session(or maybe for some other reason), to try to troubleshoot a bug, I noticed that I cannot make the Plasma panel/kickoff menu non-transparent or “adaptive”.

See screenshots:
  1. Exiting edit mode
  2. Notice that the setting hasn’t changed

  3. (Sometimes the toggle(1.) doesn’t even work and it instantly reverses the setting to “transparent”)
    I have a video but cant upload it here.

So currently I cannot have either “adaptive” or “opaque/covering”, it just instantly reverts the setting to “transparent” and I cant notice any - even temporary - changes to the panel’s transparency.

I am using the Breath Panel, however creating a default panel to test if the setting works with that shows that it doesn’t. Shortly before this incident I could indeed set the Panel to be opaque, but in a very pitch black way only and when I tried logging out and in again this behavior appeared.

Potentially relevant information:

Operating System: Manjaro Linux 
Branch: Stable
KDE Plasma Version: 6.0.4
KDE Frameworks Version: 6.1.0
Qt Version: 6.7.0
Kernel Version: 6.9.0-1-MANJARO (64-bit)
Graphics Platform: Wayland
Graphics Processor: AMD Radeon RX 6800 XT

Please tell me if I can provide any logs etc or if is indeed a know issue and/or has already been reported upstream.

This tells me your theme is not compatible with plasma 6 or is otherwise incomplete.

Please switch your desktop theme.
Breeze as the control.

Extra explanation:
Those settings correspond to “Opaque”, “Solid” and “Translucent” folders in the plasma desktop theme directory. I just checked and Breath does not have these directories. So it will not function correctly with those plasma panel settings.

For some further styles besides the default that I know works with plasma 6 see all the Mace things:


Switching to the Breeze theme does indeed allow me to switch the setting persistently. However it seems that with that I can reproduce the instance where the panel appears pitch black and somewhat pixilated, if I operate an application in full screen and have the panel’s opacity set to “Translucent”:

Edit: This issue seems to disappear if I log out and in again.

The pixely thing is probably something else.

Is it specifically on wayland? Or does not matter?
Hidpi? Using a display scale factor like 1.25x ?

I had a similar error that presented a little differently. But may be of interest to you.
Here is my applied workaround with commented reference;

# qt wayland font bug

In case that in any way related to some of the other variables here are the other QT ones I have

# QT wayland
# Less Debug Logging
# Some hidpi stuff for QT

It indeed happens on Wayland, haven’t tested X11 yet. But I am indeed using a 1.5x display scale factor (and 1.75x on my second screen).
Edit: Ok after a restart using the Breeze theme as recommended works, all panel modes seem to work as intended.

continuing to offer breath if it is incomplete for plasma6 is probably not very wise

Maybe, however it looks better or to be a bit more objective, Breeze is also incomplete for Plasma 6, take a look at the icon pack applied in Dolphin for instance:

The Iconpack used in Breath looks plain consistent, the one I get with Breeze looks like a bug to be honest.
Fortunately I can use the Breeze Theme and apply the Breath icon pack(and accent colour) to it, but still, I assume this will get fixed soon, but if not I am going to report it as well.

I have reported it to the team, which is all I can do for now.

1 Like

Thanks a lot, that’s all I am asking for. I just want to report all issues I have on Manjaro, in order to make this distro and Linux as a whole better.
And since this is a fresh install most issues I am facing should be issues everyone could be facing after their first Manjaro install.

1 Like

something is wrong with your breeze icons, i have the same ones as you show in first image

edit: in fact i don’t even have breath icons installed, even when the theme is.

I also only have “Breeze”-icons and “Breeze dark”-icons, with “Breeze”-icons it works(the “Breath Dark”-theme is using that one) with the “Breeze Dark”-icons which the “Breeze Dark”-theme is using it doesn’t look as good.
You can either switch the icon pack directly or click on a theme and go to more options and than only check the box to apply the icon pack of e.g. the “Breeze Dark” theme.

TLDR: The Breeze Dark icons are the ones at fault, the Breeze theme uses the Breeze Dark icon pack, while the Breath Dark theme uses the Breeze icon pack.

It’s the opposite, it’s Breath who is not following Breeze standard. In Breeze, the standard is: small icons like 16px and 22px should appear monochrome, because it’s easier for eyes to differentiate the details with small monochrome icons.

And when you increase the size above 22px, they will become colorful

Thanks for the reply,
however I have 4 icon packs installed “Adwaita”, “Breeze”, Breeze Dark and “HighContrast”.
Breath Dark seems to utilize the “Breeze” icons, while Breeze Dark seems to utilize Breeze Dark icons.
Both have a scale of 22x22. I did not change any of that.
And this is how they look in Dolphin for me:

As you can clearly see ‘Breeze’ does it “right” while ‘Breeze Dark’ does it “wrong” aka at 22px it doesn’t use the monochrome icons.

I did not mess with the theme or installed/uninstalled any, I just switched between themes and applied/reapplied them. From manually applying the “Symbols” aka icon themes of a theme while keeping everything else from the previous theme I found out which theme uses which icons. The results is what you can see above.
I hope this was helpful, thx.

Btw, should we move this to an independent thread?

Don’t apply a different icon theme to another global theme.

Go to Global theme, apply Breeze global theme then reapply Breeze Dark global theme, and retest again.

Thx for the reply.
Applying Breeze the icons work as intended, monochrome.
If I afterwards directly apply the Breeze Dark global theme the icons are colourful again. Checking which icon pack is used for which Theme, I can see that Breeze uses the “Breeze” icons while Breeze Dark uses the Breeze Dark icons.

and that’s what you would expect, right? i use breeze dark with breeze dark icons and it works perfectly

edit: i suspect you misreported breath as breeze in your reply, but it does not change the fact it works for me on a close to 6 year old install. If you have problems on a very fresh install, then it might be an issue with recent install media.

I can see that Breeze uses the “Breeze” icons while Breeze Dark uses the Breeze Dark icons.

Ok, we all seem to be right about this.
I was able to reproduce this issue within a live environment:

  1. Switch to Breeze (Dark) Theme(up until now everything works as intended)
  2. Switch display scale above 100%
  3. Icons are not monochrome anymore(after relaunching Dolphin etc)

Works on both X11 and Wayland, however setting the scale to a value below 100% (on Wayland that is possible) doesn’t trigger the unintended behavior.

Maybe some of you could confirm that this issue exists for them as well, if not at least in a live environment.
If someone can confirm this issue I could open a separate thread in case @cscss mention is not sufficient.

1 Like

So it seems you found a icon ↔ scaling bug ?

that only happens with breeze, not breath?

If so we have undefined behavior with both breeze and breath themes, which is highly unfortunate. And displays lack of testing.

1 Like

Yes, maybe you could try to reproduce that and if so confirm it in the thread I just opened.
Thanks for your help troubleshooting.

1 Like

As investigated by Nate, the problem of monochrome icons with scaling above 100% seems to be a recent regression in Qt6.7.