Pamac update and VirtualBox

I run Manjaro Cinnamon edition on a Thinkpad X230t. I have 3 different issues, but I put them in one post because I think they are related.

Issue 1: For a about 2 months I noticed that in the shut-down window, the ‘Shut-Down’ button is Red? as in the attached screenshot:
It does not seem to have any effect on the buttons functionality?
This issue has not been resolved.

Issue 2: During the last few updates, I got an error message that said “Unable to lock database and failed to synchronize databases” (may not be the exact words) but the updates still proceeded as if nothing was wrong? A google search lead me to a previous post on this forum, and the solution was to run ‘Pamac update --force-refresh’ I run that command and it looked like a LOT of apps got updated! some 700Mb or so. After a restart all seemed to work fine until I tried to run a VirtualBox VM of Windows 7 That’s where Issue 3 starts

Issue 3: Windows VM ‘Aborted’?? It was working just fine before I decided to run the update command. Back to google and I tried a few suggestions. Basically just changing some of the VM settings. The one that worked was to drop the USB controller setting from 3.0 to 1.1 After that Windows VM started OK, but a pop up window suggested to update the ‘Guest Addition’ (There was no such suggestion prior to running the above command) I proceeded with the install/update of the Guest Addition, but to my surprise I can no longer set the USB controller to 3.0 (one of the function of the guest addition?)

In conclusion issue 2 caused issue 3. Issue 3 persist unless the USB setting is in USB1.1 If I set it in 2.0 or 3.0 the VM aborts I don’t use USBs in the VM so it is not a problem, but I don’t think it’s normal. And issue 1 (the red shut-down button) is still there.
Is there a more serious underlining issue with the system?? any suggestions/advice will be welcome Thanks

Looks like normal Cinnamon theming to me…

So… resolved?


The virtualbox is normal, you’ve needed to have guest editions installed on guest for a long time if you want to use usb > 1.1, I can’t remember when that started, but it was years ago. Sounds like you hadn’t updated your vm or vbox for a long time and then did, so now you are running current which has this component as standard. If you install guest editions by the way on the guest you’ll have a generally better experience if you interact with the guest in the gui a lot. it’s not necessary, but the experience tends to be better.

I use vbox heavily in inxi development and testing, that’s a normal standard current vbox thing.

Your issue 2 kind of confirms it, you had something stuck then you got it unstuck, and finally ran the real upgrade, so things changed to what they are now, and have been for a while.

The cinnamon is clearly intended to be that way, it’s correctly styled, red background, white font, that wouldn’t happen by accident. They probably made the shutdown button red because people were accidentally shutting down when they meant to logout or suspend or hibernate.

You can’t set the usb controller to anything but 1.1 unless you have guest editions updated, but I don’t honestly remember much since I don’t usually bother, I run so many virtual machine operating systems I don’t really care about keeping that stuff up to date, but vbox won’t boot the os if the usb mode is not correct, I also some years back had to change all mine to usb 1.1 for the same reason, images weren’t booting.

I don’t know how arch/manjaro do the vbox guest editions packaging, but basically a package has that as an iso file, and you simply boot the os with that iso mounted as a cd image, then run the relevant executable on that iso from inside the guest os, and it installs the guest additions drivers to the guest os (not the host, remember). I don’t know how vbox determines the right drivers are installed on the guest, as noted, I don’t really try to maintain my many guest images, I just boot them to check stuff so I don’t care if everything works optimally anymore, but that’s how that works roughly.;

You’re probably wright but the change only happened less than 2 months ago and on another computer I run Linux Mint Cinnamon 20.3 (the makers of the Cinnamon desktop) and there it is black text on grey button like the other buttons.

Yes Issue is resolved.

Thanks for that link, while it did not solve the issue, it pointed to the cause of the issue. It turns out that the distributions repo updates VirtualBox, the kernels host modules, and the Guest additions along with everything else, BUT it does not update the ‘VirtualBox Extension Pack’ because of a licensing issue (one has to agree to a license before installation can take place). The extension pack in my system was older than the guest addition. But updating it came with it’s own difficulties! when updating, it asks for the root password but does not recognize it and the install fails!? Its a common issue and there are lots of posts and Youtubes that offer solutions using the CLI, but in my case they did not work either once again a window pops up asking for the root password and does not recognize it. But in the end I found my own dead simple solution that works!
Anybody having the same issue, here is the solution. I’m using the Cinnamon edition, I’m not sure if it works with other editions - I did not test it.

  1. Download the latest Extension Pack from Oracle, make a note of where you downloaded it (i put mine on the desktop)
  2. Open the menu find and click on ‘Root Filemanager’ This will open the file manager as root.
  3. Find the Extension Pack you downloaded earlier, Double-click on it, accept the license and install it - That’s it. :grinning:

Probably obvious, but just to be clear updating the Extension Pack to the same version as VirtualBox and Guest Additions means that you can select and use USB 2.0 or 3.0 and all other improvements that came with the Extension Pack.

Just to add virtualbox is in the Manjaro repos and the extension pack is in aur.
You can add yourself to vboxusers with sudo gpasswd -a $USER vboxusers and can use pamac to keep virtualbox and the extension pack updated.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.