OpenSnitch is causing the same problem!?!

I just installed OpenSnitch from Official Repositories. After a reboot, I ended up with the exact same problem, which I had twice before.

Manjaro is setup to automatically logs in. I don’t have to manually log in.

But when the problem below happens, I get a login screen to enter my password. And even though I select my native desktop theme, Plasma (X11), to log in, and enter my (correct) password, it logs in for 2 seconds and kicks me back out the the same log in screen.

When I select “deepin (Wayland)” desktop theme to log in, it accepts my password, but that’s not my desktop theme.

Since I was able to log in to the “deeping (Wayland) desktop theme, I uninstalled OpenSnitch and all of its Orphans that came along with it. Now, everything is back to normal. So far so god!

My question, that I need your help with, is: what is it about “OpenSnitch” that causes the problem? Any ideas? Any suggestions?

I don’t think my system is broken. I think it’s just some app (package) causing this problem. I just want to install OpenSnitch and want it to work with my system.

First time:

Second time:

No, Plasma X11 works fine with that in VM. But only you have something messed up in your system.

No idea, without your system info and error log.

When you setup the system to login without authentication - other services relying on the user being authenticated will fail.

This is the most probable cause your issue.

My previous experience with Deepin environment is that can be a ‘troublemaker’ - the environment appears to make a lot of assumption with regard to which system it runs on top of.

It may have gotten better - I don’t know for certain.

From the location of this thread, I presume you are using KDE Plasma.

If this actually means something like Deepin (Wayland) login session, it might be best to find a way to remove it, and install the correct Wayland Session, and login to that instead.

As I don’t know whatever other inconsistencies you have with your system, I can’t say that will solve any issues, but it may help to some degree.

I’m not running Manjaro on VM (Virtual Machine). It’s installed in my laptop as the main operating system to replace Window$.

Hence this posting to figure out what it is…!?

KDE Plasma Version: 5.27.10
KDE Frameworks Version: 5.113.0
Graphics Platform: X11

And I need a bit of help, creating an error log regarding this problem I’m having. How do I do that?

Output from these commands will be a good start. Someone should be able to help more with this information:

inxi --admin --verbosity=7 --filter --no-host --width
journalctl --boot=-1 --priority=3 --catalog --no-pager

This problem doesn’t make a big difference between VM and real hardware (your laptop), because Plasma login function is on the higher level “Applications” of OS, but not directly in Kernel.

If you don’t want to post your log and info here, you can compare two identical Plasmas with your same themes, apps and configurations in a new VM and your laptop to see if both reproduce the same issue. This would help you to track the issue and let us know.


My guess is Deepin needs internet connection before login. If OpenSnitch blocks internet request from Deepin, the Deepin login would not work properly.

This is my guess without practical proof. You can find out for yourself why you installed OpenSnitch, why Deepin needs an internet connection when login? Does it work in Offline mode without OpenSnitch? Is Deepin malware?

I too have plasma with automatic login, and opensnitch had no problems. So definitely something to do with your setup.

You could do the classical troubleshooting step of creating a new user in plasma, and see if you can log in to that. This tells you if the problem is with system or user configurations.

And even before this, disable automatic login and see if explicit login cures the crash you see 2 seconds after what was supposed to be automatic login.


Deepin is not proven to be. There is no evidence that anything malicious happens under the hood.

1 Like

I actually disabled auto-login to see if I was going to have the same problem. It didn’t help! I still have the same problem.

And how…!!!

You hit the nail (that’s been sticking out above the rest) right on the head. Do you think this may be one of the areas that can be worked on and improved upon to eliminate this problem, considering the fact that anything man-made has a room for improvement?

You see an app and you think, “Hmm, I can really use that! That would be perfect for what I need!” Then you install it, not realizing that the very app you just installed has gnome or deepin dependencies, which get installed in your system. Some time later at some point, you scratch your head and wonder how the heck in the world you end up with


in your system.

When you try to or want to uninstall a single “deepin” package, then it branches out to other 50 packages, which pamac cannot seem to remove (for a good reason, I guess!?). That’s when pacman comes handy to remove them all just to see your system is crippled the next time you restart it.

Maybe try to replace with original plasma packages?

bash <(curl -s -IA

(write kde at the prompt`)

Note: Since this will try to reinstall pretty much everything that would have been on the ISO … you may have extra packages you wish to remove afterwards.

By sheer coincidence, here is what I figured out!

Disabling auto-login into Plasma (X11) desktop theme (which is my native desktop theme) did not help fix the problem. We already know that!

Then I decided to disable autostart on OpenSnitch when Manjaro booted up, to see if it would start or if I would have the same problem (kicking me back out to the login screen). After the normal system boot-up to Plasma (X11) desktop theme, when I manually launched OpenSnitch, it worked perfectly fine without any problem!!! I was like, “What the heck!?!”

Then I thought the problem might be related to “Autostart” feature in “System Settings” of Manjaro. Then I decided to create a script to automatically start OpenSnitch. The script I created didn’t help, either! I still had the very same problem. I got kicked out of the natively installed Plasma (X11) desktop theme.

Just to recap, as long as OpenSnitch is not on “Autostart” when the system starts (it doesn’t matter if Manjaro is on auto or manual log-in), it is okay. OpenSnitch works fine as long as it is not auto-started!

I don’t know if anybody can make any sense out of this, but if you do, please let me know! I’m all ears for you!

Maybe related to something like


IE - If its autostarted too early it wont allow some early handshake to occur without user approval, but user cannot approve before logged in, blah blah.

Autologin is rarely a good idea. Make sure to revert that.


Would autostarting OpenSnitch as a systemd unit be of any possible benefit, considering the OP’s recent revelation:

1 Like

That would be the first thing you do after installation.

systemctl enable --now opensnitchd

The autostart feature is only the ui - the daemon itself must be running for opensnitch to function.

OpenSnitch defaults to an aggressive monitoring of outgoing connections which can be pretty annoying - so I suggest diving into the available documentation at Home · evilsocket/opensnitch Wiki · GitHub

Desktop Environment does not boot up

The related issue

Portmaster as second option

Portmaster is in the repo portmaster-stub

The firewall provides extra features if you have need of support or access to SPN (Safing Privacy Network)

please disregard the ranting and whining comments in this topic


Very interesting!?!

First I executed the command below in terminal

systemctl enable --now opensnitchd

Then I created the script below with 1 second delay and named it “OpenSnitch_Script” and made it executable (sudo chmod +x OpenSnitch_Script) and auto-started the script I created and it worked without any problem. It did work!!! I’m beside myself. :smiley:

sleep 1 && opensnitch-ui

Wonderful. Now, both of you, give @linux-aarhus a little tick (under his post).

So it was related to a service … the opensnitch service … not being started. :sweat_smile:

Well, not exactly!

Right after I read your comment, I went ahead and completely removed the delay from the executable script I created, just to see what would happen without the “1 second” delay. It did not work again! I could not log in to Plasma (X11) desktop theme. Well, it would be “incorrect” to say, “I could not log in”. I was able to log in, but within 2 seconds after the login, I got kicked back out to the login screen again, which was exactly the very same problem I had, all along!

To be honest with you, I really don’t know what “1 second” delay does or what it triggers because (let’s face it!?!) 1 second delay is not much of anything to make any difference in terms of Manjaro doing what it needs to do under the hood, if you will…

It appears to me, correct me if I’m wrong!, that rather than amount of time it needs, it is just the “interruption” that the delay provides that fixes the issue that I’m having. I hope I was articulate enough to explain it properly.

Now that the service is starting correctly, your script is no longer needed. Don’t forget to remove it. :wink: