Unable to log in to Plasma (X11) after system update

After system update, Manjaro does not automatically boot up to Plasma (X11) without log-in screen. I didn’t have a log-in screen before. It was automatic.

When I enter the correct log-in password, it logs in to Plasma (X11), then it kicks me back out to the same log-in screen again.

In the initial log-in screen, “Desktop Session” is located on the left bottom corner. I’m able to log in to different session (that I’ve never used or installed before), but it doesn’t log in to the native session, “Plasma (X11)”

It is similar to the problem posted below. However, the initial issue below was due to “libimobiledevice-git” and “ultimately gnome-shell-extension-tray-icons-reloaded-git”. But both are removed now.

sudo pacman-mirrors -f && sudo pacman -Syu

That will sort mirrors and update for starters. Share any errors.
We can also check your pacnews:

pacdiff -o

And, if in any way similar to before … lets see foreign packages:

pacman -Qm

Hi cscs!

Please see below for the printout of sudo pacman-mirrors -f && sudo pacman -Syu

::INFO Downloading mirrors from Manjaro
::INFO => Mirror pool: https://repo.manjaro.org/mirrors.json
::INFO => Mirror status: https://repo.manjaro.org/status.json
::INFO Using custom mirror file
::INFO Querying mirrors - This may take some time
1.410 United_States : FCIX Micro Mirror
1.365 United_States : Index of /manjaro/
1.378 United_States : FCIX Micro Mirror
1.068 United_States : FCIX Micro Mirror
1.320 United_States : FCIX Micro Mirror
1.569 United_States : FCIX Micro Mirror
2.057 United_States : FCIX Micro Mirror
1.450 United_States : FCIX Micro Mirror
1.245 United_States : FCIX Micro Mirror
1.760 United_States : FCIX Micro Mirror
1.852 United_States : FCIX Micro Mirror
1.559 United_States : FCIX Micro Mirror
1.335 United_States : FCIX Micro Mirror
1.709 United_States : FCIX Micro Mirror
1.409 United_States : FCIX Micro Mirror
1.663 United_States : FCIX Micro Mirror
1.754 United_States : Index of /pub/manjaro
2.207 United_States : Index of /manjaro/
::INFO Writing mirror list
::United_States : https://ask4.mm.fcix.net/manjaro/stable/$repo/$arch
::United_States : https://forksystems.mm.fcix.net/manjaro/stable/$repo/$arch
::United_States : https://uvermont.mm.fcix.net/manjaro/stable/$repo/$arch
::United_States : https://coresite.mm.fcix.net/manjaro/stable/$repo/$arch
::United_States : http://mirror.fcix.net/manjaro/stable/$repo/$arch
::United_States : https://nnenix.mm.fcix.net/manjaro/stable/$repo/$arch
::United_States : https://southfront.mm.fcix.net/manjaro/stable/$repo/$arch
::United_States : https://ohioix.mm.fcix.net/manjaro/stable/$repo/$arch
::United_States : https://nocix.mm.fcix.net/manjaro/stable/$repo/$arch
::United_States : https://volico.mm.fcix.net/manjaro/stable/$repo/$arch
::United_States : https://mnvoip.mm.fcix.net/manjaro/stable/$repo/$arch
::United_States : https://ridgewireless.mm.fcix.net/manjaro/stable/$repo/$arch
::United_States : https://opencolo.mm.fcix.net/manjaro/stable/$repo/$arch
::United_States : https://mirror.math.princeton.edu/pub/manjaro/stable/$repo/$ar
::United_States : https://irltoolkit.mm.fcix.net/manjaro/stable/$repo/$arch
::United_States : https://codingflyboy.mm.fcix.net/manjaro/stable/$repo/$arch
::United_States : https://ziply.mm.fcix.net/manjaro/stable/$repo/$arch
::United_States : https://repo.ialab.dsu.edu/manjaro/stable/$repo/$arch
::INFO Mirror list generated and saved to: /etc/pacman.d/mirrorlist
error: could not register ‘sublime-text’ database (database already registered)
:: Synchronizing package databases…
core is up to date
extra 8.5 MiB 4.04 MiB/s 00:02 [######################] 100%
community is up to date
multilib is up to date
sublime-text is up to date
:: Starting full system upgrade…
there is nothing to do

pacdiff -o


pacman -Qm

error: could not register 'sublime-text' database (database already registered)
afdko 4.0.0-1
backlight-openrc 2-1.1
clementine 1.4.0rc2-4
coolkey 1.1.0_36-2
cython2 0.29.36-1
deepin-wayland 1.0.0-1
electron12 12.2.3-4
etcher 1.7.9-1
gklib 5.1.1-4
gnome-icon-theme 3.12.0-7
gnome-icon-theme-symbolic 3.12.0-6
grub-editor 1.12-1
hidapi-git 1:0.14.0.r8.gd0856c0-1
i2c-ch341-dkms 20210501-1
i2c-tools-git r386.c94a3a2-1
js78 78.15.0-4
lib32-lzo 2.10-2
libsidplay 1.36.59-10
lua51-periphery 2.3.1-1
manjaro-documentation-en 20181009-1
manjaro-firmware 20160419-1
metis 5.2.1-2
mingw-w64-tools 10.0.0-1
mp3tag 3.22-1
msi-perkeyrgb 2.1-2
noto-fonts-compat 20151217-1
openrc 0.51-1
opensc-p11-kit-module 1.0.0-1
phoronix-test-suite 10.8.4-1
piv-agent 0.20.1-1
pivccu-modules-dkms 1.0.79-1
plasma5-applets-caffeine-plus 1.4-2
playonlinux 4.4+29+gd0ae9ce6-2
preload 0.6.4-9
psautohint 3:2.4.0-2
python-jarowinkler 1.2.3-2
python-pep517 0.13.0-4
python-progress 1.6-8
python-rapidfuzz-capi 1.0.5-5
python-smbus-git r386.c94a3a2-1
python-ufonormalizer 0.6.1-3
python2 2.7.18-8
python2-atomicwrites 1.4.1-1
python2-attrs 21.4.0-1
python2-automat 20.2.0-7
python2-backports 1.1-2
python2-backports.functools_lru_cache 1.6.4-3
python2-configparser 4.0.2-3
python2-contextlib2 0.6.0.post1-2
python2-coverage 5.5-3
python2-docutils 0.18.1-1
python2-funcsigs 1.0.2-4
python2-graphviz 0.16-1
python2-importlib-metadata 2.1.3-2
python2-linecache2 1.0.0-5
python2-m2r 0.2.1-7
python2-mistune 0.8.4-6
python2-mock 3.0.5-9
python2-more-itertools 5.0.0-3
python2-numpy 1.16.6-3
python2-packaging 20.9-7
python2-pathlib2 2.3.7.post1-2
python2-pbr 5.9.0-2
python2-pluggy 0.13.1-9
python2-py 1.11.0-2
python2-pycurl 7.45.1-7
python2-pygments 2.5.2-2
python2-pyparsing 2.4.7-1
python2-pytest 4.6.11-2
python2-pytest-cov 2.12.1-3
python2-pytest-runner 5.2-5
python2-scandir 1.10.0-8
python2-setuptools 2:44.1.1-2
python2-setuptools-scm 5.0.2-1
python2-six 1.16.0-6
python2-sortedcontainers 2.4.0-1
python2-toml 0.10.2-7
python2-traceback2 1.4.0-7
python2-unittest2 1.1.0-8
python2-wcwidth 0.2.5-6
python2-zipp 1.2.0-1
rubyripper 0.8.0rc3-2
stacer-bin 1.1.0-5
systemd-fsck-silent 239-1
teamviewer 15.46.7-1
ttf-ms-win10-auto 10.0.19042.789-5
ulauncher 5.15.4-1
webkit2gtk-5.0 2.38.6-1

Thanks cscs!

The other ones should be merged as well, but this one seems related to login problems (sddm being your display manager…).

Theres possibly something up with this third party repo.
I dont know anything about it, so I couldnt say.

You need to handle all of these.

(ex; sudo pacman -Syu meld && DIFFPROG=meld pacdiff -s)

This repo no longer exists.
This would be reflected in your pacman.conf.pacnew.

These should be gone.

Is there a reason for this on a plasma install?
Actually it doesnt exist in the repos or the AUR.
Which probably means it shouldnt be on your system.

This is an odd one … are you using openrc somehow?

This doesnt exist in the repos or the AUR and the version is rather old in comparison to systemd.

In general you have a good number of AUR packages … which is not necessarily a problem, but I wonder if they are all needed … and if they are all updated.

1 Like

I just removed sublime-text. It’s something I use from time to time, but it’s not a must for me!

When I executed sudo pacman -Syu meld && DIFFPROG=meld pacdiff -s, for each one, it asked me to choose (V)iew, (M)erge, (S)kip, (R)emove pacsave, (O)verwrite with pacsave, (Q)uit. What should I choose for each?

==> pacsave file found for /usr/share/icons/default/index.theme
:: (V)iew, (M)erge, (S)kip, (R)emove pacsave, (O)verwrite with pacsave, (Q)uit: [v/m/s/r/o/q]
==> pacnew file found for /etc/shells
:: (V)iew, (M)erge, (S)kip, (R)emove pacnew, (O)verwrite with pacnew, (Q)uit: [v/m/s/r/o/q]
==> pacnew file found for /etc/locale.gen
:: (V)iew, (M)erge, (S)kip, (R)emove pacnew, (O)verwrite with pacnew, (Q)uit: [v/m/s/r/o/q]
==> pacnew file found for /etc/default/grub
:: (V)iew, (M)erge, (S)kip, (R)emove pacnew, (O)verwrite with pacnew, (Q)uit: [v/m/s/r/o/q]
==> pacnew file found for /etc/pamac.conf
:: (V)iew, (M)erge, (S)kip, (R)emove pacnew, (O)verwrite with pacnew, (Q)uit: [v/m/s/r/o/q]
==> pacnew file found for /etc/mkinitcpio.conf
:: (V)iew, (M)erge, (S)kip, (R)emove pacnew, (O)verwrite with pacnew, (Q)uit: [v/m/s/r/o/q]
==> pacnew file found for /etc/pacman.conf
:: (V)iew, (M)erge, (S)kip, (R)emove pacnew, (O)verwrite with pacnew, (Q)uit: [v/m/s/r/o/q]
==> pacnew file found for /etc/pam.d/sddm
:: (V)iew, (M)erge, (S)kip, (R)emove pacnew, (O)verwrite with pacnew, (Q)uit: [v/m/s/r/o/q]

I just deleted both.

Thinking back, I can’t remember why or how I have deepin-wayland installed, but I removed deepin-wayland 1.0.0-1 too.

While removing deepin-wayland 1.0.0-1, using PAMAC, I also noticed I have 36 deepin related packages.
Some for example:


and goes on and on…

I have also bunch of gnome related stuff too.

Disks (gnome-disk-utility)
Terminal (gnome-terminal)

Here is the thing though! If I didn’t have deepin or gnome related packages installed, I would have nothing (no means) to log in to Manjaro now!

In the initial login screen, when I choose “Plasma (X11)” and enter my password, it boots up to my desktop theme for a second or two, then kicks me back out to the same login screen. But when I select “deepin” theme in the initial login screen, and enter my password, even though I’m in totally different and unfamiliar (deepin) environment, at least I have access to Manjaro to post my messages and reply to your posts. What would I have done if I didn’t have deepin to log in to Manjaro?

First, “openrc” didn’t ring a bell for me. When I typed “openrc” in PAMAC, “backlight-openrc” came up in the list. Then I remembered that I had installed bunch of packages, to no avail, to get the keyboard backlight to work on my laptop. Since I now know they are not needed, I removed both openrc 0.51-1 and backlight-openrc.

I have not removed it yet, but if you think it’s unnecessary, I can go ahead and remove systemd-fsck-silent 239-1

I was also considering removing “systemd” that systemd-fsck-silent depended on, but when I checked it, there are 39 packages, required “systemd”, one of which is flatpack. Doing so (removing “systemd”) would cripple things far worse than the trouble I’m in now. Let’s not create more excitement than I can handle all at once! :wink:

You’re right! I have more AUR packages than I would have liked.

To be honest with you, most of them installed in the initial months of Manjaro when I was not too familiar with it. Also, I know that I tried out and installed bunch of packages, short of throwing the kitchen sink into it, to get the devices (nvidia video card, keyboard backlight, etc…) to work in my laptop. To top it all off, I also installed other packages (apps) that I wanted to have, but could not find in official repositories. Now, It turned into a bit of a mess in a sense that when I look at the list of foreign packages in PAMAC, I can’t really tell by the name of each AUR package if I really need it or not… or if it’s safe to delete or not… without causing any problem. But sooner or later, it’s something I need to tackle. Since it seems a bit overwhelming, I may be putting it off too. :worried:

Also, here is something I should have mentioned before anything else, but kept the best for last for the thrill.

For at least 6 to 9 months, I cannot run updates in PAMAC. It always prompts, “Error. Failed to synchronize database”. So, I impose updates running the commands below in terminal. And I’ve never had a problem with it so far.

sudo su
pacman-mirrors -f
pacman -Syyu

Right before this current problem (when everything was working fine), I tried system updates in PAMAC. It gave me the same “Error. Failed to synchronize database” prompt. So, I typed the commands below in terminal.

sudo su
pacman-mirrors -f
pacman -Syyu

then it asked me one by one if I wanted to update and replace bunch of packages. All the new packages had the same name as the old ones, but included the number, “5” at the end (as much as I remember). I replied “no” to 10 of them or so. It kept going and going! Then I exited out with “CNTRL+C”. I didn’t want to do something I wasn’t sure about. Then I tried system updates in PAMAC. The system updates in PAMAC worked this time, but I ended up with this problem.

I know, I’m scratching my head too!? :open_mouth:

Oops, you should’ve selection Y for all of them. The reality is (at least for me, and judging from the comments on this and other forums) that when this sort of question comes up, 99% of the time users should select Yes.

1 Like

I’m not giving up on Manjaro yet! I just can’t see myself going back to Micro-spy’s Window$. I’m sure there is a way to fix this.

1 Like

A couple of tips:

  • Try to avoid using sudo su as you can end up with permission/ownership issues etc. and is generally regarded as bad practice. Always use e.g. sudo pacman -Syu. Newer programs I believe tend to use PolicyKit and will ask for the password when elevated privileges are needed; I think this includes Pamac.
  • Where there are a lot of packages requiring a Y/N response, you could CTRL+C out and then re-run with the --noconfirm option e.g. sudo pacman -Syu --noconfirm although according to the Pacman man page, it’s generally not a good idea.

N.B. The capitalized letter e.g. (Y/n) is the default and only requires pressing Enter.

Most likely yes, but the question is, will it ever be completely “stable”.
It seems you have a LOT of “stuff” on your system that should not be there.
Your pacenew files are a mess (I hope you fixed that first!)

About your login, you had a pacnew for SDDM witch is the login manager you probably should use, not deepin.
And do not for gods sake try to uninstall systemd!

The question is, is it worth the work to fix this or is a reinstall on the map.
This is for you to decide.

1 Like

Thank you for the tip. Greatly appreciated! That’ll be my practice going forward.

I’m from a generation, who grew up with an 8-bit computer, called Commodore 64! Back then, everything (games) was written (meaning, coded & programmed) in something called “Assembly Language” by a single person or 2 or 3 people. Games were not “complicated”.

You couldn’t get the computer to do anything “serious” back in the day unless you coded things in Assembly Language. And it took a while ( I mean, “a while”) to get your head around to understand how the CPU functioned and processed things and why you needed to write lines & lines of codes in a very specific ways just to do a simple task.

To me, Assembly Language was so much fun, and mysterious and at the same time, very satisfying to accomplish things. Commodore 64 had a 6510 CPU. You had to understand and get a book about the 6510 CPU to start your journey with Assembly Language coding.

“Cracking”games was the thing back then! Games were sold on cassette tapes. Good old days!


If I start cleaning and uninstalling things that are causing conflicts, I think there is a chance to make it stable.

I know… :worried: Is there any particular one you’re referring to, that you think it must be removed first before other ones?

1- AUR packages? 
2- Flatpak packages? 
3- gnome, deepin, wayland related packages from official repositories? 

I would love to fix them first, but I just don’t know how to do that. And without knowing what I’m really doing, I don’t want to mess with them and cause more/worse problems.

When I executed the command, sudo pacman -Syu meld && DIFFPROG=meld pacdiff -s in terminal, it asked me to take action for pacsave and for each pacnew file, either to

(V)iew, (M)erge, (S)kip, (R)emove pacsave/pacnew, (O)verwrite with pacsave/pacnew, (Q)uit:

Basically, if I have two of the same file, either I will need to

  • remove one of them. The question is: which one?

  • I will need to merge them. Merging them does not make sense because whatever or wherever the problem is, merging them will include and keep the problem, consolidated in single pacsave or pacnew file. So, I can eliminate this option!

  • I will need to overwrite with the current (latest) pacsave/pacnew. I’m assuming that I will be overwriting with the current pacsave/pacnew (that I viewed). But how can I view the old one that I will be overwriting? And what if the old one is the one I need to keep? How can I know or make sure which one to keep and which one to overwrite?

As a matter of fact, I’ve never had a login screen in the first place, before this problem. After I booted up Manjaro, it would automatically log in to Plasma (X11) theme without having to enter my login password. I used nothing else other than “Plasma (X11)”. It was the only desktop theme I always used. Nothing else!

But after this problem, I have this “new” login screen that I don’t even know why it is there in the first place.

When I select “Plasma (X11)” theme, and enter my password to log in, it logs in and shows my desktop theme for about 2 seconds and kicks me back out to the same login screen.

When I select “Deepin” or any other theme, and enter my password, I’m able to log in to Manjaro with a different (unfamiliar) desktop theme that I’ve never used before! And things seem to work if and only if I can find my way around in this unfamiliar desktop environment.

No! No! No! I would not do that! :crazy_face:

Everything in my Plasma (X11) theme is set up meticulously. And things took a long, long time to put the pieces of the jigsaw puzzle together. Every new piece I added and included upon the previous ones was a process and a progress, built upon the previous ones.

I don’t know/remember how to do everything all over again. I really don’t…

I spent 18 months, searching for ways/solutions to get the keyboard backlight to work on my laptop. And it finally works now. If and when I start all over again, will I be able to get the keyboard backlight to work again? I really don’t want to go through the same hassle.

Everything in Manjaro is set up in a way, perfectly and completely for my laptop “AS IF” this laptop came with Manjaro.

Not knowing anything about Manjaro, it was not easy for me to get there. I just don’t want to start all over again. And to be honest with you, I don’t… I really don’t want to resort back to “Windows” with my tails between my legs. I really don’t…

I have been thinking. And… Reinstall. I totally get that you don’t want to but you have done things to the system that most likely will never be fixed completely.

A reinstall does not mean you loose all your settings (the backlight might be gone though, but if it is working now, it can work again).
All your desktop settings are in your /home directory so if that is on a separate partition, you just select that partition as home when reinstalling.
If your /home is NOT on a partition, it is very easy to just create one and move the files to that before reinstalling.

1 Like

Re. the tips, it’s appreciated, thanks! Hopefully a bit of a time-saver.

I did have a go at assembly language on the C64 but didn’t do much more than write mouse drivers for my GUI interface (loosely based on the one we had on the RM Nimbus machines at college, password login and everything).

If you can get a list of all your installed programs and don’t format your /home partition, at least you should be able to reinstall those and your settings for each should be preserved.

I’d like to thank each & every one of you, who tried to help me with this problem. I greatly appreciate your time and effort.

It’s unfortunate that there was so solution or resolution to this problem, but I take this as a learning experience that I should have been and (going forward) I should be a lot more careful with installing packages.

I had 2 choices. Either I was going to reinstall Manjaro or recover from an old image I backed up with TimeShift.

The TimeShift backup didn’t recover my system to where I wanted it to be, but at least, things were not as tedious as starting all over again.

I know that I should have backed up my system with TimeShift every so often. I don’t know what I was thinking!?

After the recovery, I reduced AUR packages from 90 down to 12.

Now I only have 2 flatpak packages installed in my system.

Also, I was going to remove the SDDM package, not knowing much about it, but I realized that the automatic login function in KDE Plasma (which is what I have) is handled by SDDM. That’s a no-no!

Now I have a better understanding that installing multiple desktop environments may cause problems. Settings packages may overlap. You may end up with more than one instance of similar applications. You may have 2 Bluetooth managers, display managers, etc… Sometimes two different desktop environment may share the same configuration files, causing strange things to happen.

Question: how do I get a list of desktop environments currently installed in my system? Is there a command to type in terminal to get a list a desktop environment installed in my system?

Question: the desktop environment I’m using is KDE Plasma. After figuring out what additional desktop environments installed in my system, would it be safe to delete all of them and only leave KDE Plasma?

Question: I have 163 orphan packages. Would it be safe to delete all of them?

Thank you.

SDDM is a Display Manager, the default one on KDE. It doesnt just handle ‘automatic login’ … it would be there to ask you for a password without the autologin option too.


There is no ‘DE management system’ or similar. They are just collections of packages and configs.
You can use groups or scripting to add or remove groups of packages though.

See this thread:

(note that if you want to use mapare the syntax has changed slightly with capital letters)

As the maintainers intended. Yes, its entirely ‘safe’ to have just one DE.

Orphan does not necessarily mean you dont want it. But could be.
Especially given your forays into adding/removing things … its entirely possible something you rely on was installed as a dependency of something else, but you removed the original package without dependencies so now this package you need is technically an orphan until you manually change install reason to ‘explicit’. etc.
Inspect the list first.

pacman -Qdt