NTFS3 disk errors when torrenting

Long story short, torrenting (qbittorrent,kget, etc) sometimes freezes and then corrupts the NTFS partition and the only way to mount them again is to run a disk check on windows and reboot.

and its not disk failure, one of them is brand new and partitioned with another ext4 working without a hitch.

my fstab file:

UUID=90E49D60E49D48FC                     /mnt/external  ntfs3 uid=1000,gid=1001,dmask=022,fmask=133 0 0
UUID=E0BE0711BE06DFC0                     /media/gamedisk ntfs3   defaults 0 0

i need to mount them with permissions to use plex and steam proton, but these current flags are perhaps causing this issue? i didnt have this issues previously when using ntfs-3g.

i’m not the only one apparently:

Being brand new does not exempt it from being faulty. I talk from experience.
You should check its SMART data, at least to definitely close that option.

If you need interpoerability with a Windows system, why not exfat (using exfatprogs)?

It’s matured and clean.

It’s also possible that the way torrenting uses “allocation” or “sparse files” might be causing the issues you’re facing when writing to an NTFS filesystem via a Linux client.

I use a 500GB SSD for my Download folder and the disk is shared with a Windows system too. I never noticed any issue, I’m using NTFS3 since it is available, and use torrents a lot on it. I don’t use the same fstab options though.

UUID=1ECAE670CAE6441D /media/SSD_500Go ntfs3 defaults,noatime,uid=omano,gid=omano 0 0

i need to use it as i plug’n’play device, at least the external hard-drive so exfat may not work for every device i connect it to. can i game on a exfat on both linux and windows?

interesting, i’ll try using your fstab options then and report results if the issue persists.

i also never had this issue before, at least with fuse… what torrent client do you use? i use qbittorrent, also tried kget and found similar issues.

ExFAT is universally supported. (Samsung is the main developer for exfatprogs, which is important for Android devices as well.) ExFAT is here to stay with universal compatibility across Linux, macOS, Windows, and mobile devices.


As in you’re installing applications to the partition? I’ll be honest, this is an odd “hybrid” setup you’ve got going.


Then out of curiosity, do you have preallocation enabled with qBittorrent?


Finally, to rule out a more serious underlying issue, I must second @maycne.sonahoz’s recommendation to check the SMART logs and even run a short (or preferably extended) SMART selftest.

To add to this, I’ve owned two WD Blue drives that both catastrophically failed within 30 days of purchase. Two different drives. Two different occasions. Both purchased brand new from Amazon (not from a third-party seller, but legit from Western Digital.)

the recommended mounting options for ntfs3 include both noatime,prealloc. this might specially apply for torrenting.

i had issues where qbitorrent quit on a ntfs3 mount when onetime i had a powerloss while torrenting. the NTFS partition was corrupted, and could only be fixed by chkdsk /f in windows. also if you are using ntfsfix always use the ‘-d’ flag, any check without the -d flag make the NTFS partition marked as being dirty, which could lead to the partition being at worse being unmountable or lead to other issues with ntfs3. ntfs-3g somehow seems to work nevertheless.

ntfs3 implementation is still rough on the edges, worse its not maintained for sometime now, so dont expect the current issues to go away soon.

like others have suggested exfat is recommended if you can switch.

on a tangent:
new is also an acronym for
never ever worked :wink:

… unlikely to be the issue here though

Sometimes freezes … ? Sounds like that is the actual problem here.

Are you certain it’s not libtorrent being bugged?

I’m using the same config as @omano and included the prealloc option now, did a quick test and no issues so far, but it doesn’t always present itself immediately so I’ll keep reporting whatever happens in the next few weeks.

There is an open issue i just found, im dumb i was search qbittorrent issue tracker… so the devs are aware of this issue, but reading that thread you’ll see that ntfs-3g works, its ntfs3 that is presenting this issue, i’ve been using fuse on linux for years and never ever had this issue before.

fairly common setup, if you want to share a large partition and the same files between windows and linux the easiest way is to use NTFS, especially for gaming.

ive considered using exfat before, but data loss is a real concern for me.

I have the same Problem with qbittorrent + ntfs3

UUID=C42E58082E57F1C2  /media/Downloads ntfs3  defaults,noatime,prealloc,nofail,uid=1000,gid=1001     0 1

prealloc is not the Solution

1 Like

For sharing and accessing files between Linux and Windows? Agreed. But what you’re describing is installing software and games to this partition. You’re not just sharing files (like images, videos, documents, etc.) The software installed by one system is useless to the other system.


For OS-interoperability, exFAT is safer (and less complex) than NTFS. (See @koshikas’s post above.)

Just make sure you remove exfat-utils and install exfatprogs (developed by Samsung).


Do you have preallocation enabled with qBittorrent?

i mean, its a steamlibrary, its accessible and usable on both systems, the only unusable files i have are the windows store games…

gonna it a whirl, for my external hdd at least.

No. not desirable tbh, but if it fixes the issue i’m fine with it, gonna enable it.

That makes more sense, and you shouldn’t have (more) problems with Steam games stored on exFAT. :slightly_smiling_face: Years ago Valve removed the pointless “small games only” limitation for exFAT filesystems, because they were treating FAT32 and exFAT the same.

1 Like

so preallocation was disabled, enabling it and trying to download a simple iso image promptly causes issues, so disabling it causes less issues.

huh that is interesting… well im going to try formatting with exfat my gaming partition, lets see how it goes.

sudo tune2fs -l /dev/sda1                                                                                   1 ✘ 
tune2fs 1.46.5 (30-Dec-2021)
tune2fs: Ungültige magische Zahl im Superblock beim Versuch, /dev/sda1 zu öffnen
/dev/sda1 hat ein ntfs-Dateisystem mit Namen „Downloads“

tune2fs: Bad magic number in super-block

tune2fs is for ext2/3/4 filesystems, why would you try to use that on a ntfs filesystem?
https://man.archlinux.org/man/tune2fs.8.en

SORRY my fault

So what are the odds? I now experienced twice a NTFS error that I had to boot to Windows to “checkdisk” and fix.

But I still am not sure this is related to qbitorrent. I know it was started (but not downloading) the first time I crashed, not sure about the second, but it crashed when I moved my computer case (image froze, sound continued playing for ten seconds, then total freeze no TTY nothing), and the only issue I find in journal is an Nvidia issue about the GPU (total journal flood of similar lines omano-nvme kernel: nvidia-modeset: ERROR: GPU:0: Failed to query display engine channel state: 0x0000927c:0:0:0x0000000f. I think the NTFS issue was caused because both crashes I electrically reset the computer, didn’t REISUB or cleanly shutdown the computer. I think this is what caused the NTFS issue forbidding boot because of the fstab entry for this NTFS disk, the NTFS file system was harmed in some way when I crashed and unplugged the computer to restart.

I also repasted my video card last week so maybe my video crash issue are related (I will loosen up the screws I went full tight).