My laptop's ui is way too small

a few months ago i installed Manjaro in a virtual machine on my laptop. everything went semi-ok so i decided i wanted to install it on my laptop fully, then when i did, the ui, cursor and task manager was WAY too small. So i changed global scaling and the other things so that it was bearable. now when i connect my monitor it (somewhat unsurprisingly) makes everything very big so its unusable again.

so how do i change it so that either:

the monitor doesn’t keep the changes i made in global scaling, task manager and cursor settings or

so that my laptop, by default has a normal ui, cursor and task manager.

display res is 3840x2160

monitor res is 1920x1080

installed graphic drivers

Installed PCI configs:

              NAME               VERSION          FREEDRIVER           TYPE
       video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!

To clarify:

  • UI in laptop display is too small.
  • UI in monitor is at the perfect size.

Is it correct?

What’s the resolution of the laptop display and monitor?

And also what’s the graphics driver used? Check from command mhwd -li.

Hi @siken, and welcome!

In order for us, or anyone for that matter, to be able to help you, more information is necessary. To that end, please see:

Hope you manage!

yes that is correct

display res is 3840x2160

monitor res is 1920x1080

konsole spit:

Installed PCI configs:

              NAME               VERSION          FREEDRIVER           TYPE

       video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!

Ah I’m starting to understand the issue.

But just to make sure first, can you provide the following:

  • Output of inxi -Fazy
  • Output of xrandr, with the external monitor connected to your laptop
  • Output of mhwd -l
1 Like

my desktop environment is KDE plasma

inxi -fazy output:

  Kernel: 5.16.11-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.16-x86_64
    root=UUID=d59cad4c-7a6a-4d3b-8e2a-b877aa44a063 rw quiet
  Desktop: KDE Plasma 5.24.2 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 20TQCTO1WW v: ThinkPad P15v Gen 1
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: LENOVO model: 20TQCTO1WW v: SDK0J40697 WIN
    serial: <superuser required> UEFI: LENOVO v: N30ET40W (1.23 )
    date: 08/03/2021
  ID-1: BAT0 charge: 47.3 Wh (77.3%) condition: 61.2/68.0 Wh (90.0%)
    volts: 12.1 min: 11.5 model: Celxpert 5B10W13961 type: Li-poly
    serial: <filter> status: Discharging cycles: 110
  Info: model: Intel Core i7-10875H bits: 64 type: MT MCP arch: Comet Lake
    family: 6 model-id: 0xA5 (165) stepping: 2 microcode: 0xEC
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 2 MiB desc: 8x256 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 800 high: 801 min/max: 800/5100 scaling:
    driver: intel_pstate governor: powersave cores: 1: 800 2: 800 3: 801 4: 800
    5: 800 6: 800 7: 800 8: 800 9: 800 10: 800 11: 800 12: 800 13: 800 14: 800
    15: 800 16: 800 bogomips: 73625
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: Lenovo driver: i915
    v: kernel ports: active: eDP-1 empty: DP-1, DP-2, DP-3, HDMI-A-1, HDMI-A-2
    bus-ID: 00:02.0 chip-ID: 8086:9bc4 class-ID: 0300
  Device-2: Chicony Integrated Camera type: USB driver: uvcvideo
    bus-ID: 1-8:2 chip-ID: 04f2:b6be class-ID: fe01 serial: <filter>
  Display: x11 server: X . Org v: compositor: kwin_x11 driver: X:
 fbdev,vesa gpu: i915 display-ID: :0  loaded: modesetting alternate:
    screens: 1
  Screen-1: 0 s-res: 3840x2160 s-dpi: 96 s-size: 1015x571mm (40.0x22.5")
    s-diag: 1165mm (45.8") monitors: <missing: xrandr>
  Monitor-1: eDP-1 built: 2019 res: 3840x2160 dpi: 284 gamma: 1.2
    size: 344x194mm (13.5x7.6") diag: 395mm (15.5") ratio: 16:9 modes: 3840x2160
  OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 21.3.7
    direct render: Yes
  Device-1: Intel Comet Lake PCH cAVS vendor: Lenovo driver: snd_hda_intel
    v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
    chip-ID: 8086:06c8 class-ID: 0403
  Sound Server-1: ALSA v: k5.16.11-2-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.47 running: yes
  Device-1: Intel Comet Lake PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:06f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  Device-2: Intel Ethernet I219-LM vendor: Lenovo driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:0d4c class-ID: 0200
  IF: enp0s31f6 state: down mac: <filter>
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 1-14:4 chip-ID: 8087:0026 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends
  Local Storage: total: 3.73 TiB used: 15.54 GiB (0.4%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Toshiba model: N/A
    size: 1.86 TiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: 5105AHLA temp: 22.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:3 vendor: Toshiba model: N/A
    size: 1.86 TiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: 5105AHLA temp: 22.9 C scheme: GPT
  ID-1: / raw-size: 1.86 TiB size: 1.83 TiB (98.37%) used: 15.54 GiB (0.8%)
    fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 288 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  Alert: No swap data was found.
  System Temperatures: cpu: 31.0 C pch: 31.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 331 Uptime: 1d 1h 2m wakeups: 538 Memory: 62.44 GiB
  used: 21.17 GiB (33.9%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1194 lib: 340 Shell: Zsh
  v: 5.8.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.13


Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
eDP-1 connected (normal left inverted right x axis y axis)
   3840x2160     60.00 +  59.98    59.97  
   3200x1800     59.96    59.94  
   2880x1620     59.96    59.97  
   2560x1600     59.99    59.97  
   2560x1440     59.99    59.99    59.96    59.95  
   2048x1536     60.00  
   1920x1440     60.00  
   1856x1392     60.01  
   1792x1344     60.01  
   2048x1152     59.99    59.98    59.90    59.91  
   1920x1200     59.88    59.95  
   1920x1080     60.01    59.97    59.96    59.93  
   1600x1200     60.00  
   1680x1050     59.95    59.88  
   1400x1050     59.98  
   1600x900      59.99    59.94    59.95    59.82  
   1280x1024     60.02  
   1400x900      59.96    59.88  
   1280x960      60.00  
   1440x810      60.00    59.97  
   1368x768      59.88    59.85  
   1280x800      59.99    59.97    59.81    59.91  
   1280x720      60.00    59.99    59.86    59.74  
   1024x768      60.04    60.00  
   960x720       60.00  
   928x696       60.05  
   896x672       60.01  
   1024x576      59.95    59.96    59.90    59.82  
   960x600       59.93    60.00  
   960x540       59.96    59.99    59.63    59.82  
   800x600       60.00    60.32    56.25  
   840x525       60.01    59.88  
   864x486       59.92    59.57  
   700x525       59.98  
   800x450       59.95    59.82  
   640x512       60.02  
   700x450       59.96    59.88  
   640x480       60.00    59.94  
   720x405       59.51    58.99  
   684x384       59.88    59.85  
   640x400       59.88    59.98  
   640x360       59.86    59.83    59.84    59.32  
   512x384       60.00  
   512x288       60.00    59.92  
   480x270       59.63    59.82  
   400x300       60.32    56.34  
   432x243       59.92    59.57  
   320x240       60.05  
   360x202       59.51    59.13  
   320x180       59.84    59.32  
DP-1 disconnected (normal left inverted right x axis y axis)
HDMI-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)
HDMI-2 disconnected (normal left inverted right x axis y axis)
DP-3 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 527mm x 296mm
   1920x1080     60.00*+  74.97    50.00    59.94  
   1920x1080i    60.00    50.00    59.94  
   1680x1050     59.88  
   1280x1024     75.02    60.02  
   1440x900      59.90  
   1280x960      60.00  
   1280x720      60.00    50.00    59.94  
   1024x768      75.03    70.07    60.00  
   832x624       74.55  
   800x600       72.19    75.00    60.32    56.25  
   720x576       50.00  
   720x480       60.00    59.94  
   640x480       75.00    72.81    66.67    60.00    59.94  
   720x400       70.08```

Can you the enclose the command output texts with triple `:

It’s hard to read.

1 Like

Did you happen to accidentally truncate something? Just to make sure that your laptop only has an Intel integrated GPU without AMD or NVIDIA GPU.

What is the output of mhwd -l?


                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

That’s a weird laptop architecture given that the screen resolution is 3840x2160.

The problem is in the graphics driver; it doesn’t properly handle graphics resolution higher than 1920x1080.

I thought initially that your laptop had an NVIDIA GPU … , because if so, I know that using NVIDIA proprietary graphics driver will fix the resolution issue.

Your current graphics driver is video-linux. So my advice is to try installing video-modesetting graphics driver first: sudo mhwd -i pci video-modesetting, then reboot. If the resolution is still not fixed, then try video-vesa: sudo mhwd -i pci video-vesa and then reboot.


If none of these 3 drivers work, then unfortunately my last advice is either one of below:

  • Live with the small UI
  • Try another distro and see if the screen resolution works fine, though I doubt so
  • Split your 3840x2160 laptop screen into 2 virtual screens, each screen resolution not larger than 1920x1080: Setup virtual display with xrandr

Do tell if you later need assistance on splitting your laptop screen into 2 virtual screens.

1 Like

thanks, but unfortunately it didnt work:( im gonna try an other dektop and os, and see if that fixes it, but thanks for trying:)

Look at the last button

Which did you choose? “For all monitors” or “For current monitor”? It seems that the default is “For all monitors

I didn’t notice this KDE settings, good to know.

But from my experience, open-source graphics driver currently doesn’t seem able to handle ppi for resolution higher than 1920x1080 well. Scale to 200% or higher may fix the DE look, but some GUI application UI may still suffer.

I have a laptop with screen resolution like yours, 2560x1600, and UI looks small on Manjaro. I switched to a deb or rpm based distro to get the official NVIDIA drivers support and it fixed the whole small UI issue.

OP’s screen resolution is twice of 1920x1080, so I expect GUI widgets will look twice smaller than the normal.

1 Like

have tried that sadly it doesn’t work.
would have been the perfect solution though