Manjaro loads the graphical installer but freezes within the first second

No matter what I try, when I boot into the USB, I choose the proprietary drivers for my NVIDIA GPU and everything goes fine until the graphical installer loads, then within the first second the screen freezes

CPU: Intel Core i5-10400f
GPU: MSI Geforce GTX 1060 3GB Gaming X
Motherboard: Gigabyte Z590 UD AC

I have tried running Open-Source drivers but then it ends in a black screen

do you have windows on your system? So first check your bios/uefi settings:

Firmware checklist for BIOS systems

  • :white_small_square: Use latest available firmware
  • :white_small_square: Disable EFI
  • :white_small_square: Disable RAID option
  • :white_small_square: Enable AHCI

Firmware checklist for EFI Systems

  • :white_small_square: Disable CSM (Legacy) boot
  • :white_small_square: Disable Secure Boot
  • :white_small_square: Enable AHCI
  • :white_small_square: Use latest available firmware
  • :white_small_square: Disable Optane Memory and Rapid Storage Technology (RST)
  • :white_small_square: Disable RAID option
  • :white_small_square: Disable Fast Boot (if unable to boot from USB)

Also use ventoy to flash your usb.

Hi @1NilusNilus, and welcome!

  • Have you tried with the open-source driver?
  • Which GPU do you have?

Also, if possible,

(But I know it might not be, that’s why I specified if it is.)

I edited my post, I have a GTX 1060.
Yes I have tried open source drivers, then instead of freezing it goes to a black screen.

Thank you!

  • What’s the age of the ISO?
  • Have you turned off fast boot/quick boot, or whatever it’s called. Both in Windows and in the BIOS.
  • Have you gone through the list of things to check/do, given by @brahma?

I must be off now, so it probably won’t be me giving you assistance, but anyone else will probably need the info as well.

@brahma I didn’t find some settings in my bios but I changed the rest, and I used ventoy but it still has the same issue

did you disable the following:
fast boot/ secure boot/ RAID - disabled
is it the latest ISO?
did you try different distro to boot?

@Mirdarthos I installed the ISO today, and i’ve turned off fast boot in both windows and bios, still the same

@brahma yes I did, and it is the latest ISO. Do you mean by different distro for example the gnome version of manjaro or like debian?

is secure boot and raid disabled in bios?
yes, like linux mint for example, can you boot with it?

@brahma yes, I tried with pop os I will try with debian now

@brahma It worked with debian

you still didnt answer if you disabled secure boot in bios… if its disabled, than maybe its probably an arch/ manjaro issue with your hardware? :thinking:

@brahma sorry :sweat_smile: i did

I fixed it guys, thanks!

I just installed another distro (like debian in my case) onto my ssd where windows was installed and then after it finished I immediately installed manjaro and it worked first try.

This topic was automatically closed after 4 hours. New replies are no longer allowed.