Manjaro KDE crashes randomly with Ryzen 7 3700X

Hi, I’ve been having this issue for some time now and I’m not sure what to do. I’ll be using my computer and everything will be fine until it locks up for no apparent reason and reboots. I’ve tested the memory using memtest86 and found no errors, and I don’t have this problem when I boot into Windows. I’m at a loss as to what to do. This is the error I get from sudo journalctl -p 3 -xb. Please let me know if there is any other information I can provide that would be useful. Thank you.

Hello @Gandhi!

-- Logs begin at Sun 2020-08-16 10:17:03 EDT, end at Sat 2020-09-19 01:25:33 EDT. --
Sep 19 01:22:17 Compy-3700X kernel: mce: [Hardware Error]: CPU 5: Machine Check: 0 Bank 5: bea0000000000108
Sep 19 01:22:17 Compy-3700X kernel: mce: [Hardware Error]: TSC 0 ADDR 1ffffc0197c54 MISC d012000100000000 SYND 4d000000 IPID 500b000000000
Sep 19 01:22:17 Compy-3700X kernel: mce: [Hardware Error]: PROCESSOR 2:870f10 TIME 1600492932 SOCKET 0 APIC a microcode 8701021

It is a known error of these Ryzen Processors.

With this tool you can check it:

Solution is to add processor.max_cstate=5 to the kernel parameter line in /etc/default/grub at the line with GRUB_CMDLINE_LINUX_DEFAULT="".

1 Like

First thing I’d try: If you’re running a D.O.C.P. profile on your memory in setup, disable that and see if system behavior improves. If it does, try testing each memory module individually, overnight if you’re using Memtest.

Second thing I’d try: Swap power supplies. I realize most people don’t have a spare power supply sitting around, but unless you have access to a good shop with a PSU load tester, there’s really no other way to check it (also: Make sure all the cable connections are tight and there is no sign of overheating at the connectors or scuffed insulations).

What GPU are you using?

I’m using a RX 5700 XT. I can try disabling XMP, but I don’t think that’s it.

For some reason I was thinking I had already done that, but when I checked Grub it wasn’t there. I’ll try it and update the thread if there are any changes. In the meantime, it did it again a few minutes ago. The error was slightly different this time. link

And despite making the changes to Grub, it crashed again. That’s the 3rd time tonight.
journal output
Grub

I also had problems with crashes until I disabled the c6 state, though I’m on a 1700. Though I’m not sure if it matters, I disabled it via the ‘zenstates’ script which you can get from AUR. The main reason I opted for this over the grub changes is it offered a way to actually verify if the states were disabled, using the -l flag. It also allows you to change them while the system is running.

If you do go this route instead, you’ll want a systemd script to run it at each boot and when resuming from sleep states:

$ cat /etc/systemd/system/disable-c6.service 
[Unit]
Description=Ryzen Disable C6
DefaultDependencies=no
After=sysinit.target local-fs.target suspend.target hibernate.target
Before=basic.target

[Service]
Type=oneshot
ExecStart=/usr/sbin/zenstates --c6-disable

[Install]
WantedBy=basic.target suspend.target hibernate.target

Howdy!

My recommendation is to upgrade to the latest kernel, such as Linux58 !

Some AMD Ryzen bugs and such have been fixed in this release!

Have a wonderful day!