Impossible installation on HP 455 G7, AMD Renoir 4500u

Did you type the whole line?

This output is from the live session, so not from a local install.

Here is where the boot stops…

Sometimes it stops at “RF Kill switch” So I dont believe that is the root cause, but as mentioned above, I’m lost

This shoud be it: yAwej and 5fGEt
Hope everything is in there. Thanks for patience!

I am sorry, but that is actually useless now. Please read carefully what i have written first.

I was thinking that you have installed it and now after installation it hangs. If so, you need to chroot into the local disk from a live session and get a journal log (this one you send is empty).

So you can boot a Desktop CD? Then boot it, open a terminal, type manjaro-chroot -a, type 1, and now you have full access to your local installation. Then type type the commands i mentioned:

Because it is very long, please as link:

This please as code:

like that:

output of inxi


Its true, I’m sorry for the garbage logs. :pensive:

Yes, correct, this is the situation.
However after the recent new installation it now hangs already on the first start, black screen.

No, I cannot start neither the manjaro graphic installer (thats one reason I tried with Architect.) nor any desktop. (Only Xubuntu via USB´stick shows a desktop, but crashes sometimes, which I believe is the old Kernel)
Unfortunately I have no much experiance with chroot’ing and manjaro-chroot is not available on the Architect.

Can’t I use “classic” chroot (thats available on Architect). What needs to be mounted min. to get the logs out? (Years ago, I used to recover Grub, it were several directories) I hope its less…

ok understood now.

  1. You can’t boot a Desktop Session.
  2. Architect Session works.
  3. You never installed Manjaro locally.

The issue comes from the ISO. I would suggest to use the architect version, which will retrieve everything you need.

About the crashes… a thought comes to my mind. There was a similar problem. When i look at your CPU:

  Topology: 6-Core model: AMD Ryzen 5 4500U with Radeon Graphics socket: FP6 
  bits: 64 type: MCP arch: Zen family: 17 (23) model-id: 60 (96) stepping: 1 
  microcode: 8600106 L1 cache: 384 KiB L2 cache: 3072 KiB L3 cache: 8192 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 28463 
  Speed: 1397 MHz min/max: 1400/2375 MHz base/boost: 2375/4000 boost: enabled 
  volts: 1.2 V ext-clock: 100 MHz Core speeds (MHz): 1: 1398 2: 1397 3: 1397 
  4: 1397 5: 1397 6: 1400 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, 
  STIBP: disabled, RSB filling 
  Type: tsx_async_abort status: Not affected 

there is “family: 17 (23)” written. This family has a hardware bug, which needs to be addressed.

You could try to add processor.max_cstate=5 to kernel parameter in grub before booting by editing the the boot command in the live session.

Have you read this tutorial?

Hi again!

  1. You can boot a Desktop Session. → No, I cant get any Desktop working.
  2. Architect Session works. → Yes
  3. You never installed Manjaro locally. → No, Manjaro is installed on a 80 GB partition. However thats not booting.

l will reinstall Manjaro with Architect and Kernel 5.6 and add processor.max_cstate=5 . Maybe that’ll help.

THKS for the Dual boot manual. My UEFI is proper and not mixed wth MBR as well as all the other items are no isse here.

Hi @megavolt I would like to thank you for trying helping me, but I’m close to give-up.
It seems to be too early for this notebook. On the other side I’m lacking to get the right logs, while manjaro-chroot is not available to be used via Architekt installer. Manjaro is repeatedly not starting (neither graphic installaller USB nor installed Manjaro on notebook) whatever GRUB settings and parameters have been set. I gave a try to endeavorOS (Arch based) with same result. The only Linux so far with limited success ist Xubuntu, which at least is presenting a desktop beside many many error messages due to old kernel and whats most important: its not rolling. Maybe I should wait for 12 month or so, or at least until linux-hardware indicates some level of maturity.

My experience with installing Manjaro (KDE) on this hardware on a friends new laptop was quite different from yours. Manjaro was among the few distributions* that worked flawless.
If I remember correctly I did an architect-installation and definitely chose kernel 5.8.
You want the newest available stable kernel and firmware for this new hardware.

Installing alongside Windows 10, I had to hack the windows bootmanager as described in the dual-boot-tutorial (mentioned above):
bcdedit /set {bootmgr} path \EFI\manjaro\grubx64.efi
Otherwise Win10 messed up the boot-configuration regularly.

*I tried several, before settling down with Manjaro and MX-KDE-AHS as a second choice.

Hi @Friedrich1,
this is good news, means there should be a way …

The Dual-boot setup works fine, no errors during installation wth Architect (which performs basically fine). GRUB is working fine as well, just out of the box wth no malnual adjustments required: Windows starts no problem and performs like a charm, Manjaro shows the usual “drive/partition data” in the first line and then goes black. I assume just after graphic is initialized. It’s not possible to interact anymore (no other TTY etc.). The Architect is as well only starting through with GRUB parameter “nomodeset”, w/o that it hangs already when starting Architect in my case.

If you could get some information about the friends machine, I would love to verify some details:

  • Which model precisely?
  • Intel or AMD?
  • BIOS Version?
  • any specific BIOS settings (beside secure-boot off)
  • Any boot parameter nessecary?
  • what GPU?
  • dual boot setup wth windows?

I started to setup as a Manjaro only system. Above mentioned problems appeared an I just wanted to confirm what the problem is. So I installed Win10Pro with really no issues at all.

Still I’m lost and about givin up… loosing my daiy driver because Win is only for few games and programs which require Windows only.

  • Which model precisely?

Same as yours, I think:

  • Intel or AMD?

AMD 4500U

  • BIOS Version?

The latest (the previous (first one) worked as well)

  • any specific BIOS settings (beside secure-boot off)

Nothing that I remember. Apart from disabling wake up by LAN, USB,
which probably does not matter.

  • Any boot parameter nessecary?

This parameter is in the /boot/grub.cfg:
linux […] quiet udev.log_priority=3
But I am pretty sure not having added that myself.

  • what GPU?

Same as yours

  • dual boot setup wth windows?


I started to setup as a Manjaro only system.

I started with the win10 installation and let win10 do its default partitioning (3 partitions)

*(checked directly on my friends laptop via an anydesk connection)

Thats really weired. You are right, thats identically beside the BIOS update which was performed as one initial idea to fix the problems… After havin no success installing Manjaro as first step, I build the system then first with Win10 and Manjaro as the second, similar to your setup. The Grub parameter are the default ones. If Windows wouldnt run so smoothly, I would expect a hardware error on my machine as everything seems really same, beside the difference that my machine is rejecting any kind of linux beside poor running xubuntu.
Thank you for checking and confirming! Any idea or recommendation?

The nessecity of “nomodeset” indicates to me that here are issues with the graphics. But what?

Probably right.
I checked again on the friends laptop and you might want to check if these packages are installed:
linux-firmware (at the moment: 20200901)
linux-latest (kernel; at the moment: 5.8.1)

Good luck!
Bedtime for now…

Encouraged by your postings I deleted the existing Manjaro partition to make a clean reinstall (leaving the running Windows). As well I didnt put the “nomodeset” as additional start parameter in the Grub setting of Architect. The result ist again that by already by booting Architect it hangs at this well known position:

Maybe by setting “nomodeset” again I could perform an installation, which mostlikely again will not work.

One idea came to my mind: Is there recently a new version of Architect out, which you may have used?

I just noticed, that you mentioned above you had problems starting the “normal” live-media.
That should not be the case, as far as i can see.
They worked without any problem here (KDE and KDE_minimal).
I installed Manjaro using architect, but by starting architect from a running live session!
So if this does not work for you, the laptop hardware is probably not the cause of it.
Maybe try another USB-stick (Thats what I guess you use) or even a different USB-port.
Or check if you correctly wrote the iso to the USB-stick.

Hi again,
yes you are right: The probs appear already starting the “normal” live-media.
That the laptop hardware is probably not the cause of it is my believe as Win10 performs wth no problems. I tried your recommendations:

  • Maybe try another USB-stick : used new one
  • different USB-port : used different one
  • correctly wrote the iso to the USB-stick : This time used Rufus(Win) instead of dd(old machines Manjaro)

Additionally I included manually the packages

  • mhwd-amdgpu
  • xf86-video-amdgpu
  • linux-firmware (at the moment: 20200901)
  • linux-latest (kernel; at the moment: 5.8.1)

As a result, after below message again (presumably after changing the graphic mode) the usual black screen and humming vent. No improvement unfortunately. :disappointed_relieved:

just came to my mind that there are maybe 2 differences:

  1. I try to use XFCE (but KDE failed earlier on as well)
  2. I’m no partitioning SWAP (no need, Flashmem doesnt like)

I dont know that makes a difference? Shouldnt, but…

have added on boot param kernel ( from grub (e) )

have also try to get TTY ( Ctrl + Alt + F2 to F7 )

Hi @stephane, interesting ideas.
I thought IOMMU=pt helps for virtualisation? I have problems to get the system itself up.
As mentioned above its not possible to get anything, also TTY is not available.