Manjaro doesn't load xfce GUI after kernel upgrade

Stucks in .

/dev/sdc4: clean 464359/1978592 files, 4882161/7899648 blocks

Any other info required just ask me please!

There’s much more information that can be provided.

Do you have multiple kernel versions installed? Does it work with a different kernel version?

Can you switch to a TTY prompt, such as CTRL + ALT + F2?

If so, what happens if you run,

sudo systemctl restart display-manager.service

hi winnie thanks for your asnwer, well, how to know how many kernel version i have installed?
but when run: uname -r returns: 5.15.32-1-MANJARO
Yes, i can switch to tty promp with ctrl alt f2 and i could logged in with my account but the xfce gui still doesnt show up so i ran the line you told me to restart the display-manager service and nothing happens
so i ran sudo systemctl status display-manager.service
and show me that the lightdm.service was active(running)
what else could i do?

After attempting to restart the display manager, do the logs show any errors?

You can check with either,

journalctl -e


sudo dmesg | tail -n 100

Press Q to exit the journalctl view.

no, these logs doesnt show any errors with display manager, everything with it seems to be ok

Can you post your system info? Especially the GPU.

Is there anything under /etc/X11/xorg.conf.d/

inside /etc/X11/xorg.conf.d/ only have 2 files:
About my gpu if i run mhwd -li it shows:

What are the contents of 90-mhwd.conf

Let’s not forget the basics.

1 Like

content of 90-mhwd.conf, thanks for helping me i really appreciate it

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 390.147  (dvs-builder@U64-E08-29-1)  Mon Dec 13 13:50:12 UTC 2021

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"

Section "Files"

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
	Option "NoLogo" "1"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24

Section "Extensions"
    Option         "COMPOSITE" "Enable"

Section "InputClass"
    Identifier          "Keyboard Defaults"
    MatchIsKeyboard        "yes"
    Option              "XkbOptions" "terminate:ctrl_alt_bksp"
Section "ServerFlags"
  Option "IgnoreABI" "1"

if you want i can share you the file

Those are older drivers. Does your card not support the latest Nvidia drivers?

To rule something out, you can temporarily rename the file to 90-mhwd.conf.disabled, and then try to reboot the computer.

There has to be some error message showing in your logs when your display manager won’t start.

my graphic card is old, an 560 SE how to know or force the update of those drivers
im going to try the .disabled file and tell you later

hey winnie i made the change and rename 90-mhwd.conf as 90-mhwd.conf.disabled and reboot my pc, but keep the same issue, no gui at all

:face_with_raised_eyebrow: That’s not what this command would tell you. I’m not saying this is not the driver version you have installed but this is not a MHWD output it wouldn’t list the kernel version in the driver name. That lead to me wondering if you’re looking at the proper things people ask you to. For example seems like it should have some errors in log as said by winnie, but you have none, are you sure you’re doing what is asked to look at it?

//EDIT: are you sure you are up to date? do a sudo pacman -Syyu

1 Like

I have to revisit this. I took your word for it, but how do you know there are no issues or errors?

thanks for answer, i will run sudo pacman -Syyu and tell you later

sorry but im a little unexperienced with arch and linux in general, well, i can copy the content of any log file if you need it, just tell me what log file and i will share the file here

i ran de command and pacman updates 1 package and reboot but the GUI still doesnt show up


hi winnie i checked again the journalctl -e and i found something new i pass trough previously, this error:
``Failed to insert ‘nvidia’: No such file or directory
ctx=HEX# path=/lib/modules/5.15.32-1-MANJARO/extramodules/nvidia-modeset.ko.gz error=No such file or directory
ctx=HEX# path=/lib/modules/5.15.32-1-MANJARO/extramodules/nvidia.ko.gz error=No such file or directory
ctx=HEX# path=/lib/modules/5.15.32-1-MANJARO/kernel/arch/x86/kvm/kvm.ko.gz error=No such file or directory
hope this tell you something!