Lutris (Vulkan is not installed) Error

I just downloaded League of Legends to my Manjaro KDE Plasma with Lutris ,after first installation i closed ‘‘Riot Games Client’’ and i launched again but It gave me the error I mentioned in the title.

If u want to look at the ‘’‘inxi -Gazy’’

  Device-1: AMD Robson CE [Radeon HD 6370M/7370M] vendor: ASUSTeK
    driver: radeon v: kernel alternate: amdgpu arch: TeraScale-2 code: Evergreen
    process: TSMC 32-40nm built: 2009-15 pcie: gen: 1 speed: 2.5 GT/s lanes: 16
    ports: active: LVDS-1 empty: HDMI-A-1,VGA-1 bus-ID: 01:00.0
    chip-ID: 1002:68e4 class-ID: 0300 temp: 79.0 C
  Display: wayland server: v: with: Xwayland v: 23.1.1
    compositor: kwin_wayland driver: X: loaded: radeon unloaded: modesetting
    alternate: fbdev,vesa dri: r600 gpu: radeon display-ID: 0
  Monitor-1: LVDS-1 res: 1707x960 size: N/A modes: N/A
  API: OpenGL v: 4.5 Mesa 23.0.3 renderer: AMD CEDAR (DRM 2.50.0 /
    6.1.31-1-MANJARO LLVM 15.0.7) direct-render: Yes

Thanks for helps and sorry for my english…

Hi @Daktylos, and welcome!

In order for us, or anyone for that matter, to be able to provide assistance, more information is necessary. To that end, please see:

Hope you manage!

:bangbang: Tip: :bangbang:

To provide terminal output, copy the text you wish to share, and paste it here, surrounded by three (3) backticks, a.k.a grave accents. Like this:

pasted text

Or three (3) tilde signs, like this:

pasted text

This will just cause it to be rendered like this:

Portaest sed
cursus nisl nisi
hendrerit ac quis
tortor sit leo commodo.

Instead of like this:

Portaest sed elementum cursus nisl nisi hendrerit ac quis sit adipiscing tortor sit leo commodo.

Alternatively, paste the text you wish to format as terminal output, select all pasted text, and click the </> button on the taskbar. This will indent the whole pasted section with one TAB, causing it to render the same way as described above.

Thereby improving legibility and making it much easier for those trying to be of assistance.

:bangbang::bangbang: Additionally

If your language isn’t English, please prepend any and all terminal commands with LC_ALL=C. For example:

LC_ALL=C bluetoothctl

This will just cause the terminal output to be in English, making it easier to understand and debug.

Please edit your post accordingly.

This might be helpful, so also see:

Please provide the output of:

vulkaninfo --summary

ERROR: [../mesa-23.1.1/src/amd/vulkan/radv_physical_device.c:2157] Code 0 : Device '/dev/dri/renderD128' is not using the AMDGPU kernel driver: Invalid argument (VK_ERROR_INCOMPATIBLE_DRIVER)
ERROR: [Loader Message] Code 0 : setup_loader_term_phys_devs:  Failed to detect any valid GPUs in the current config
ERROR at /usr/src/debug/vulkan-tools/Vulkan-Tools-1.3.245/vulkaninfo/vulkaninfo.h:237:vkEnumeratePhysicalDevices failed with ERROR_INITIALIZATION_FAILED

This GPU: :point_down:

Doesn’t seem to support Vulkan. And this: :point_down:

Supports that.

So, either:

  • You need to disable that feature in Lutris; or
  • You’re out of luck.

Oh, well sorry for taking your time…

According to this:


I found that I have to uncomment this on Proton config file on Steam:

file location: /home/user/.steam/debian-installation/steamapps/common/Proton 5.0/ (this config file was duplicated from )
Uncomment the “PROTON_USE_WINED3D”: “1”,

#Use OpenGL-based wined3d for d3d11, d3d10, and d3d9 instead of Vulkan-based DXVK`


The same on Lutris, found the game you tried to install .yml

file location: /home/user/.config/lutris/game.yml

And change dxvk from true to false

dxvk: false
esync: true
version: lutris-5.7-8-x86_64

Maybe this could help others! :smiley:

I’m still noob to Games on Linux. Specially when you don’t have a good GPU.

Could you not do this in the lutris game settings?

Or if your gpu doesn’t support it you can probably just change it in the wine settings under preferences > runners > wine (and click settings) to disable it globally (what you did, but in gui instead, hacker… xD).

2 posts were split to a new topic: Moved to Private Message

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.