Libre Office Writer Window No Longer Visible

When I open Libre Office Writer, the splash screen appears but the window doesn’t. The only sign it’s open is an entry on the panel. When hovering over the icon in the panel, instead of showing a preview of the window it shows a thin black bar, like the window failed to load.


I tried running it from the command line via libreoffice --writer and the same thing happened with no error output. I’ve run the most recent Stable update and am on KDE. I’m using Libre Office Fresh from the repos.

  Kernel: 5.15.71-1-MANJARO arch: x86_64 bits: 64 Desktop: KDE Plasma
    v: 5.25.5 Distro: Manjaro Linux
  Type: Laptop System: LENOVO product: 3260EDU v: ThinkPad Edge E535
    serial: <superuser required>
  Mobo: LENOVO model: 3260EDU v: Win8 Pro DPK TPG
    serial: <superuser required> UEFI-[Legacy]: LENOVO v: HHET75WW (2.08 )
    date: 10/24/2012
  ID-1: BAT0 charge: 33.5 Wh (100.0%) condition: 33.5/40.4 Wh (83.0%)
  Info: dual core model: AMD A4-4300M APU with Radeon HD Graphics bits: 64
    type: MT MCP cache: L2: 1024 KiB
  Speed (MHz): avg: 1860 min/max: 1400/2500 cores: 1: 1894 2: 1827
  Device-1: AMD Trinity 2 [Radeon HD 7420G] driver: radeon v: kernel
  Device-2: Acer ThinkPad Integrated Camera type: USB driver: uvcvideo
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3 driver: X:
    loaded: radeon unloaded: modesetting dri: r600 gpu: radeon
    resolution: 1366x768~60Hz
  OpenGL: renderer: AMD ARUBA (DRM 2.50.0 / 5.15.71-1-MANJARO LLVM 14.0.6)
    v: 4.3 Mesa 22.1.7
  Device-1: AMD Trinity HDMI Audio driver: snd_hda_intel
  Device-2: AMD FCH Azalia driver: snd_hda_intel
  Sound API: ALSA v: k5.15.71-1-MANJARO running: yes
  Sound Server-1: PulseAudio v: 16.1 running: yes
  Sound Server-2: PipeWire v: 0.3.58 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8168
  IF: enp1s0 state: down mac: <filter>
  Device-2: Realtek RTL8188CE 802.11b/g/n WiFi Adapter driver: rtl8192ce
  IF: wlp2s0 state: up mac: <filter>
  Local Storage: total: 465.76 GiB used: 263.81 GiB (56.6%)
  ID-1: /dev/sda vendor: Western Digital model: WD5000LPLX-00ZNTT0
    size: 465.76 GiB
  ID-1: / size: 188.07 GiB used: 115.44 GiB (61.4%) fs: ext4 dev: /dev/dm-0
  ID-1: swap-1 type: partition size: 3.91 GiB used: 4.8 MiB (0.1%)
    dev: /dev/sda2
  System Temperatures: cpu: 42.1 C mobo: N/A gpu: radeon temp: 41.0 C
  Fan Speeds (RPM): cpu: 0
  Processes: 178 Uptime: 1d 4h 19m Memory: 7.2 GiB used: 1.79 GiB (24.9%)
  Shell: Zsh inxi: 3.3.22
1 Like

What does occur, when you start Libreoffice on console ./libreoffice ?

1 Like

If I run libreoffice without any flags, I get the Start Center window. In this case though, only the side menu is visible and I have to maximize the window to see the panel with recent files in it. I don’t get any errors opening it like this either, but if I click on “Writer Document”, a new document opens in the same size window.

What happens is Writer starts running but no window appears on the desktop. I don’t even get any tiny thing in the upper corner. The window preview from hovering Writer’s entry in the taskbar looks just like it does in the attachment, that weird line going down the middle.

I went to the link on Arch’s bbs and that’s virtually identical to my problem. I tried opening Writer from the Start Center and it opened properly. I then unmaximized the window, quit the program, and was able to re-open it straight from the Writer shortcut, but when I maximized the window again, I got the same window problem as before when I re-opened the program from the Writer shortcut. I also noticed I’m running version 7.4.1, which looks like the version that’s been having issues.

There is actually a really small window, but you can only see it’s borders, not the content. So you can resize it.

But yes, it’s a bug.

Looks like you’re right. I moved the cursor to the upper left corner of the desktop and when it turned into that double-ended arrow that shows up when it lands on a window corner, I started dragging. Sure enough, the window started expanding. Weird.

the workaround is not to close any libreoffice window maximixed, then you will get the non-maximized window on every launch

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.