LibreOffice Calc Does Not Open Correctly After Recent "Testing" Update?

Hi,

Running Manjaro KDE fully updated on the “Testing” branch.

The most recent “Testing” update did something bad to LibreOffice Calc.
When I open LibreOffice Calc, the application is very tiny and on the top-left part of screen?
(See screenshot)

Any ideas, thanks!

Jesse

1 Like

Hi @JeZxLee

that is kinda funny, because that happens always when I start Libreoffice the first time in a floating window manager like on XFCE, KDE or Gnome. However, no Issue in i3 and sort of.

It looks like that it has no predefined window size, therefore it goes the minimal size (almost zero).

But sorry, I have no solution to offer. Maybe someone can take look there. Would like to see a fix as well.

Greetings

Also can confirm this behavior. Switched to Libreoffice still, even downgraded but behavior stays the same.

One way to maximize the window is to

  • Right click the icon in the icon-only task manager > More > Set flag at ‘Maximize’

Another way is to resize the application window to a non-maximized or non-minimized size before closing the application. It keeps the size with a new open. A window rule didn’t help for me.

Maybe solved in version 7.4.2
https://git.libreoffice.org/core/+/105d129683b0e88bbb8e682d308786a587aa895f^!
https://bugs.documentfoundation.org/show_bug.cgi?id=150236
https://bugs.documentfoundation.org/show_bug.cgi?id=150779

3 Likes

Also have this issue:

Thanks @raguse for the bugs links.

Let’s hope it’s fixed in the next version.

1 Like

I got the LO update to 7.4.1-3 and it still has the issue. Waiting impatiently for 7.4.2.

7.4.2 is downloadable in pre-release on their homepage.