Kscreenlocker error. Cannot mix cannot mix incompatible qt library (5.15.2) with this library (5.15.3)

Hello! I installed Manjaro KDE today and than install all qt5 packages. After that lock screen stopped working.

I tried following command:

/usr/lib/kscreenlocker_greet --testing

And it gives me this:

Locked at 1647367884
Cannot mix incompatible Qt library (5.15.2) with this library (5.15.3)
zsh: IOT instruction (core dumped)  /usr/lib/kscreenlocker_greet --testing

How can i fix that? I already tried to update all qt5 packages and rebuild qt5-styleplugins. All other Qt program work fine.

Plasma version: 5.24.3
Kernel version: 5.15.28-1

Thanks in advice!

EDIT: I noticed, that in Wayland session all works fine!

Have a read at the update announcement:

I already tried this. It doesn’t help. All packages are up to date, no upgrades available.

The problem started right after the Steam update. I believe it’s this kde bug (451315).

I have the same problem, and I even do not have qt5-styleplugins installed .

1 Like

I guess this is a specific question for kscreenlocker. I tried launching okular in terminal and there is no warning or error.

1 Like

If by chance you locked before you reboot the system after the update, then that might be the behavior. Check what version of kscreenlocker you are running
pacman -Qi kscreenlocker

Try to reinstall it but use this comand
sudo pacman-mirrors -f5 && sudo pacman -Syyu kscreenlocker

1 Like

Here is the result of pacman -Qi kscreenlocker

Name            : kscreenlocker
Version         : 5.24.3-1
Description     : Library and components for secure lock screen architecture
Architecture    : x86_64

I have tried to reinstall it with sudo pacman-mirrors -f5 && sudo pacman -Syyu kscreenlocker, but the problem still exists.

Then try this

I find the problem. It seems that qt5-virtualkeyboard-bigscreen is outdated.

Repository      : community
Name            : qt5-virtualkeyboard-bigscreen
Version         : 5.15.2+kde+r4-1

Archlinux has removed this package, so maybe Manjaro needs to do this as well.

1 Like

Thank you, it’s solved my problem!

Seems like there’s already replacement for this: Arch Linux - qt5-virtualkeyboard 5.15.3+kde+r3-1 (x86_64). I’ve encountered the following error again on my second pc, and just reinstalling qt/qt5 packages didn’t help, but replacing qt5-virtualkeyboard-bigscreen with qt5-virtualkeyboard did the thing

This was also the way I fixed the problem. Anyway. thanks!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.