After updating qt 5.15.7, there's a problem on screen locking

Error message is:

The screen locker is broken

loginctl unlock-session 2

It’s really similar to This topic. But this time is:

Cannot mix incompatible Qt library (5.15.6) with this library (5.15.7)

I refered to the old topic and tried to use this command to fix:

sudo pacman-mirrors -f 5 && sudo pacman -Syyu 

But it doesn’t work. Sad.

But after I went back to qt 5.15.6, the problem dispeared.

It seems that you still have a QT package at version 5.15.6 after updating.

So after updating, try running

pacman -Qs qt5 | grep 5.15.6

to see what packages still wasn’t updated.

Yes, it seems there’s a package called


not updated. I think that’s the problem.

Thanks for the guide. I think I need to wait for the new qt5 package added to the unstable branch. :grin:

After receiving the latest update, this problem is solved. Thank you.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.