Lock screen broken after 2022-05-23 update

After last update - 2022-05-23 my screen locker is broken. I’m using KDE.
Any help is appriciated.


In order for us to be able to help you, please specify ‘broken’.

When my pc locks I get message on screen:
The screen locker is broken and unlocking is not possible anymore.
In order to unlock switch to a virtual terminal log in and execute the command: loginctl unlock-session 2
Then log out of virtual screen and switch back to running session.

Did you reboot after the update?

Yes, several times and rebooted just now. I can login when freshly starts pc but if I manually lock the pc or locks automaticly I get this error.

Just do it.

Then you need to check the error logs to find out what the problem is. You can use KSystemLog if you need a UI to easily check the different files (syslog, X11, …) Are you using Wayland or X11? Any special settings for the lockscreen? What happens if you log in, log out and log in again, and then lock the screen?

That’s because login screen and lock screen are 2 different things.

Do you use a specific (non-default) theme?
Do you see the problem with a fresh user?
Did you try cleanig caches?

My guess is the screen locker kicked in during the actual update. It was then deemed “broken” because something in Qt or Frameworks had since updated. Someone at KDE has gone to the trouble to code a special screen for this eventuality. It gives instruction on how to unlock (for which read “unbreak”) the screen locker.

Same for me. It suggests to use ctrl+alt+f2 shortcut to login through tty and then type loginctl unlock-session etc… tried reboots but nothing

I use breeze dark theme

I see there’s a bunch of “can’t mix incompatible qt library versions” errors in there. Please make sure everything is up to date and that you don’t have qt5-styleplugins installed.

already done that but same error remains

I had the same problem with @buzdrev after updating. I followed the message, rebooted, logged out and then logged in. But still can’t fix it. The login screen does not show X11 or wayland.
Now everytime the computer sleeps I get this problem. When I press the power button to turn off and then restart, I can enter the login interface.

I had the same issue like that. I checked the KSystemLog and it said that I had used incompatible Qt library. It’s because qt5-virtualkeyboard-bigscreen in my pc was outdated. I just replaced it with a newer qt5-virtualkeyboard and it works.


Thanks you very much. I install qt5-virtualkeyboard and it works.

Solution for me was to replace qt5-virtualkeyboard-bigscreen with qt5-virtualkeyboard.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.