Kio-fuse: command not found

I’m trying to use kio-fuse to mound smb in Dolphin. Previous posts regarding this endeavor are here: Building ffmpeg-git, target not found: intel-graphics-compiler-bin and Cannot play video from smb in Dolphin.

So the problem is, my kio-fuse installation is not good for some reason. I installed it by

$ sudo pacman -S kio-fuse

However, when I want to run it, it prompts:

$ kio-fuse
-bash: kio-fuse: command not found

How do I solve this?

kio-fuse is not an application, it’s a service:

$ pacman -Ql kio-fuse
kio-fuse /usr/
kio-fuse /usr/lib/
kio-fuse /usr/lib/kio-fuse
kio-fuse /usr/lib/systemd/
kio-fuse /usr/lib/systemd/user/
kio-fuse /usr/lib/systemd/user/kio-fuse.service
kio-fuse /usr/lib/tmpfiles.d/
kio-fuse /usr/lib/tmpfiles.d/kio-fuse-tmpfiles.conf
kio-fuse /usr/share/
kio-fuse /usr/share/dbus-1/
kio-fuse /usr/share/dbus-1/services/
kio-fuse /usr/share/dbus-1/services/org.kde.KIOFuse.service

I don’t think you need kio-fuse for smb mounting in Dolphin, I can do that before installing this package.

Thanks for the info! Do I enable it like this?

$ systemctl enable kio-fuse
$ systemctl start kio-fuse

The thing is, ffmpeg (for mpv) or VLC does not take smb: url properly, hence the necessity for the kio-fuse.

It runs in userspace, so add --user as well.

Oyea, for those you might need it.

I’ve just learned from here that

kio-fuse is a DBus activated service, so for permanent installation the
installed service file has to be in a directory used by dbus-daemon.
If you're installing into a custom prefix, you may want to link
[prefix]/share/dbus-1/services/org.kde.KIOFuse.service into
~/.local/share/dbus-1/services/ and
[prefix]/lib/systemd/user/kio-fuse.service into

To make sure that the installed version is actually used, stop any already
running instance with "killall kio-fuse" and log out and in again.

So it seems that kio-fuse should be evoked by DBus rather than starting by systemctl. Then the following sentence says linking the dbus-1 and systemd stuff (by ln -s I assume?). I wonder is this linking necessary?

Anyway, I started the kio-fuse service by systemctl way, but there’s no change on Dolphin, the shared folder still goes by a name of smb: url in the tab, rather than mounted by kio-fuse. Could anyone kindly teach me how to use kio-fuse for Dolphin? Thanks a lot!

Nothing to do for config this package !!!
it works : in dolphin open smb: and url is the same BUT with F4 we open terminal and can view clasic local Path (Prompt or by pwd)

1 Like

Thank you very much! To open terminal in pwd by pressing F4 works, and I can play video files using mpv command. Just to confirm, is this the only way kio-fuse works with Dolphin GUI? Because I read from somewhere that when you open a smb folder in Dolphin, the tab (address bar) in the GUI will change to the virtual directory that kio-fuse creates rather than the smb:// url…

no idea
but if i load movie from dolpin, in vlc , i can view /run/user/…

for mpv read this ?

Thanks, I think I have got the idea about kio-fuse itself.

Yes I’m aware of the necessary steps for mpv to play video in smb, which has been discussed here (with the help of @Darksky): Building ffmpeg-git, target not found: intel-graphics-compiler-bin. Basically rebuild the ffmpeg so it has --enable-libsmbclient functionaliy, and then mpv depends on this to play smb videos.

The thing is, if I open video from terminal in the virtual directory kio-fuse creates, it seems there’s no need to use this --enable-libsmbclient at all. That would be another problem to discuss: to open smb video without kio-fuse using ffmpeg’s libsmbclient support, the url it receives must be in format like smb://<user>@<host>. What Dolphin passes to ffmpeg is smb://<host>. Knowing this, I think this is too much a hustle for me to solve, I’ll use your suggestions instead!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.