How to have my Samba share show in file directory

You need these 3 things:


domain is not needed if it is the default one.

Sorry it is not like copy&paste. You need to type in the correct information there.

Since i have no idea how you set it up, i can only give examples.

And yes you need to create that folder.

1 Like

Lots of information that is 100% correct and 100% confusing to a new user. :wink:

First read this:

Then read that:

then edit your fstab to ensure your Samba shares are mounted at startup and become visible inside your local file system :+1: (The standard to do that is inside /mnt or /media)

If you would run into specific issues trying that, please leave another message.

Looking at the information already provided, this would do what you want:

# Create NAS mountpoint
sudo mkdir /mnt/NAS
mount -t cifs // /mnt/NAS -o username=james,password=JamesPassword,domain=WORKGROUP`

Where obviously james is the samba share’s username and JamesPassword, is that username’s password and WORKGROUP is the actual workgroup name

If that works, add the following line as the last line on your fstab:

// /mnt/NAS cifs uid=1001, username=james,password=JamesPassword,domain=WORKGROUP`

and for old time’s sake reboot. In Linux you never need to reboot for anything, just execute mount -a and that should do the trick.

So I got the temporary way to work, but on startup the fstab didn’t work, I had to use a terminal based emergency mode, and I ended up just using vim to remove the line I added. Instead of using /mnt/NAS I’m using /home/james/home, what does “cifs uid=1000” do, I think that’s what it didn’t work but the temporary way to mount it did.

So I tried it again, and this time after restarting, I got to my desktop, but it didn’t mount, when I access the folder, in dolphin, it says An error occurred while accessing ‘/home/james/home’, the system responded: mount: /etc/fstab: parse error at line 12 – ignored mount: /home/james/home: can’t find in /etc/fstab.
This is what I have in fstab for it
// /home/james/home cifs uid=1001, username=MY_USERNAME,password=MY_PASSWORD,domain=WORKGROUP

Add 0 0 at line end:

in “options”, I add nofail,noauto,x-systemd.automount,x-systemd.mount-timeout=30,_netdev if server not run when i open my manjaro ( and wiki)


You use kde !
Other way to access to smb:// by local file system without fstab (use kio-fuse package):

If smb is mounted with dolphin, we can access by local directory:


For test (and found directory): open smb directory in dolpin and open console by F4

1 Like

Can you explain a little bit with how that works, I’m not really sure how or what this is accomplishing?

We use fstab OR dolphin-smb://

kio-fuse package will automatically create a virtual directory on our machine after you manually mount your smb:// folder with dolphin.
So it will be accessible to all applications by /run/user/1001/kio-fuse-xxx/smb/ while with fstab you have /home/james/home/

So it’s another solution (without fstab/mount at boot) but:

  • no automatic smb mount
  • not a easy directory name to remember

Okay, so that works out of the box, and I like that, but I would rather get fstab to work better, it would automatically do it now that I vaguely understand how it works. With this kio method, I can navigate, to the folder, but I have to do a lot of clunky searching for the path, currently I found part of the solution was to get rid of a space but now I’m not getting write permission all the way so idk whether to settle for this or not.

in fstab you can add (for test) in options file_mode=0777,dir_mode=0777

1 Like

so the final line in fstab becomes:

// /home/james/home cifs uid=1001, username=MY_USERNAME,password=MY_PASSWORD,domain=WORKGROUP,file_mode=0777,dir_mode=0777 0 0


P.S. @papajoke Oh drat! forgot about the 0 0! Thanks for helping out!

So i’ve found part of the problem, initially, was that I had a space during the options, and apparently, that’s not allowed. Anyways, I’ve got it kinda configured right, almost verbatim what you’ve been typing with all variations, and they all return this error. “mount.cifs: permission denied”, weirdest thing, If I run mount -a, I get that error, if I run sudo mount -a, no problem.

Sorry for being confusing.

Please provide the output to:

echo $USER

and also provide the full mount command you’re using (not the mount --all command but the full mount command you used from here before you added it to the fstab file…)


P.S. also provide the same output from the computer that is running the Samba share when logged in there…
:bed: :zzz: :wave:

echo $User on computer:
groups output on computer:
sys network power sambashare lp wheel autologin james

Server user output:
jamess7995 adm cdrom sudo dip plugdev lxd

Mount command that you would use in terminal before configuring fstab:

mount -t cifs // /home/james/home -o  username=sora,password=123456,domain=leviathan

, which outputs ““mount: only root can use “–options” option””, using sudo resolves that and it just works at that point

Ah, you’re logging on under different user names and uids on both client and server.


  mount -t cifs // -o rw,username=sora,password=123456,domain=leviathan,vers=3.0  /home/james/home 

if that doesn’t work, what is the version number of the Samba running on the server?

Also, I’d make the server and client UIDs the same and use james instead of sora , but that’s just an opinion, not a technical necessity.


Still get “mount: only root can use “–options” option”
from server:

Version 4.7.6-Ubuntu```

Yeah, add sudo, sorry!!!

That should work. what’s your samba config file on the server?


Okay, but the whole issue seems to be that only root / sudo can do it, so even if I run sudo, I’m going to get the same issue with fstab since that’s the same logic?

Nope. fstab always runs as root.
The mount command we’re testing is just to ensure we get the fstab correct before modifying it…


Okay, so just like before, the command works only with sudo, not sure why we did that but what’s next.