KDE hangs on splash screen when logging in after logout

My issue is pretty much identical to thread 31359 (I cannot put links in this post).

Steps to reproduce:

  • Boot PC and wait for desktop to load (I have “automatically log in” set at startup)
  • Log out
  • Type password and click “log in”

Expected:
Desktop loads normally as on fresh boot

What happens instead:
Splash screen starts, and progress bar hangs.
After some time the mouse cursor appears and moves (bluetooth mouse is working)
Sometimes after waiting a LONG time, the desktop loads but with graphic glitches. After a reboot everything works fine.

I tried editing /etc/systemd/logind.conf as stated in thread 31359
I tried changing the line both as KillUserProcess=yes and KillUserProcesses=yes then rebooting, but nothing changes.

Thanks in advance

I have the same issue:

I think the some bug in Manjaro, not KDE?

I’m sorry, i forgot to add system info. I just updated to:

Operating System: Manjaro Linux
KDE Plasma Version: 5.20.3
KDE Frameworks Version: 5.76.0
Qt Version: 5.15.1
Kernel Version: 5.4.78-1-MANJARO
OS Type: 64-bit
Processors: 8 × Intel® Core™ i7-6700HQ CPU @ 2.60GHz
Memory: 31,2 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics 530

And the problem persists, however I noticed that by enabling: “KDE settings > login screen > advanced > Log in immediately after logging off” the logout and consequent log in works without problems.

I noticed same issues on my KDE, latest testing branch

I know new sddm 0.19.0-2.2 has the bug with new version of Plasma.
Try to downgrade old sddm 0.18.1-2 that works fine for me on my VM. You need to reboot after downgrade.
It is same as the version of sddm in KDE Neon that has no issue.

This old version of sddm works random, sry

I have the same issue

Hi Everyone,

I having the same problem on two separate installs.
It looks like desktop freezes but application menu sort of works.

I’m in unstable branch and after recent updates i’m also facing this issue.
I also noticed high CPU utilization by plasmashell, for plasmashell issue i have reported bug on KDE forum. Check if you are also facing high CPU utilization by plasmashell.

I am not sure but my issue seems related:

After bootup and login the display on one of my three displays frezzes. It is a black screen with frozen login spinner. When i change the displaysettings (my solution atm is to change the resolution on the affected screen) it works normally.

Edit: The one display just hanged again and when I tried to do my workaround the whole kde seemed to hang. I hat to kill switch my pc

I have something similar on KDE-Dev (Unstable).

  • I enter my password in SDDM
  • I see the spinner
  • A dialog box appears saying kded5 needs my KDE Wallet Password
  • I enter it and eventually I see my cursor, but the spinner stops.
  • I can ctrl alt f4 and login to a tty and sudo pacman -Syyu so I know my wireless got activated