Black screen on logout forcing reboot

I’ve looked at other posts that seem to be similar, but are not the same problem, and not on the same version of KDE. Also, I tried changing “KillUserProcesses=no” to “yes”. Either way my screen goes blank after logging out, no logging in involved. The monitor then keeps switching inputs (HDMI1,HDMI2) looking for a signal, but nothing doing. I have to reboot. This is on a recently installed (I think 01/23/2021) system. System info:

  Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 
  root=UUID=4404eb16-d7a1-403e-b421-e9aef693b66a ro quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.20.5 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Desktop Mobo: ASUSTeK model: TUF GAMING X570-PLUS (WI-FI) v: Rev X.0x 
  serial: <filter> UEFI: American Megatrends v: 2607 date: 08/14/2020 
  Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard serial: <filter> 
  charge: 55% (should be ignored) rechargeable: yes status: Discharging 
  Info: 6-Core model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2 
  family: 17 (23) model-id: 71 (113) stepping: N/A microcode: 8701021 
  L2 cache: 3 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 86258 
  Speed: 2196 MHz min/max: 2200/3600 MHz boost: enabled Core speeds (MHz): 
  1: 2196 2: 2195 3: 2192 4: 2190 5: 2195 6: 2194 7: 2195 8: 2192 9: 2195 
  10: 2191 11: 2193 12: 2188 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA GP104 [GeForce GTX 1060 6GB] vendor: Gigabyte 
  driver: nvidia v: 460.32.03 alternate: nouveau,nvidia_drm bus ID: 0b:00.0 
  chip ID: 10de:1b83 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: 
  loaded: nvidia display ID: :0 screens: 1 
  Screen-1: 0 s-res: 3840x2160 s-dpi: 159 s-size: 613x352mm (24.1x13.9") 
  s-diag: 707mm (27.8") 
  Monitor-1: HDMI-0 res: 3840x2160 hz: 60 dpi: 160 
  size: 608x345mm (23.9x13.6") diag: 699mm (27.5") 
  OpenGL: renderer: GeForce GTX 1060 6GB/PCIe/SSE2 v: 4.6.0 NVIDIA 460.32.03 
  direct render: Yes 
  Device-1: Creative Labs CA0108/CA10300 [Sound Blaster Audigy Series] 
  driver: snd_emu10k1 v: kernel bus ID: 05:00.0 chip ID: 1102:0008 
  Device-2: NVIDIA GP104 High Definition Audio vendor: Gigabyte 
  driver: snd_hda_intel v: kernel bus ID: 0b:00.1 chip ID: 10de:10f0 
  Device-3: AMD Starship/Matisse HD Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 0d:00.4 chip ID: 1022:1487 
  Sound Server: ALSA v: k5.9.16-1-MANJARO 
  Device-1: Intel Wireless-AC 9260 driver: iwlwifi v: kernel port: e000 
  bus ID: 06:00.0 chip ID: 8086:2526 
  IF: wlp6s0 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8169 v: kernel port: d000 bus ID: 07:00.0 
  chip ID: 10ec:8168 
  IF: enp7s0 state: down mac: <filter> 
  Local Storage: total: 1.89 TiB used: 51.83 GiB (2.7%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 980 PRO 1TB 
  size: 931.51 GiB block size: physical: 512 B logical: 512 B speed: 63.2 Gb/s 
  lanes: 4 serial: <filter> rev: 2B2QGXA7 temp: 36.9 C 
  ID-2: /dev/sda maj-min: 8:0 vendor: SanDisk model: SDSSDXPS480G 
  size: 447.13 GiB block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: 00RL 
  ID-3: /dev/sdb maj-min: 8:16 vendor: Kingston model: SA400S37480G 
  size: 447.13 GiB block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: 61K1 
  ID-4: /dev/sdc maj-min: 8:32 vendor: Kingston model: SA400S37120G 
  size: 111.79 GiB block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: B1E1 
  ID-1: / raw size: 931.01 GiB size: 915.4 GiB (98.32%) used: 51.83 GiB (5.7%) 
  fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 
  ID-2: /boot/efi raw size: 512 MiB size: 511 MiB (99.80%) 
  used: 312 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 47.2 C mobo: N/A gpu: nvidia temp: 55 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 28% 
  Processes: 303 Uptime: 2m wakeups: 2 Memory: 62.78 GiB used: 2.48 GiB (3.9%) 
  Init: systemd v: 247 Compilers: gcc: 10.2.0 Packages: pacman: 1337 lib: 409 
  flatpak: 0 Shell: Bash v: 5.1.0 running in: konsole inxi: 3.2.02

Do you have the same experience with 510 or 54?
(59 will no longer be updated latest is now 510 or 54 LTS)

Haven’t tried 510 or 54. I guessing that you suggest I try. I’ll get back after trying. Thanks.

I tried other kernels, to no avail. I don’t think it’'s a kernel problem. More likely KDE or SDDM. Any other suggestions? Anyone?

Is this not the place to get support? If not, can you point me at the proper place?

I am using the 5.4.89 kernel and I have the same exact problem. At first I thought it was the Nouveau drivers that I am using.

I tried the command chvt 1 after pressing ctl+alt+F2.
Also tried sudo sddm and just sddm.

That does not help either.

I found this, which seems to have fixed it for me:
Thanks wojtosla!

I tried downgrading sddm, as per a suggestion. That did not help. I think I will wait until the big update coming soon. Annoying, but not urgent for me as I rarely have a need to log out.