Inxi -Fazy says pipewire is running, but I cannot delete it as Add/Remove says it isnt installed?

Hi, upon advice with a different issue, I was informed that I am running pipewire & pulse and to only use one.

Atm Im choosing to use Pulse as I had a lot of issues with pipewire & jack before … so I decided to remove pipewire however I cannot as Add/Remove says its not installed?

Ive had a look thru approx 4 pages of search results using my keywords and cant find any similar post as to why this may be or what to do to try and fix it. (I have looked)

  Kernel: 5.15.46-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=ce855673-fe32-42db-ad8d-b31e5de8e913 rw radeon.si_support=1
    radeon.cik_support=1 apparmor=1 security=apparmor
    resume=UUID=757b5e60-6999-41b8-a9df-8c2136460b4a udev.log_priority=3
  Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.4 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: P8H61-M LE/USB3 v: Rev x.0x
    serial: <superuser required> BIOS: American Megatrends v: 4601
    date: 09/18/2013
  Info: model: Intel Core i5-2500 bits: 64 type: MCP arch: Sandy Bridge
    gen: core 2 built: 2010-12 process: Intel 32nm family: 6 model-id: 0x2A (42)
    stepping: 7 microcode: 0x2F
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
    desc: 1x6 MiB
  Speed (MHz): avg: 1656 high: 1836 min/max: 1600/3700 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 1596 2: 1836 3: 1596
    4: 1596 bogomips: 26347
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled
  Type: mds mitigation: Clear CPU buffers; SMT disabled
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Hawaii PRO [Radeon R9 290/390] driver: radeon v: kernel
    alternate: amdgpu arch: GCN 2 process: GF/TSMC 16-28nm built: 2013-17 pcie:
    gen: 2 speed: 5 GT/s lanes: 16 link-max: gen: 3 speed: 8 GT/s ports:
    active: HDMI-A-1 empty: DP-1,DVI-D-1,DVI-D-2 bus-ID: 01:00.0
    chip-ID: 1002:67b1 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.3 compositor: kwin_x11 driver: X:
    loaded: radeon unloaded: modesetting alternate: fbdev,vesa gpu: radeon
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: HDMI-A-1 mapped: HDMI-0 model: LG (GoldStar) 42LF66
    serial: <filter> built: 2007 res: 1920x1080 hz: 60 dpi: 49 gamma: 1.2
    size: 1000x550mm (39.37x21.65") diag: 802mm (31.6") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  OpenGL: renderer: AMD HAWAII (LLVM 13.0.1 DRM 2.50 5.15.46-1-MANJARO)
    v: 4.5 Mesa 22.1.1 direct render: Yes
  Device-1: AMD Hawaii HDMI Audio [Radeon R9 290/290X / 390/390X]
    driver: snd_hda_intel v: kernel bus-ID: 2-1.3:3 pcie: chip-ID: 047f:c056
    gen: 2 speed: 5 GT/s class-ID: 0300 serial: <filter> lanes: 16 link-max:
    gen: 3 speed: 8 GT/s bus-ID: 01:00.1 chip-ID: 1002:aac8 class-ID: 0403
  Device-2: Creative Labs Sound Core3D [Sound Blaster Recon3D / Z-Series]
    driver: snd_hda_intel v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    bus-ID: 03:00.0 chip-ID: 1102:0012 class-ID: 0403
  Device-3: Plantronics Plantronics Blackwire 3220 Series type: USB
    driver: plantronics,snd-usb-audio,usbhid
  Sound Server-1: ALSA v: k5.15.46-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.0 running: yes
  Sound Server-4: PipeWire v: 0.3.52 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK P8P67 and other motherboards driver: r8169 v: kernel pcie:
    gen: 1 speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 04:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp4s0 state: down mac: <filter>
  Device-2: Ralink RT5370 Wireless Adapter type: USB driver: rt2800usb
    bus-ID: 1-1.1:3 chip-ID: 148f:5370 class-ID: 0000 serial: <filter>
  IF: wlp0s26u1u1 state: up mac: <filter>
  IF-ID-1: virbr0 state: down mac: <filter>
  Device-1: TP-Link UB500 Adapter type: USB driver: btusb v: 0.8
    bus-ID: 2-1.6:6 chip-ID: 2357:0604 class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 2.04 TiB used: 1.51 TiB (74.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 model: SATA3 120GB SSD size: 111.79 GiB
    block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s type: SSD
    serial: <filter> rev: 7A0 scheme: MBR
  ID-2: /dev/sdb maj-min: 8:16 vendor: Kingston model: SA400S37120G
    size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    type: SSD serial: <filter> rev: 71E0 scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 vendor: Seagate model: ST1000DM003-9YN162
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: CC4H scheme: MBR
  ID-4: /dev/sdd maj-min: 8:48 vendor: Seagate model: ST1000DM010-2EP102
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: CC43 scheme: MBR
  ID-1: / raw-size: 102.99 GiB size: 100.81 GiB (97.89%)
    used: 69.05 GiB (68.5%) fs: ext4 dev: /dev/sda1 maj-min: 8:1
  Kernel: swappiness: 10 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/sda2 maj-min: 8:2
  System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: radeon temp: 65.0 C
  Fan Speeds (RPM): N/A
  Processes: 224 Uptime: 3h 29m wakeups: 0 Memory: 15.59 GiB
  used: 3.39 GiB (21.7%) Init: systemd v: 251 default: graphical
  tool: systemctl Compilers: gcc: 12.1.0 clang: 13.0.1 Packages: 1752
  pacman: 1709 lib: 499 flatpak: 24 snap: 19 Shell: Zsh v: 5.9 default: Bash
  v: 5.1.16 running-in: konsole inxi: 3.3.18

what is output from:
pacman -Qs pipewire

    Low-latency audio/video router and processor - 32-bit client library
local/pipewire 1:0.3.52-1
    Low-latency audio/video router and processor
local/pipewire-media-session 1:0.4.1-2
    Example session manager for PipeWire```

is this the whole output?
if you want to search for pipewire, type pipewire in the add/remove software and click on installed

Hello …

Yes it was …

And thx … Seems a bit obvious after you suggested it that way :slight_smile:

it looks like you have installed 2 pipewire packages, so if you dont want it, uninstall them

Hi …

Ive tried to uninstall them and Im getting a load of dependency issues come up … its seems that it wont let me remove the thing the dependencies rely on :grimacing:

So still in situ where I cannot remove pipewire :frowning:

You could try installing the package manjaro-pulse. It is set to conflict with pipewire packages so it should automatically remove the conflicting packages on install.

Hi and thx for the reply :slight_smile:

My “manjaro-pulse” is already installed.

Would it hurt it if tried removing it and then re-installing … Or is there a possibility that I could further mess up a load of different dependencies in the process?

From the documentation, if the packages can’t be removed, you may still at least disable the related services.

systemctl --user disable --now pipewire-pulse.service
systemctl --user disable --now pipewire-pulse.socket

Please avoid posting a screenshot for justifying everything. If you do want to justify your reply, please prefer using command outputs as much as possible.

And there’s me thinking I had covered all the bases :innocent: … I`ll give that a go & thank you for the advice!

The other thing you might want to try is installing the manjaro-pipewire package. Then once that’s done install the manjaro-pulse package. I dont THINK anything should be messed up by doing so as both packages conflict with each other.

Ok … So … Its just errors, errors, errors in this camp im afraid :joy:

    ~  systemctl --user disable --now pipewire-pulse.service                                                                                        ✔ 
Failed to disable unit: Unit file pipewire-pulse.service does not exist.
    ~  systemctl --user disable --now pipewire-pulse.socket                                                                                       1 ✘ 
Failed to disable unit: Unit file pipewire-pulse.socket does not exist.

If I try and install the manjaro-pipewire package I get these errors pop up ( Ive had them before ) - Failed to prepare transaction … The build files say

pkgdesc="Kernel modules for Anbox or Waydroid (DKMS)"

pkgver() {
	cd "$srcdir/$_pkgname/"
	printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"

prepare() {
	cd "$srcdir/$_pkgname/"
	sed -i "s/^PACKAGE_VERSION=\".*\"$/PACKAGE_VERSION=\"$pkgver\"/g" ./**/dkms.conf
	# needed for linux 5.18
	sed -i '1s/^/#include <linux\/task_work.h>\n/' binder/deps.c
	# this should work with all Arch Linux kernels (including linux-lts)
	#sed -i 's/^#if (LINUX_VERSION_CODE >= KERNEL_VERSION(5,15,2))$/#if 1/g' binder/binder.c

package() {
	cd "$srcdir/$_pkgname/"
	install -Dm644 anbox.conf "$pkgdir/usr/lib/modules-load.d/$_pkgname.conf"
	install -Dm644 99-anbox.rules "$pkgdir/usr/lib/udev/rules.d/99-$_pkgname.rules"
	install -dm755 "$pkgdir/usr/src/"
	cp -rT ashmem "$pkgdir/usr/src/anbox-ashmem-$pkgver"
	cp -rT binder "$pkgdir/usr/src/anbox-binder-$pkgver"
- removing jack2 breaks dependency 'jack2' required by jack2-dbus
- removing pulseaudio breaks dependency 'pulseaudio=16.0-1' required by pulseaudio-jack

target not found: anbox-modules-dkms-git

you are running 5.15.46 kernel, so you didnt run the latest stable update

Not yet … Im still a linux noob and after formatting my machine approx 20 times last year every time a update happened in PopOs & broke the Amdgpu-pro dependencies ( bleeding long story) … I have a mass fear of updating just because. :frowning:

Would just updating my kernel really be enough to fix these issues?

Im half considering just downloading the lastest Iso and installing from scratch if Pipewire has already taken over … Would it be setup from the get go if I did that?

Forget about that inxi output. And forget about removing pipewire package. Why is this coming up every few days. Many things depend on pipewire even if it is not in use.

If you want to remove package x and 100 things depend on it, isn’t this a big enough clue by itself, that it most probably shouldn’t be removed?

How to know which audio server you are running?

pactl info

If you get Server Name: pulseaudio then you are using PulseAudio.
If you get Server Name: PulseAudio (on PipeWire 0.3.52) then you are using PipeWire.


I just installed the latest release and I don’t remember pipewire being setup by default.

Can you do me a favour and post output of:

grep -m1 pipewire /var/log/pacman.log && stat /

You are kind of “advice-resistent”. Remove the aur/git pacages first (i.e.: you have both pipewire-alsa and pipewire-alsa-git). Remove that mess, get a clean setup, update you system and then ask for advice for what you want to archive.

1 Like

Hi & thx for the input.

Here is my output - I am running pulse

Server String: /run/user/1000/pulse/native
Library Protocol Version: 35
Server Protocol Version: 35
Is Local: yes
Client Index: 16
Tile Size: 65472
User Name: rob
Host Name: rob-Manj-22
Server Name: pulseaudio
Server Version: 16.0
Default Sample Specification: s16le 2ch 44100Hz
Default Channel Map: front-left,front-right
Default Sink: alsa_output.usb-Plantronics_Plantronics_Blackwire_3220_Series_AD024E0046484CA98515CE4E74B9607C-00.analog-stereo
Default Source: alsa_output.usb-Plantronics_Plantronics_Blackwire_3220_Series_AD024E0046484CA98515CE4E74B9607C-00.analog-stereo.monitor
Cookie: 88d9:94a4

So basically dont remove anything as there are obviously some pipewire dependencies (steam I think ) and continue just to use pulse. (This was my inital thought after going thru a lot of guides & suggestions found on here after a week of looking ). So I feel that Im kinda back at square one now with my inital problem.

TLDR … Im getting errors from modules on boot that have “NOTHING” to do with PEffects as I have been told by the dude who supports it on github.

The modules that are causing an issue cannot be removed because they are being used by Timeshift & gnome-disk-utility … Of which I dont now wish to remove as I like using them.

What I need to know if how I can go about trying to remove the modules from loading up in PEffects as they are not needed n so shouldnt cause a issue if I remove some lines (I assume via a config file).

I do not know how to do this or what approach I should take to resolve this?

Imo … This has nothing to do with Pulse or flatpak its to do with a config file … one that I need to edit … am I thinking right or am I missing something obvious?

P.s … If I am thinking correct, do you know what path(s) im likely to run across the config file :smiley:

Sorry for my typos … Im dyslexic