Internal Speakers/Jack detected but no audio comes out

Hello, i recently installed manjaro along side windows and ubuntu 18.04 and i am unable to get the speakers to work on my system. I know they do work as both windows and ubuntu are capable of using it.
I found this in dmesg, i have no idea if its related to this problem though.
[ 17.206499] snd_hda_intel 0000:00:1f.3: No response from codec, resetting bus: last cmd=0x202a0000
[ 17.210977] snd_hda_intel 0000:00:1f.3: spurious response 0x0:0x2, last cmd=0x202a0000
[ 18.219764] snd_hda_intel 0000:00:1f.3: azx_get_response timeout, switching to single_cmd mode: last cmd=0x01270700
[ 18.219886] azx_single_wait_for_response: 13 callbacks suppressed
[ 18.928500] snd_hda_codec_realtek hdaudioC0D0: Unable to sync register 0x1f0e00. -5
[ 18.928715] snd_hda_codec_realtek hdaudioC0D0: Unable to sync register 0x1f0e00. -5
[ 19.462792] snd_hda_codec_hdmi hdaudioC0D2: Unable to sync register 0x2f0d00. -5

This is my output from “inxi -Fazy”:
System:
Kernel: 5.8.16-2-MANJARO x86_64 bits: 64 compiler: N/A
parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64
root=UUID=131e9ee0-8e8f-49c3-92f1-967416751be4 rw quiet apparmor=1
security=apparmor udev.log_priority=3
Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.1 wm: kwin_x11 dm: SDDM
Distro: Manjaro Linux
Machine:
Type: Laptop System: IT Channel Pty product: P95_96_97Ex,Rx v: N/A
serial: Chassis: type: 10 serial:
Mobo: IT Channel Pty model: P95_96_97Ex,Rx serial: UEFI: INSYDE
v: 1.07.01TMB date: 02/18/2019
Battery:
ID-1: BAT0 charge: 57.9 Wh condition: 57.9/56.2 Wh (103%) volts: 17.0/15.2
model: Notebook BAT type: Li-ion serial: status: Full
CPU:
Topology: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP
arch: Kaby Lake family: 6 model-id: 9E (158) stepping: A (10) microcode: D6
L2 cache: 12.0 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
bogomips: 48019
Speed: 800 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 800 2: 800 3: 800
4: 800 5: 800 6: 800 7: 800 8: 800 9: 800 10: 801 11: 800 12: 800
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel UHD Graphics 630 vendor: CLEVO/KAPOK driver: i915 v: kernel
bus ID: 00:02.0 chip ID: 8086:3e9b
Device-2: NVIDIA TU106M [GeForce RTX 2060 Mobile] vendor: CLEVO/KAPOK
driver: nvidia v: 455.28 alternate: nouveau,nvidia_drm bus ID: 01:00.0
chip ID: 10de:1f11
Device-3: Acer BisonCam NB Pro type: USB driver: uvcvideo bus ID: 1-8:8
chip ID: 5986:9102
Display: x11 server: X.Org 1.20.9 compositor: kwin_x11
driver: modesetting,nvidia display ID: :0 screens: 1
Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1013x285mm (39.9x11.2")
s-diag: 1052mm (41.4")
Monitor-1: HDMI-0 res: 1920x1080 dpi: 305 size: 160x90mm (6.3x3.5")
diag: 184mm (7.2")
Monitor-2: eDP-1-1 res: 1920x1080 hz: 144 dpi: 128
size: 382x215mm (15.0x8.5") diag: 438mm (17.3")
OpenGL: renderer: GeForce RTX 2060/PCIe/SSE2 v: 4.6.0 NVIDIA 455.28
direct render: Yes
Audio:
Device-1: Intel Cannon Lake PCH cAVS vendor: CLEVO/KAPOK
driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci
bus ID: 00:1f.3 chip ID: 8086:a348
Device-2: NVIDIA TU106 High Definition Audio vendor: CLEVO/KAPOK
driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:10f9
Sound Server: ALSA v: k5.8.16-2-MANJARO
Network:
Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel
port: 5000 bus ID: 00:14.3 chip ID: 8086:a370
IF: wlp0s20f3 state: up mac:
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: CLEVO/KAPOK driver: r8169 v: kernel port: 3000 bus ID: 08:00.0
chip ID: 10ec:8168
IF: enp8s0 state: down mac:
Drives:
Local Storage: total: 2.82 TiB used: 403.91 GiB (14.0%)
ID-1: /dev/mmcblk0 model: N/A size: 62.50 GiB block size: physical: 512 B
logical: 512 B serial: scheme: MBR
SMART Message: Unknown smartctl error. Unable to get data.
SMART Message: Unable to run smartctl. Root privileges required.
ID-2: /dev/sda vendor: TeamGroup model: TM8PS7001T size: 953.87 GiB
block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s serial:
rev: 9A0 scheme: GPT
ID-3: /dev/sdb vendor: Seagate model: ST2000LX001-1RG174 size: 1.82 TiB
block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
rotation: 5400 rpm serial: rev: SDM1 scheme: GPT
ID-4: /dev/sdc type: USB vendor: Verbatim model: STORE N size: 7.28 GiB
block size: physical: 512 B logical: 512 B serial: rev: 8.07
scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw size: 145.36 GiB size: 142.08 GiB (97.74%)
used: 41.67 GiB (29.3%) fs: ext4 dev: /dev/sda7
Swap:
Kernel: swappiness: 60 (default) cache pressure: 100 (default)
ID-1: swap-1 type: partition size: 9.54 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/sda5
Sensors:
System Temperatures: cpu: 65.0 C mobo: N/A gpu: nvidia temp: 51 C
Fan Speeds (RPM): N/A
Info:
Processes: 313 Uptime: 5m Memory: 15.35 GiB used: 2.86 GiB (18.6%)
Init: systemd v: 246 Compilers: gcc: 10.2.0 alt: 9 Packages: pacman: 1271
lib: 348 flatpak: 0 Shell: Bash v: 5.0.18 running in: yakuake inxi: 3.1.05

check in log

sudo journalctl -b0

see this

i ran:

journalctl -b -p err

and it showed:

Oct 23 08:16:25 cupiditas-potatokiller kernel: snd_hda_intel 0000:00:1f.3: No response from codec, resetting bus: last cmd=0x202a0000
Oct 23 08:16:25 cupiditas-potatokiller kernel: snd_hda_intel 0000:00:1f.3: spurious response 0x4015:0x2, last cmd=0x202a0000
Oct 23 08:16:26 cupiditas-potatokiller kernel: snd_hda_intel 0000:00:1f.3: azx_get_response timeout, switching to single_cmd mode: last cmd=0x01270700
Oct 23 08:16:27 cupiditas-potatokiller kernel: snd_hda_codec_realtek hdaudioC0D0: Unable to sync register 0x1f0e00. -5
Oct 23 08:16:27 cupiditas-potatokiller kernel: snd_hda_codec_realtek hdaudioC0D0: Unable to sync register 0x1f0e00. -5
Oct 23 08:16:27 cupiditas-potatokiller kernel: snd_hda_codec_hdmi hdaudioC0D2: Unable to sync register 0x2f0d00. -5

It looks like i may be having a few issues with audio? there also appeared to be an Xorg core dump just before thisThis text will be hidden
EDIT:
Ive just looked inside modprobe.d and found that i dont have an alsa file at all, on ubuntu atleast changing that changed my systems sound severely. Should that be missing?

Onboard audio device Intel Cannon Lake PCH and 9th Generation Intel CPU probably has a built-in digital microphone array (DMIC) that is not supported by the usual snd_hda_intel driver
system requires a different driver for the DMIC from package sof-firmware

But SOF drivers did not work well when first released and needed a number of patches to work on laptop systems

The usual modprobe.d option for these systems was a workaround to disable the internal DMIC
so the rest of the sound card would use the ‘legacy’ snd_hda_intel driver

# /etc/modprobe.d/alsa.conf
options snd-intel-dspcfg dsp_driver=1

(Ubuntu may have used an older option snd-hda-intel dmic_detect=0 but that option is no longer supported by kernel v5.8)

But if use of internal DMIC is needed, system needs package sof-firmware installed and a later version of PulseAudio (v13.99) that has patches included for the DMIC

See this discussion for how to switch to Manjaro testing branch to get the development version of PulseAudio - Problems with audio on laptop

Update on previous post:

PulseAudio v13.99 is in latest stable branch update - [Stable Update] 2020-11-04

so changing branches is not needed now - just update all stable packages