Intel Sound firmware missing

Update:

Just recompiled the kernel getting this:
==> WARNING: Possibly missing firmware for module: xhci_pci

So nothing to do with alsa-lib??

First post:
I restored my Manjaro to a new PC and now its missing:

    Sep 05 11:08:43 manjaro kernel: sof-audio-pci 0000:00:1f.3: error: request firmware intel/sof/sof-icl.ri failed err: -2

    [john1@manjaro ~]$ lspci

00:00.0 Host bridge: Intel Corporation Device 8a12 (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Iris Plus Graphics G7 (rev 07)
00:04.0 Signal processing controller: Intel Corporation Device 8a03 (rev 03)
00:07.0 PCI bridge: Intel Corporation Ice Lake Thunderbolt 3 PCI Express Root Port #0 (rev 03)
00:0d.0 USB controller: Intel Corporation Ice Lake Thunderbolt 3 USB Controller (rev 03)
00:0d.2 System peripheral: Intel Corporation Ice Lake Thunderbolt 3 NHI #0 (rev 03)
00:12.0 Serial controller: Intel Corporation Device 34fc (rev 30)
00:14.0 USB controller: Intel Corporation Ice Lake-LP USB 3.1 xHCI Host Controller (rev 30)
00:14.2 RAM memory: Intel Corporation Device 34ef (rev 30)
00:14.3 Network controller: Intel Corporation Killer Wi-Fi 6 AX1650i 160MHz Wireless Network Adapter (201NGW) (rev 30)
00:15.0 Serial bus controller [0c80]: Intel Corporation Ice Lake-LP Serial IO I2C Controller #0 (rev 30)
00:15.1 Serial bus controller [0c80]: Intel Corporation Ice Lake-LP Serial IO I2C Controller #1 (rev 30)
00:16.0 Communication controller: Intel Corporation Management Engine Interface (rev 30)
00:1c.0 PCI bridge: Intel Corporation Ice Lake-LP PCI Express Root Port #5 (rev 30)
00:1d.0 PCI bridge: Intel Corporation Device 34b4 (rev 30)
00:1f.0 ISA bridge: Intel Corporation Ice Lake-LP LPC Controller (rev 30)
00:1f.3 Multimedia audio controller: Intel Corporation Smart Sound Technology Audio Controller (rev 30)
00:1f.4 SMBus: Intel Corporation Ice Lake-LP SMBus Controller (rev 30)
00:1f.5 Serial bus controller [0c80]: Intel Corporation Ice Lake-LP SPI Controller (rev 30)
2b:00.0 3D controller: NVIDIA Corporation GP108M [GeForce MX250] (rev a1)
2c:00.0 Non-Volatile memory controller: Micron Technology Inc Device 5410 (rev 01)
[john1@manjaro ~]$

How to fix that?

Info:

Audio: Device-1: Intel Smart Sound Audio driver: sof-audio-pci
Sound Server: ALSA v: k5.8.3-2-MANJARO

pavucontrol shows no device!

Thank you

Shit!
I can’t paste inxi -F to this post?!!
Link not possible

can you please add

sudo pacman -S  sof-firmware alsa-ucm-conf  

reboot and recheck with pavucontrol

@philm @schinfo maybe we need to add sof-firmware for intel sound

rebooted but:

    [john1@manjaro ~]$ journalctl -b -p err

– Logs begin at Sat 2020-09-05 10:44:37 CEST, end at Sat 2020-09-05 18:24:27 CEST. –
Sep 05 16:37:52 manjaro kernel: pci 0000:00:07.0: DPC: RP PIO log size 0 is invalid
Sep 05 16:37:52 manjaro systemd-udevd[296]: could not read from ‘/sys/module/pcc_cpufreq/initstate’: No such device
Sep 05 16:37:52 manjaro kernel: intel-spi 0000:00:1f.5: invalid resource
Sep 05 16:37:52 manjaro kernel: i801_smbus 0000:00:1f.4: Transaction timeout
Sep 05 16:37:52 manjaro kernel: i801_smbus 0000:00:1f.4: Failed terminating the transaction
Sep 05 16:37:52 manjaro kernel: i801_smbus 0000:00:1f.4: SMBus is busy, can’t use it!
Sep 05 16:37:53 manjaro kernel: i2c_hid i2c-MSFT0001:01: failed to retrieve report from device.
Sep 05 16:37:53 manjaro kernel: i2c_hid i2c-MSFT0001:01: failed to retrieve report from device.
Sep 05 16:37:54 manjaro wpa_supplicant[885]: nl80211: kernel reports: Attribute failed policy validation
Sep 05 16:37:54 manjaro wpa_supplicant[885]: Failed to create interface p2p-dev-wlp0s20f3: -22 (Invalid argument)
Sep 05 16:37:54 manjaro wpa_supplicant[885]: nl80211: Failed to create a P2P Device interface p2p-dev-wlp0s20f3
Sep 05 16:37:56 manjaro kernel: sd 0:0:0:0: [sdb] No Caching mode page found
Sep 05 16:37:56 manjaro kernel: sd 0:0:0:0: [sdb] Assuming drive cache: write through
Sep 05 16:37:56 manjaro kernel: sd 1:0:0:0: [sda] No Caching mode page found
Sep 05 16:37:56 manjaro kernel: sd 1:0:0:0: [sda] Assuming drive cache: write through
Sep 05 16:37:57 manjaro python[1553]: backintime (john1/1): ERROR: Back In Time is not configured!
Sep 05 16:38:00 manjaro kernel: irq 9: nobody cared (try booting with the “irqpoll” option)
Sep 05 16:38:00 manjaro kernel: handlers:
Sep 05 16:38:00 manjaro kernel: [<000000004d95c478>] acpi_irq
Sep 05 16:38:00 manjaro kernel: Disabling IRQ #9
Sep 05 16:38:22 manjaro systemd[1]: Timed out waiting for device /dev/disk/by-uuid/59D3AF785645FC89.
Sep 05 16:38:22 manjaro systemd[1]: Timed out waiting for device /dev/disk/by-uuid/fc01ccdd-2e1b-44c2-9e66-c11e415122c1.

pavucontrol shows sound meter, but i don’t here anything. Yes i controlled all sound volume settings!

What to do next?

What about this “ausgesteckt”

pavucontrol, “Ausgabegeräte”

HDMI3/DP3 (ausgesteckt)

Shit, no screenshots possible

can you provide

inxi -Fza

Here it is:

Shit, cant post it!

Only part:
Audio: Device-1: Intel Smart Sound Audio vendor: Lenovo driver: sof-audio-pci alternate: snd_hda_intel,snd_sof_pci

This one saved my existence on Manjaro:

echo “options snd-hda-intel dmic_detect=0” | sudo tee /etc/modprobe.d/alsa-fix.conf

Ist jetzt nur Internes Audio, aber immerhin Audio!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.

From previous thread:

sudo pacman -S  sof-firmware alsa-ucm-conf

then follow these instructions and reboot:

https://wiki.archlinux.org/index.php/Lenovo_Yoga_c940#Overview

I really hate this new forum rules: close thread 3 days after last post and make it unpossible for new users to post the result of inxi -F or links. Do you really want new users?