Intermittent Internet Access

Lately I have been experiencing very slow internet speeds. I am on wired internet on a desktop. I have 1GB/s from my ISP, and performance is fine from my windows laptop on wifi. What I noticed is that if I watch the packet download speed, it is very volatile and will go from 0, to 100, to 0, to 500, etc with a period of a second or so and webpages will sometimes load quickly, sometimes very slowly (especially images), and sometimes not all. If I wait a few seconds and refresh, the performance will be different.

ping looks good

PING (2607:f8b0:4006:81d::2004)) 56 data bytes
64 bytes from (2607:f8b0:4006:81d::2004): icmp_seq=1 ttl=118 time=4.34 ms
64 bytes from (2607:f8b0:4006:81d::2004): icmp_seq=2 ttl=118 time=4.94 ms
64 bytes from (2607:f8b0:4006:81d::2004): icmp_seq=3 ttl=118 time=3.95 ms
64 bytes from (2607:f8b0:4006:81d::2004): icmp_seq=4 ttl=118 time=4.84 ms
64 bytes from (2607:f8b0:4006:81d::2004): icmp_seq=5 ttl=118 time=3.81 ms
64 bytes from (2607:f8b0:4006:81d::2004): icmp_seq=6 ttl=118 time=4.34 ms
64 bytes from (2607:f8b0:4006:81d::2004): icmp_seq=7 ttl=118 time=3.70 ms
64 bytes from (2607:f8b0:4006:81d::2004): icmp_seq=8 ttl=118 time=4.31 ms
64 bytes from (2607:f8b0:4006:81d::2004): icmp_seq=9 ttl=118 time=4.80 ms
64 bytes from (2607:f8b0:4006:81d::2004): icmp_seq=10 ttl=118 time=3.74 ms
64 bytes from (2607:f8b0:4006:81d::2004): icmp_seq=11 ttl=118 time=4.99 ms
64 bytes from (2607:f8b0:4006:81d::2004): icmp_seq=12 ttl=118 time=4.41 ms

system specs:

  Kernel: 4.19.262-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-4.19-x86_64
    root=UUID=a3338de4-c5a1-4324-93d7-7df0da2fd04a rw quiet
  Desktop: KDE Plasma v: 5.26.2 tk: Qt v: 5.15.6 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: PRIME X470-PRO v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 4024
    date: 09/07/2018
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 3
    serial: <filter> charge: 100% (should be ignored) rechargeable: yes
    status: discharging
  RAM: total: 47.14 GiB used: 25.01 GiB (53.0%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: model: AMD Ryzen 7 2700X bits: 64 type: MT MCP arch: Zen+ gen: 2
    level: v3 note: check built: 2018-21 process: GF 12nm family: 0x17 (23)
    model-id: 8 stepping: 2 microcode: 0x800820D
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 768 KiB desc: d-8x32 KiB; i-8x64 KiB L2: 4 MiB desc: 8x512 KiB L3: 16 MiB
    desc: 2x8 MiB
  Speed (MHz): avg: 2179 high: 3608 min/max: 2200/3800 boost: disabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1912 2: 1855
    3: 2080 4: 2136 5: 2069 6: 2172 7: 1893 8: 1912 9: 1885 10: 2125 11: 2036
    12: 1915 13: 2022 14: 2008 15: 3608 16: 3251 bogomips: 121366
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
    bmi2 bpext clflush clflushopt clzero cmov cmp_legacy constant_tsc cpb
    cpuid cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c
    flushbyasid fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb irperf
    lahf_lm lbrv lm mca mce misalignsse mmx mmxext monitor movbe msr mtrr
    mwaitx nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae pat
    pausefilter pclmulqdq pdpe1gb perfctr_core perfctr_llc perfctr_nb
    pfthreshold pge pni popcnt pse pse36 rdrand rdseed rdtscp rep_good sep sev
    sha_ni skinit smap smca sme smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3
    succor svm svm_lock syscall tce topoext tsc tsc_scale v_vmsave_vmload vgif
    vmcb_clean vme vmmcall wdt xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    disabled, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
    vendor: XFX Pine driver: amdgpu v: kernel arch: GCN-4 code: Arctic Islands
    process: GF 14nm built: 2016-20 pcie: gen: 3 speed: 8 GT/s lanes: 8
    link-max: lanes: 16 ports: active: DP-2 empty: DP-1, DP-3, DVI-D-1,
    HDMI-A-1 bus-ID: 08:00.0 chip-ID: 1002:67df class-ID: 0300 temp: 52.0 C
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.4
    compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
    alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x2160 s-dpi: 96 s-size: 1016x571mm (40.00x22.48")
    s-diag: 1165mm (45.88")
  Monitor-1: DP-2 mapped: DisplayPort-1 model: LG (GoldStar) HDR 4K
    serial: <filter> built: 2018 res: 3840x2160 hz: 60 dpi: 163 gamma: 1.2
    size: 600x340mm (23.62x13.39") diag: 690mm (27.2") ratio: 16:9 modes:
    max: 3840x2160 min: 640x480
  API: OpenGL v: 4.6 Mesa 22.2.1 renderer: AMD Radeon RX 580 Series
    (polaris10 LLVM 14.0.6 DRM 3.27 4.19.262-1-MANJARO) direct render: Yes
  Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    vendor: XFX Pine driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s
    lanes: 8 link-max: lanes: 16 bus-ID: 08:00.1 chip-ID: 1002:aaf0
    class-ID: 0403
  Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 0a:00.3
    chip-ID: 1022:1457 class-ID: 0403
  Sound API: ALSA v: k4.19.262-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.59 running: yes
  Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: 5.4.0-k
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 07:00.0
    chip-ID: 8086:1539 class-ID: 0200
  IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 3.18 TiB used: 366.45 GiB (11.2%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: SSD 970 EVO Plus 1TB size: 931.51 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 2B2QEXM7 scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000DM006-2DM164
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: CC26 scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 860 EVO M.2 500GB
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 1B6Q scheme: GPT
  Optical-1: /dev/sr0 vendor: ASUS model: DRW-24B1ST j rev: 1.11
    dev-links: cdrom
  Features: speed: 48 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r state: running
  ID-1: / raw-size: 465.46 GiB size: 457.09 GiB (98.20%)
    used: 366.45 GiB (80.2%) fs: ext4 dev: /dev/sdb2 maj-min: 8:18 label: N/A
    uuid: a3338de4-c5a1-4324-93d7-7df0da2fd04a
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 280 KiB (0.1%) fs: vfat dev: /dev/sdb1 maj-min: 8:17 label: N/A
    uuid: A303-F22E
  Alert: No swap data was found.
  ID-1: /dev/nvme0n1p1 maj-min: 259:1 size: 931.51 GiB fs: ext4 label: N/A
    uuid: 4bc59d4d-36c4-4fb6-a1bb-5a81e342c8b6
  ID-2: /dev/sda1 maj-min: 8:1 size: 1.82 TiB fs: ext4 label: N/A
    uuid: 5671091f-5642-457f-82ce-6d3e574943ac
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 14 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-4:2 info: Logitech Unifying Receiver type: Keyboard,Mouse,HID
    driver: logitech-djreceiver,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s
    power: 98mA chip-ID: 046d:c52b class-ID: 0300
  Hub-2: 2-0:1 info: Super-speed hub ports: 8 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 2 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 4-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-5: 5-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 5-1:2 info: Topre REALFORCE 108 US type: Keyboard,HID
    driver: hid-generic,usbhid interfaces: 3 rev: 1.0 speed: 12 Mb/s power: 100mA
    chip-ID: 0853:0147 class-ID: 0300
  Device-2: 5-4:3 info: Generic SatoshiLabs TREZOR type: HID
    driver: hid-generic,usbhid interfaces: 2 rev: 2.1 speed: 12 Mb/s power: 100mA
    chip-ID: 1209:53c1 class-ID: 0300 serial: <filter>
  Hub-6: 6-0:1 info: Super-speed hub ports: 4 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 44.9 C mobo: N/A gpu: amdgpu temp: 53.0 C
  Fan Speeds (RPM): cpu: 0 gpu: amdgpu fan: 750
  Processes: 314 Uptime: 52m wakeups: 6 Init: systemd v: 251 default: graphical
  tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman
  pkgs: 1745 libs: 437 tools: octopi,pamac,yay pm: flatpak pkgs: 0 Shell: Bash
  v: 5.1.16 running-in: konsole inxi: 3.3.23

I am not sure how to diagnose this, nor do i know how to get a log of my packet download rate. Could someone help? Thanks

Hi @vmr, and welcome!

In order for us, or anyone for that matter, to be able to provide assistance, more information is necessary. To that end, please see:

Hope you manage!

:bangbang: Tip: :bangbang:

To provide terminal output, copy the text you wish to share, and paste it here, surrounded by three (3) backticks, a.k.a grave accents. Like this:

pasted text

This will just cause it to be rendered like this:

Portaest sed
cursus nisl nisi
hendrerit ac quis
tortor sit leo commodo.

Instead of like this:

Portaest sed elementum cursus nisl nisi hendrerit ac quis sit adipiscing tortor sit leo commodo.

Alternatively, paste the text you wish to format as terminal output, select all pasted text, and click the </> button on the taskbar. This will indent the whole pasted section with one TAB, causing it to render the same way as described above.

Thereby improving legibility and making it much easier for those trying to be of assistance.

Please edit your post accordingly.

Did you try a newer (LTS) kernel, like 5.15 or 5.10? That one seems quite old.

1 Like

I have just run the pacman -Syyu upgrade periodically. How do I upgrade my Kernal? I will try that. Do you have a link to technical doc I can read? Clearly I am ignorant about some of the fundamentals of manjaro…

This should help:

But, as @freggel.doe also said, I recommend a LTS kernel, the latest of which is 5.15.

More info here:

thank you for this. now I have some reading to do this weekend. :slightly_smiling_face:

I upgraded to 5.15, and so far webpage downloads seem to be working normally.

  Host: vmr-pc Kernel: 5.15.76-1-MANJARO arch: x86_64 bits: 64 compiler: gcc
    v: 12.2.0 parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=a3338de4-c5a1-4324-93d7-7df0da2fd04a rw quiet
  Desktop: KDE Plasma v: 5.26.2 tk: Qt v: 5.15.6 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux

I still do occasionally see 0 B/s when I hover over the Networks widget on the system tray, but it seems to be working so I will just assume that is normal behavior for now. Do you know what command I should run to query/monitor this in the terminal?

Unfortunately not. I don’t use wireless, so never had the need for anything wireless-specific. For something more general, you can try the iftop package in the community repository:

$ pamac search iftop
iftop                                                                                                                                                                                                                 [Installed] 1.0pre4-5       community
Display bandwidth usage on an interface

Install it with:

pamac install iftop

But I’m glad it works now.

I am on a wired connection. iftop is exactly what I am looking for. thanks again.

1 Like

So after about an hour now, the problem comes back. when I watch iftop, I see the speed drop to zero, or very close to it for a few seconds, and then it will spike back up and it keeps going up and down like this. I have to continually refresh webpages…sometimes they will load normally, other times they will stall and especially fail to download images. If I keep refreshing eventually it work, but this is not sustainable.

any other diagnostics I can try?

Could be a hardware-related issue, whether isolated or due to a combination of the network card, switch, and/or router.

This user suffered the same problem on Linux and Windows. Replacing their switch resolved the issue. Apparently, between the NIC ← → switch, there was quirky link-speed negotiation.

:white_check_mark: Try a different switch or router, if possible.

In addition to the above, very much within the realm of possibility is a loose cable connection. Those RJ45 heads have a knack of coming loose if the plastic clip is worn out or improperly bent. I personally solved this issue myself by replacing the ethernet cable. The problem wasn’t a matter of “all or nothing”, but rather intermittent internet access and random speed hikes and slowdowns. (Similar to how you describe it.)

:white_check_mark: Try with different ethernet cables.

Was on my way to suggest this, so thank you!


Or, y’know. First try the other cables and if that doesn’t work, move on to the router/switch. My reasoning is simple: money.

1 Like

I just swapped the cable…not a cable problem. the ethernet net jack is on the motherboard and is a bit loose…if only money grew on trees but an ethernet card is not too much. I will pick one up this weekend and report back. thank you both

…that might explain it. You can always try with a stand-alone NIC.

1 Like

I recently had to troubleshoot this for someone else, last week, which is a strange coincidence! Their desktop PC’s ethernet port on their integrated NIC was loose, and Windows 10 would behave as you described.

I lent them a USB WiFi dongle in the meantime while they ordered a new PCIe network card, so they could have internet access in the meantime. Once their PCIe card arrived, we installed it, and everything’s back to normal. :slight_smile:

1 Like

In our case, we just went with the least expensive PCIe network card, knowing 100% that it will work with Windows 10.

In your case, you might want to make sure it’s compatible with Linux before ordering it. :face_with_monocle:

1 Like

This might help with that:

1 Like

This one works with the Realtek r8169 / r8168 driver:

Thank you both…a lot of good information in here. Card will come Monday and I will report back with any progress

1 Like

So I changed the cable and installed a new lan card. The internet is working normally…however I am still getting similar behavior, when I watch the packets they spike down to zero every few seconds or so only to jump back up. The internet is working fine, but I am still not sure if this the expected behavior? At least its working now

With what software?

Your subjective experience and real-world usage is more important than tests.

For what it’s worth, it might be the test giving you too much information, when in fact your internet connection is fine. (Or a further upstream issue with your ISP.)

Do downloads work?

Does show you’re getting close to your ISP’s advertised speeds?

Does torrenting work?

Does streaming video work?