Installed Nvidia proprietary drivers and now can't boot into GUI

I installed this on a Early 2013 MBP 15" 2.7Ghz, 1TB, 16GB Ram. It was running fine with the open source drivers and I knew from previous experience that this most likely won’t boot up but I thought I’d try and sure enough, it didn’t boot up. What changes do I make and how do I make them in GRUB to boot up with the open source drivers? The other option is that just reinstall the OS.

in the black screen enter into tty: ctrl+alt+f2 - or f1-f6 keys instead, enter your username/password and post a picture of this output:
mhwd -l && mhwd -li

Well, two problems here, first I hit escape to get to the GRUB menu and then I hit C to get to the GNU GRUB command line. I type in what you are asking but it tells me invalid syntax. I try these keys during boot up before hitting ESC and nothing occurs.
The second problem is more glaring. Even if I could do this, how could I get the hundreds of lines to you except by photographing it on my phone and posting the pic?

no… just start up your pc, then on the stuck screen press: ctrl+alt+f2 - or f1-f6 keys instead, enter your username/password
you do nothing in grub, just boot normally and in the stuck/black screen you do it

Nothing happens. I tried the keys and when they didn’t work I added in fn for the function keys to see if that would help, it didn’t. I also tried Cmd instead of Cntrl.

ok so you mentioned you can enter into grub, so in there press ‘E’ and in the kernel line add this parameter:
here is a link on how to do it

I looked at the link and tried it and hit F10. No joy.

that should worked, so boot into manjaro usb, open terminal and run this command:
sudo manjaro-chroot -a
then post output from:
mhwd -l && mhwd -li

I wouldn’t know how to post the output from mhwd -l && mhwd -li.

you post it from chroot, since disabling nvidia didnt work, and neither tty did …

Sorry, that doesn’t help me. I have heard of chroot and that is my extent of knowledge on that.

that is ok…
just boot into manjaro usb
open terminal and run this:
sudo manjaro-chroot -a - this is the command for chroot
then you run this command:
mhwd -l && mhwd -li
and post output from it

On mac that should be fn+ctrl+alt+F1 or f2/f3

  • boot a manjaro usb drive
  • open a terminal on that usb system
  • follow brahma’s instructions to change root directory from the usb system to your manjaro installation in order to be able to
  • fix your graphics

That’s why chroot is better than tty-ing from your non-booting system because there you’d need a second device to post pics if you get stuck whereas the booted manjaro usb system lets you use a functioning gui to copy and paste between your terminal and the forum here.

You’re 5 min away from being back to normal…

1 Like