I installed kernel version 5.17 but Huawei Matebook d15 sound card is not recognized

Yes, I did all of that (i.e. installed sof-firmware, pipewire and 5.19 kernel), but the only audio device shown in the sound settings is the dummy one. My understanding is that support for the particular sound card is simply not yet in the kernel. I am not sure I have enough knowledge to add it there, but I would very much like to help the devs who do. How can I do this the best way?

they are probably already aware of that… and are you dual booting? if yes, is fastboot disabled?

There is a dual boot to Windows, yes (even though I do not use it much). I did look around the BIOS, but it looks rather archaic and minimalistic, so I spotted no option of fastboot.

Soundcard not detected on Huawei Matebook d14 (intel) / Newbie Corner / Arch Linux Forums

you need to disable fastboot in windows, search for it on internet on how to do it, its nothing difficult

Right, found the setting and turned it off, but the result is still the same – only dummy output.

I can see that sof-firmware v2.2 has just been released, and the change log promises sevefral renoir improvements, so let’s keep the fingers crossed!

So, sof-firmware v2.2 has now entered the stable branch. I tried to run it together with both 5.18 and 5.19 kernels, but all I still have is the dummy output.

I would be grateful for any further ideas.

Still no sound on kernel 5.18
Does anybody know when it would fix?

I would extend Larry’s question – how would it be possible to figure out if a fix is in the works, and if yes, then how far is it? I am unfortunately not very familiar with the kernel and driver development. I would be willing to help the devs by offering my machine for testing, etc., but what is the correct way of approaching them?

may you post the output of

amixer -c0

inxi data in post#4 shows that Sound Open Firmware Cannon lake driver sof-audio-pci-intel-cnl
is already loaded, so reinstalling sof-firmware would not help

If PulseAudio/Pipewire only has Dummy Output, audio devices are probably not being detected in ALSA. Replacing PulseAudio with PipeWire would not help

Audio issue with this model device was first reported in September
No sound only "Dummy Output" on Huawei Matebook D 15 (Intel)
Support for audio codec ESSX8336 was enabled in Manjaro kernels v5.16 and v5.17 in February
Cautiously enabling ESSX8336 module in the kernel
and alsa-project created the HiFi profile (to tie all the audio channels together) in March
ucm2: sof-essx8336: initial support by plbossart · Pull Request #139 · alsa-project/alsa-ucm-conf · GitHub
sofproject currently has 13 open issue reports for this audio codec
Issues: codec ESSX8336 · thesofproject/linux · GitHub

so I think the comment from February still stands

It might help to get more information about ALSA to compare with data already posted to sofproject

sudo alsa-info.sh --upload

Here it comes:

$ amixer -c0
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]

I also include the Audio part of the inxi command:

  Device-1: AMD Renoir Radeon High Definition Audio vendor: QUANTA
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 03:00.1 chip-ID: 1002:1637
    class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: QUANTA
    driver: snd_rn_pci_acp3x v: kernel
    alternate: snd_pci_acp3x,snd_pci_acp5x,snd_pci_acp6x,snd_acp_pci,snd_sof_amd_renoir
    pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s
    bus-ID: 03:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Sound Server-1: ALSA v: k5.18.10-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: no
  Sound Server-4: PipeWire v: 0.3.54 running: yes

I did post the output of alsa-info.sh as well. The script also asked: “Please inform the person helping you.” So should I notify anyone in particular?

In order not to let the topic cold let me reiterate my question – is there anything I can do to get the sound working properly?

Best regards,

there was another system update, did you run it and it still doesnt work? tested also with the 5.19 kernel?

Yes, I tried both 5.18.16 and 5.19.0 kernels, and all I get is still the dummy output. Is there anything else to try?

are you dual booting with windows? is fastboot disabled in windows, is fastboot disabled in bios - some bioses have the fastboot option, so check it

I just checked sofproject and most of the issue reports have been closed with link to a summary page
ES8336 support · thesofproject/linux Wiki · GitHub

Looks like it is still not done yet

A determined user could try patching kernel v5.19 and adding the topology files. But there are reports of issues with v5.19.0, so I would suggest waiting until the patches are included in a later kernel version

is fastboot disabled in windows

fastboot is in BIOS. Did you mean Fast Startup?
How to disable Windows 10 fast startup (and why you'd want to) | Windows Central
Fast Startup - Turn On or Off in Windows 8 | Windows 8 Help Forums

it was called fast boot in windows 8, but yes thats what i mean