I have to reinstall my GPU drivers after every reboot

Hello, i’ve had this issue for now a little while… So i updated my kernel from 5.6 to 5.9 and ever since i have to reinstall my GPU drivers after each boot because the server x won’t start…

I have a GTX 750 ti and i’m using video-nvidia-450xx drivers.

After a boot, “inxi -G” tells that there isn’t any driver installed (“Driver : N/A”) but “mhwd -li” shows that the drivers are installed…

If you want additionnal informations i’m here…

Hello,

The linux59 doesn’t have any modules yet for Nvidia GPUs, so please stick to stable kernels.

linux54 is LTS and works fine with video-nvidia-450xx drivers
linux57 will be soon EOL but still works fine with video-nvidia-450xx drivers
Linux58 still seems to have some regressions and sometimes gives unpredictable stability, but is more usable than a rc kernel …

2 Likes

My bad it’s 5.8 not 5.9

inxi -Fazy
1 Like

Ok then. How do you install drivers?
Always use mhwd

If you prefer terminal:
sudo mhwd -i pci video-nvidia-450xx

If you install with UI and Auto install option, check if you get some error, also make sure you do not have any other driver installed.
By default you should also have
/etc/modprobe.d/mhwd-gpu.conf
with this lines in it:

blacklist nouveau
blacklist ttm
blacklist drm_kms_helper
blacklist drm

And the default /etc/X11/mhwd.d/nvidia.conf

Can you confirm?

1 Like

In /etc/modprobe.d/mhwd-gpu.conf i only have a “Generated bu mhwd - Manjaro Hardware Detection”.
Also, /etc/X11/mhwd.d/nvidia.conf doesn’t seem to exist…

So what about the previous queries that will actually give us information?

Oh, i actually only can boot in tty so i can’t really give you these informations :grimacing:

How about pasting?

inxi -Fazy | curl -F 'file=@-' 0x0.st

(that should give us a link)

I wasn’t aware i could do that!

But i actually can’t send the link ( pasting the whole thing tells me that there’s a link top)

It should be a single link. … or you cannot post that ?
It should be a very short link like " https://0x0.st/iEYo.txt "
If you cannot post real links … can you just give me the last section?
(in case above that would be “iEYo.txt”)

The last section is iEYs.txt

Aha!.
I figured as much.
You have dual-graphics.
AMD(vega)+Nvidia(gtx750)
The actual driver profile you want is

video-hybrid-amd-nvidia-440xx-prime

or 450.
To install you can do:

sudo mhwd -i pci video-hybrid-amd-nvidia-440xx-prime

Do my GPU would be used or my igpu then?

Both.
The way PRIME works is you would boot into the weaker card by default … when you want to use more power from the nvidia you use prime-run.
Ex:

glxinfo | grep renderer
prime-run glxinfo | grep renderer

(and then there is also “reverse prime” meaning it does it the other way around … but needs extra set up)

If you only ever want to use the nvidia … then you would want to entirely disable the amd gfx … if you are lucky there will be a switch in the BIOS.

1 Like

So using video-nvidia is always going to lead me to this issue ? Because i don’t really want my gpus to behave like that

I refer you again to the post above.
video-nvidia will not work on its own if you have also an amd card.
How do you want your gpus to behave? This is pretty normal …

I want my NVIDIA GPU to be used by default and not having to do that every time i boot

Then you need to disable the amd or use reverse prime.
https://wiki.archlinux.org/index.php/PRIME#Reverse_PRIME

Before you do the test as mentioned above, could you return from terminal:
mhwd -li

Since is a desktop pc the combination with prime-run is not quite ideal IMHO. Also in case you will want to attach more displays to each GPU, or possible to want to use the AMD GPU passthrough to a virtual machine … So, if you manually installed the nvidia drivers and the files i mentioned did not got created, then there might be something with mhwd as mentioned here:

That means, you will have to create also manually the file:
/etc/modules-load.d/mhwd-gpu.conf
With this lines:

nvidia
nvidia-drm

and

Do not create any custom /etc/X11/mhwd.d/nvidia.conf and also remove the /etc/X11/xorg.conf.d/90-mhwd.conf

If this gives you trouble, add nomodeset as kernel boot parameter and see if that helps and from there we might be able to help more.