[How To] Install run Manjaro ARM on Amlogic TV Boxes with S922X - S905X3 SOC

There is no file specific to my box model. It has an s905X3 CPU, but all dtb files for it don’t boot. The S905X2 CPU has very similar specifcations what is probably the reason, why the g12a-x96-max.dtb file is working.

I wish manjaro team would provide a file for my device :frowning:

We do not really work on tv boxes. It is the community users who work on it when they have a tv box which they think can work with existing dtb.

I have no idea which box you use and what chips are used inside, nor anyone have a sample device to play around with.

You can ask manjaro community users who might have the exact same device to debug things on manjaro and get manjaro working on it.

I hope someone from the community would be able to help you with manjaro for your device. This is cause the device is already discontinued so only those who already have the device can test it and report back the issues.

Good luck.

1 Like

Ah okay, i thought since the dtb files are included in the github manjaro builds, manjaro team also creates them for specific devices.

Is there a tutorial how to create dtb files or export and edit them from device?

Okay, seems like with latest meson-sm1-h96-max.dtb the GT1-Mini2 works a lot faster after updating everything. But i don’t get sound working.

If i use “sudo systemctl enable sound --now”

i get the message “Failed to enable unit: Refusing to operate on alias name or linked unit file: sound.service”.

Another problem is, that the box is not shutting down or rebooting the device from manjaro…

Is there amy way to fix some of these issues?

Do you have new AM6B plus dtb?,I install manjaro on my AM6B plus,but it’s soundcard is wrong

You can switch to different audio routing inside /usr/bin/g12_sound.sh file and it should work after a reboot.

Enable these while disable the old conf. if that does not work then you need to see what dtb you are using

it have soundcard,but it is no sound from av-out


sudo pacman -Sy linux-odroid linux-odroid-headers

Reboot then you will have audio.


I know it has been a long time but I tried installing Manjaro on my T95 max plus like you did. The box is already “SD-card-boot-enabled”, as Emuelec starts flawlessly from a microSD.

So I downloaded the same Manjaro-version like you did, burned it with Etcher, changed uenv.txt to use meson-sm1-sei610.dtb…

But every time I try to boot with the SD card entered, the box boots into Android.

So… what am I missing?

Greetings from Germany


Which OS do you have on emmc ? Manjaro will need Android to be present on emmc.

Maybe your device is different, what is the device specification ? did you try any other dtb ? check x95max dtb

i have the original ugoss AM6B+ dts file and need your help to convert it to linux dts fileAM6-B-origin

I want to try arm tv box wechip v9 (similar x96 max+), which ARM version is suitable

Try AM6 image but you will have to change the dtb used and I don’t know which dtb you should use for this device.

Try this one

X96Max+ meson-sm1-sei610.dtb S905X3

See if that works.

Sorry for the late response, been busy. Successful boot with meson-sm1-sei610.dtb

HDMI Sound
GPU Acceleration (glamour by default)

Not Work:
Internal Wi-Fi

USB Wifi detected but Enable Wifi missing on network settings (Xfce) only Enable Networking

I also tried A95X F2 using meson-g12a-u200.dtb but it shows only splash boot

maybe your device have different chips for Ethernet and wifi also they used different gpio for them as it does not work on the dtb you used.

it is difficult to find out the difference without getting the device schematic and making those changes in dtb.

Usually I plug in a detected usb wifi like Ralink MT7601 or
Atheros AR9271, but Enable Wifi is missing in xfce Network Settings

testing image from GT King Pro

HDMI Sound
GPU Acceleration (glamour by default)
USB Wifi

Not Work:
Internal Wifi

But RAM only detected 950MB on htop/task manager, actually 4GB

A good place to hunt for dtb is from GitHub - ophub/amlogic-s9xxx-armbian: Support for Armbian in Amlogic, Rockchip and Allwinner boxes. Support a311d, s922x, s905x3, s905x2, s912, s905d, s905x, s905w, s905, s905l, rk3588, rk3568, rk3399, rk3328, h6, etc.. This site is a fork of Armbian and it NOT the official Armbian site.

I hope I have NOT violated any Manjaro-Arm Forum rules.

1 Like

A post was split to a new topic: How do I install on my Beelink GT-King SA9XHQCF50153?

A post was split to a new topic: Issues booting from SD Card on Ugoos AM6 Plus