[How To] Install run Manjaro ARM on Amlogic TV Boxes with S922X - S905X3 SOC

Great, I recently acquired an am6b+ box and I see in this Manjaro version that the frequencies do not correspond to what they really are. I wanted to know if you could give me the procedure to change them (if it is not beyond the reach of an enthusiastic beginner :))?
cordially

You could look at the files in this post:

I don’t know if you have build a kernel, but if you search I guess you’ll find a good howto on how to build a custom kernel that describe the process better than I can. In short you have to get the kernel from kernel.org and put the files for the board in arch/arm64/boot/dts/amlogic and in the linux- zcat /proc/config.gz .config then make menuconfig and make dtbs wich should generate the dtb. You could try the file meson-g12b-ugoos-am6b-plus-oc.dtb which is compiled and ready to use
Remember that adjusting frequencies and voltage can be dangerous. I think the values I have used is safe and worked ok for me but you use them at your own risk as I don’t have any official data on the specs

thank for answer, seems a bit more complicated than I thought lol
i can’t decompile a dtb, modify file and recompile it? .
On the other hand it would seem that on the Verus gadget links of your previous post it is not at all the right frequencies for 922xj.
I believe the frequencies are a53 1900mhz / a73 2200mhz

I don’t have the datasheet but from Amlogic S922X-H vs Amlogic S922XJ - GadgetVersus and from booting the box up with coreelec I got those frequencies. And it make sense that the A53 got the fast cores and the more featured A73 got lower frequensies.

I asked their customer service they told me 1.8/2.2ghz my frequencies are 2ghz/1.9 I lose 300Mhz on the core a73 it’s not nothing. Same here : 🏆Best Box For The Year🏆- Ugoos AM6B-Plus Amlogic S922X-J DDR4 TV Box - YouTube

Good morning, I’m wanting to download the installation file on github but I’m not getting it, it only gives the 24,739 megabit zip file and it says corrupted file and I say it’s the most current: https://github.com/ophub/amlogic-s9xxx- arbian
If you can give a light or a download link because it’s hard to download.
My tvbox is TX3 mini.
Big hug.

What link is this?

What exactly at you talking about?

Hi, it was a current version of Manjaro for tvbox. Now I saw that the link disappeared. Can you recommend a current one for the tvbox TX3 mini? Thanks and I want to upgrade to install Klipper on it for 3d printer.

I did these days, yesterday all day trying to run Klipper on the Tvbox Tx3mini both on Armbian Debian and on Manjaro without success, but today I just confirmed the error when initializing with the arduino mega board that with the shield board makes the 3d printer work that I will ride. The error stops when I don’t turn on the arduino and after starting Manjaro I turn on the arduino mega and then it works without problems. Is there a way to make the arduino turn on at system startup?
Screen error:
Unexpected XHCI event TRB, skipping…
“Synchronous Abort” handler, esr 0x96000210
Resetting CPU…

Hi,
Does Someone have a dtb file that enabled the ethernet network for mecool the km3 tv box? The meson-g12a-sei510.dtb file does not enable the ethernet network card in my mecool km3 tv box.

the speed of the ethernet network card of my mecool km3 is 100 MB.

Thanks.

Hi,
Wanted some help,
Above some one replied that the latest images wont run on A905X F3 Air S905 X3 chip. Not sure if understand that correctly.

Below are the steps followed

  1. I flashed and updated the dtb in uEnv.ini with meson-sm1-sei610.dtb and also tried meson-sm1-a95xf3-air.dtb
  2. updated args to use label instead PARTUUID bootargs=root=LABEL=ROOT_MNJRO

The A95 boot logo keeps repeating after few seconds of blank screen and no logs printed on tv screens. Looks like it is rebooting itself.
The USB flash drive keeps blinking all the time indicating it is being red.

So wanted to know which image boots from USB stick or SD Card and the dtb file for that.

So far I tried the images on F3 Air.

  • Manjaro-ARM-kde-plasma-gtking-pro-20220718.img.xz
  • Manjaro-ARM-mate-vim2-22.06.img.xz
  • and the generic ARM build from download page.

On same Box I am able to run Armbian image using Armbian_20.08_Arm-64_bullseye_current_5.7.16_desktop.img.xz

These 2 images will never work.

This should work but without a bootlog we will never come to know what is wrong with the image for such device.

If any of the manjaro user have this device then they might be able to help you with this.

After many hours of trail and error finally got the Manjaro-ARM-kde-plasma-gtking-pro-20220718.img.xz to work on Amlogic A905X F3 Air ( S905 X3 Chip)

The issue was we also have to add the u-boot.ext file in boot partition after updating uEnv.ini and updating the conf file in the folder extlinux

Both I copied from the from old image Manjaro-ARM-kde-plasma-vim3-21.03.img.xz which worked on F3 Air, This I found out yesterday.

Now Using meson-sm1-a95xf3-air.dtb but no Onboard WiFi detected. Used USB Wifi able to play some HD video on Youtube, 4K video unable to play properly, it gets stuck…

1 Like

Hi and thanks for this very interesting thread.

I´m struggling since 2 days to get Manjaro on my Beelink GT1 Mini2 (S905X3 SOC Chip) working but with no success.

The only Manjaro version i can at least boot is Manjaro-ARM-kde-plasma-vim3-21.03.img with meson-sm1-sei610.dtb as dtb file.

But after i boot and set up the stuff like location i.e. it reboots and the device stucks.
After reconnecting the plugin, it tries to boot the environment but it stucks at the very beginning.

All other/newer build doesn´t boot at all for me.

Can anyone support me a bit, please?

Check if the DTB file is still present, some time the file disappears,
If you can upload screen shot where it is stuck , some body can help,

Try using other dtb specific to the box model.
Try using Manjaro-ARM-kde-plasma-vim3-21.03.img.xz image, for my box F3 AIR it works as stated above.

Hi, thanks for reply.
I finally found out, that Manjaro-ARM-kde-plasma-vim3-21.04.img is the only version which allows me to setup and boot fully into system on my beelink GT1 Mini 2, if i use meson-g12a-x96-max.dtb.

After Updating the sytem i had to recopy some stuff from v. 21.04 to the boot partition and also the old meson-g12a-x96-max.dtb file from 21.04, because otherwise the system stoped booting.

All newer versions of manjaro doesn`t allow me to boot since they changed some stuff on the boot partition like removing u-boot.ext file i.e.

Now i can at least boot, but the system is very slow and laggy.
Maybe i have to change the environment, or the kernel does not support my device correctly or i need a better dtb file. IDK.

Any ideas how to speed up the system?

One way is to hold “boot-vim3” as when you perform system update it will convert your image to “bootscript” boot method. That is what I did before on GT King Pro but since GT King Pro can now work with bootscript method, now on bootscript image.

Okay, i think i will give up for now with it. I can boot manjaro, but there is no sound and the system is extremely slow. I don’t think you can use it as a daily driver as long you don’t have the correct dtb file and an optimized kernel for it…

Have you tried g12_sound.sh to enable sound and do you have the latest mesa-22.1.4?

Manjaro-KDE Plasma is running smoothly on GT King Pro.

I tried to enable g12_sound.sh, but got an error message. I was on 21.04 and updated fully, but the system was very slow from the beginning. Maybe because i boot from microSD, but the command to move everything to emmc did not work.

I think i need an optimized dtb file. It’s sad, that i can not use the one from CoreELEC for GT1 Mini 2.