Headphone Mic doesn't get detected

Headphones mic doesn’t get detected.

I have dual booted with windows. Same headphones mic works in that.

Bluetooth headset mic and speaker works just fine. Internal mic works fine.

I’ve tried adding these to make it work.

Tried switching kernels to 5.4 lts, 5.8, 5.9, 5.10, 5.11. Restarted before verifying each ofcoarse.


load-module module-alsa-source device=hw:0,0 #<<<- THIS LINE I ADDED
# the line above should be somewhere before the line below

### Automatically load driver modules depending on the hardware available
.ifexists module-udev-detect.so


options snd-intel-dspcfg dsp_driver=1

sudo dmesg | egrep -i ‘(snd|sound|sof|alsa|hda)’

[    0.584048] pps_core: Software ver. 5.3.6 - Copyright 2005-2007 Rodolfo Giometti <giometti@linux.it>
[    0.835406] PCI-DMA: Using software bounce buffering for IO (SWIOTLB)
[    0.835409] software IO TLB: mapped [mem 0x00000000711fe000-0x00000000751fe000] (64MB)
[    3.458213] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[    3.552108] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC233: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
[    3.552109] snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    3.552110] snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
[    3.552111] snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0
[    3.552111] snd_hda_codec_realtek hdaudioC0D0:    inputs:
[    3.552112] snd_hda_codec_realtek hdaudioC0D0:      Mic=0x12
[    3.631773] input: HDA Intel PCH Front Headphone as /devices/pci0000:00/0000:00:1f.3/sound/card0/input16
[    3.631816] input: HDA Intel PCH HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input17
[    3.631854] input: HDA Intel PCH HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input18
[    3.631892] input: HDA Intel PCH HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input19
[    3.631930] input: HDA Intel PCH HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input20
[    3.631972] input: HDA Intel PCH HDMI/DP,pcm=10 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input21

inxi -Faz

System:    Kernel: 5.10.15-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 root=UUID=80600993-862a-4954-bd73-8ca82f953daf ro quiet apparmor=1 
           security=apparmor resume=UUID=8b11817b-7fff-4e2f-8a74-cb9d4bcc3a8f udev.log_priority=3 
           Desktop: KDE Plasma 5.21.80 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: ASUSTeK product: TUF Gaming FX505GT_FX505GT v: 1.0 serial: <filter> 
           Mobo: ASUSTeK model: FX505GT v: 1.0 serial: <filter> UEFI: American Megatrends v: FX505GT.310 date: 11/26/2020 
Battery:   ID-1: BAT0 charge: 28.0 Wh condition: 45.6/48.1 Wh (95%) volts: 11.8/11.7 model: Simplo SDI ICR18650 type: Li-ion 
           serial: <filter> status: Unknown cycles: 41 
CPU:       Info: Quad Core model: Intel Core i5-9300H bits: 64 type: MT MCP arch: Kaby Lake note: check family: 6 
           model-id: 9E (158) stepping: A (10) microcode: DE L2 cache: 8 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 38408 
           Speed: 4085 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 4085 2: 3817 3: 4090 4: 4074 5: 4074 6: 4092 7: 4096 
           8: 4079 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:3e9b 
           class ID: 0300 
           Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] vendor: ASUSTeK driver: nvidia v: 460.39 
           alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:1f91 class ID: 0300 
           Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo bus ID: 1-11:3 chip ID: 13d3:56a2 
           class ID: 0e02 serial: <filter> 
           Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: loaded: modesetting,nvidia display ID: :0 
           screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 75 s-size: 652x366mm (25.7x14.4") s-diag: 748mm (29.4") 
           Monitor-1: eDP-1-1 res: 1920x1080 hz: 144 dpi: 142 size: 344x193mm (13.5x7.6") diag: 394mm (15.5") 
           OpenGL: renderer: GeForce GTX 1650/PCIe/SSE2 v: 4.6.0 NVIDIA 460.39 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           alternate: snd_soc_skl,snd_sof_pci bus ID: 00:1f.3 chip ID: 8086:a348 class ID: 0403 
           Sound Server: ALSA v: k5.10.15-1-MANJARO 
Network:   Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel port: 5000 bus ID: 00:14.3 
           chip ID: 8086:a370 class ID: 0280 
           IF: wlo1 state: up mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8169 v: kernel port: 3000 
           bus ID: 03:00.0 chip ID: 10ec:8168 class ID: 0200 
           IF: enp3s0 state: down mac: <filter> 
Bluetooth: Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB driver: btusb v: 0.8 bus ID: 1-14:4 
           chip ID: 8087:0aaa class ID: e001 
           Message: Required tool hciconfig not installed. Check --recommends 
Drives:    Local Storage: total: 942.7 GiB used: 59 GiB (6.3%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Micron model: 2200V MTFDHBA512TCK size: 476.94 GiB block size: 
           physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 rotation: SSD serial: <filter> rev: P1MA0V4 temp: 29.9 C 
           scheme: GPT 
           ID-2: /dev/sda maj-min: 8:0 vendor: Crucial model: CT500MX500SSD1 size: 465.76 GiB block size: physical: 4096 B 
           logical: 512 B speed: 6.0 Gb/s rotation: SSD serial: <filter> rev: 023 scheme: GPT 
Partition: ID-1: / raw size: 84 GiB size: 82.18 GiB (97.84%) used: 24.94 GiB (30.3%) fs: ext4 dev: /dev/sda3 maj-min: 8:3 
           ID-2: /boot/efi raw size: 260 MiB size: 256 MiB (98.46%) used: 25.6 MiB (10.0%) fs: vfat dev: /dev/nvme0n1p1 
           maj-min: 259:1 
           ID-3: /home raw size: 100 GiB size: 97.93 GiB (97.93%) used: 34.04 GiB (34.8%) fs: ext4 dev: /dev/sda4 maj-min: 8:4 
Swap:      Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
           ID-1: swap-1 type: partition size: 16 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda2 maj-min: 8:2 
Sensors:   System Temperatures: cpu: 54.0 C mobo: 27.8 C gpu: nvidia temp: 48 C 
           Fan Speeds (RPM): cpu: 2700 
Info:      Processes: 281 Uptime: 1h 34m wakeups: 1 Memory: 7.63 GiB used: 2.67 GiB (35.0%) Init: systemd v: 247 Compilers: 
           gcc: 10.2.0 Packages: 1389 pacman: 1367 lib: 393 flatpak: 16 snap: 6 Shell: Zsh v: 5.8 running in: konsole 
           inxi: 3.3.01 

I’m planning to install Arch vanilla and see if all media hardware works out of the box, with Manjaro I’ve tried searching a lot on the internet. I’m somewhat of a noob, I’ve used ubuntu before.
Thank you for your time :slightly_smiling_face: :+1:

Audio device Intel Cannon Lake PCH is using legacy driver snd_hda_intel instead of
That suggests that the modprobe option in /etc/modprobe.d/alsa-base.conf is forcing use of the legacy driver
But if snd_sof_pci driver is not used to support the internal dmic array, the internal mic normally does not work

Data from dmesg is only showing one microphone detected
snd_hda_codec_realtek hdaudioC0D0: Mic=0x12

I suggest you revert changes made to /etc/pulse/default.pa
and delete /etc/modprobe.d/alsa-base.conf

I also suggest you delete user configuration settings for PulseAudio

rm ~/.config/pulse/cookie ~/.config/pulse/*.tdb

then reboot system

and get information from ALSA

sudo alsa-info.sh --upload

hey @nikgnomic
thanks a lot, I was helpless.
here’s the output. The mic still doesn’t function.

sudo alsa-info.sh --upload


I see that snd_sof_pci is still not being used.

!!Loaded ALSA modules


Does this mean that it should be made to use snd_sof_pci somehow?

On a side note.
I installed vanilla archlinux with kde on a different partition hoping if the headset mic would work out of the box(by magic :sweat_smile:), it didn’t. It has the same problem, only one device (internal mic) gets detected. I’m going to delete it, it’s much work to set it up again and it’s not really any different from what I have now with Manjaro.


@Olli hey man thanks
hfp <-> a2dp is working fine for me on my other bluetooth headset. But it’s wired headphones I have issue with.
I went through the wiki anyway, there didn’t seem to be anything I could use.
Maybe you meant this line pacmd set-card-profile card_number a2dp_sink.

Suppose I would change the profile of my sound card from “Hifi(Play Hifi quality music)” to “hsp/hfp”.
I’m not sure what needs to be used as the profile name. Anyway I think this is all for bluetooth devices.

I’ve also read this PulseAudio/Examples - ArchWiki which has a lot about mapping and different settings, but didn’t find anything I can use for the fix.

Trial and error. Check the search function of the wiki for “bluetooth”. there are a lot more entries.

BTW your inxi output recommends that you have to install hciconfig, not sure what it is so search for it also at the wiki

Bluetooth: Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB driver: btusb v: 0.8 bus ID: 1-14:4
chip ID: 8087:0aaa class ID: e001
Message: Required tool hciconfig not installed.

The section !!Loaded sound module options should have more data for the loaded module

I suggest you reinstate the modprobe option and revert to using snd_hda_intel driver


options snd-intel-dspcfg dsp_driver=1

I was hoping that getting the internal mic working might help with the headset mic, but it didn’t help
If you are only using a headset microphone it is better to stay with snd_hda_intel driver and not have the internal mic get in the way

I have now found what is needed to fix

Your laptop data matches the data for a similar Asus laptop in this bug report

207131 – No headset capture on Realtek ALC233 | bugzilla.kernel.org
Realtek ALC233 on Asus TUF FX505DT laptop.
Headset mic not being detected at configuration. Headphones work correctly

Reconfigure node 0x19 as per Asus MJ401T enables headphone mic

The headset microphone connection is not configured correctly and is shown in ALSA data as a Speaker Output

Node 0x19

Node 0x19 [Pin Complex] wcaps 0x40048b: Stereo Amp-In
Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
Amp-In vals: [0x00 0x00]
Pincap 0x00003724: IN Detect
Vref caps: HIZ 50 GRD 80 100
Pin Default 0x411111f0: [N/A] Speaker at Ext Rear
Conn = 1/8, Color = Black
DefAssociation = 0xf, Sequence = 0x0
Pin-ctls: 0x20: IN VREF_HIZ
Unsolicited: tag=00, enabled=0
Power states: D0 D1 D2 D3 EPSS
Power: setting=D0, actual=D0

and dmesg data does not show a speaker output for 0x19

I suggest you install package alsa-tools then use a tool to reconfigure the jack socket

sudo hdajackretask
  • Find the non-working connection - Pin ID: 0x19
  • Click to enable Override and click on the drop-down-menu and select Microphone
  • Click Install boot override
  • reboot system and check if microphone is present and working

hey nikgnomic,

that’s exactly what I did, it’s working now.
I had read a lot of forums and installed archlinux too, just for posting this on their forum.


you seem to know a lot about this :sunglasses:, you arrived to precisely what I had to do.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.