Bluetooth mic doesn't work, headphones do, in Google Meet

On a Thinkpad T15g, I can get an Aftershockz OpenComm headphones to work over Bluetooth, but not the microphone. With Google Meet, the options don’t show the Aftershockz mic.

This Aftershockz mic show up on Google Meet with Chrome on Windows 10.

It doesn’t show up with:

  • Linux 5.12.9-1
  • Linux 5.10.42-1
  • Linux 5.4.124-1

Here’s the same Google Meet panel with Chrome on Manjaro.

Here’s the inxi.

$ inxi -F
System:    Host: di-20urs01k00 Kernel: 5.12.9-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.21.5 Distro: Manjaro Linux 
Machine:   Type: Laptop System: LENOVO product: 20URS01K00 v: ThinkPad T15g Gen 1 serial: <superuser required> 
           Mobo: LENOVO model: 20URS01K00 v: SDK0T08861 WIN serial: <superuser required> UEFI: LENOVO v: N30ET38W (1.21 ) 
           date: 04/19/2021 
Battery:   ID-1: BAT0 charge: 92.7 Wh (97.6%) condition: 95.0/94.0 Wh (101.1%) 
CPU:       Info: 8-Core model: Intel Core i9-10885H bits: 64 type: MT MCP cache: L2: 16 MiB 
           Speed: 3016 MHz min/max: 800/5300 MHz Core speeds (MHz): 1: 842 2: 802 3: 1532 4: 2536 5: 1262 6: 1668 7: 1935 
           8: 2285 9: 1224 10: 1281 11: 1011 12: 811 13: 886 14: 2408 15: 1607 16: 2145 
Graphics:  Device-1: Intel UHD Graphics driver: i915 v: kernel 
           Device-2: NVIDIA TU104M [GeForce RTX 2070 SUPER Mobile / Max-Q] driver: nvidia v: 465.31 
           Device-3: Acer Integrated Camera type: USB driver: uvcvideo 
           Display: x11 server: X.Org 1.20.11 driver: loaded: modesetting,nvidia resolution: 1: 1920x1080~60Hz 
           2: 1200x1920~60Hz 
           OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 21.1.2 
Audio:     Device-1: Intel Comet Lake PCH cAVS driver: snd_hda_intel 
           Sound Server-1: ALSA v: k5.12.9-1-MANJARO running: yes 
           Sound Server-2: PulseAudio v: 14.2 running: yes 
           Sound Server-3: PipeWire v: 0.3.30 running: yes 
Network:   Device-1: Intel Comet Lake PCH CNVi WiFi driver: iwlwifi 
           IF: wlp0s20f3 state: up mac: 2c:db:07:b4:24:90 
           Device-2: Intel Ethernet I219-LM driver: e1000e 
           IF: enp0s31f6 state: down mac: 54:05:db:f3:6b:d2 
Bluetooth: Device-1: Intel type: USB driver: btusb 
           Report: rfkill ID: hci0 state: up address: see --recommends 
Drives:    Local Storage: total: 942.7 GiB used: 109.44 GiB (11.6%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO Plus 500GB size: 465.76 GiB 
           ID-2: /dev/nvme1n1 vendor: Western Digital model: PC SN730 SDBQNTY-512G-1001 size: 476.94 GiB 
Partition: ID-1: / size: 33.35 GiB used: 13.44 GiB (40.3%) fs: ext4 dev: /dev/nvme0n1p2 
           ID-2: /boot/efi size: 246.1 MiB used: 6.8 MiB (2.8%) fs: vfat dev: /dev/nvme0n1p1 
           ID-3: /home size: 374.54 GiB used: 5.45 GiB (1.5%) fs: ext4 dev: /dev/nvme0n1p4 
Swap:      ID-1: swap-1 type: partition size: 15.62 GiB used: 0 KiB (0.0%) dev: /dev/nvme0n1p5 
Sensors:   System Temperatures: cpu: 53.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 361 Uptime: 19m Memory: 15.27 GiB used: 3.87 GiB (25.3%) Shell: Bash inxi: 3.3.04 

I see that @nikgnomic and @Olli were helpful on " Headphone Mic doesn’t get detected in February , but I’m not sure if I have the same issue.

Additional guidance or diagnostics would be welcomed. Thanks.

Trying to follow through on …

  • Bug 207131 - No headset capture on Realtek ALC233

I ran the ALSA Information Script, and posted it at:

Am I supposed to be interested in Node 0x12 ?

Node 0x12 [Pin Complex] wcaps 0x40040b: Stereo Amp-In
  Control: name="Internal Mic Boost Volume", index=0, device=0
    ControlAmp: chs=3, dir=In, idx=0, ofs=0
  Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
  Amp-In vals:  [0x00 0x00]
  Pincap 0x00000020: IN
  Pin Default 0x90a60130: [Fixed] Mic at Int N/A
    Conn = Digital, Color = Unknown
    DefAssociation = 0x3, Sequence = 0x0
    Misc = NO_PRESENCE
  Pin-ctls: 0x20: IN
  Power states:  D0 D1 D2 D3 EPSS
  Power: setting=D0, actual=D0

… or in Node 0x19 ?

Node 0x19 [Pin Complex] wcaps 0x40048b: Stereo Amp-In
  Control: name="Mic Boost Volume", index=0, device=0
    ControlAmp: chs=3, dir=In, idx=0, ofs=0
  Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
  Amp-In vals:  [0x00 0x00]
  Pincap 0x00003724: IN Detect
    Vref caps: HIZ 50 GRD 80 100
  Pin Default 0x04a11040: [Jack] Mic at Ext Right
    Conn = 1/8, Color = Black
    DefAssociation = 0x4, Sequence = 0x0
  Pin-ctls: 0x24: IN VREF_80
  Unsolicited: tag=02, enabled=1
  Power states:  D0 D1 D2 D3 EPSS
  Power: setting=D0, actual=D0

@nikgnomic said …

The headset microphone connection is not configured correctly and is shown in ALSA data as a Speaker Output
Node 0x19
and dmesg data does not show a speaker output for 0x19

… so here’s the dmesg:

$ sudo dmesg | egrep -i '(snd|sound|sof|alsa|hda)'
[    0.451645] pps_core: Software ver. 5.3.6 - Copyright 2005-2007 Rodolfo Giometti <>
[    0.619594] PCI-DMA: Using software bounce buffering for IO (SWIOTLB)
[    0.619595] software IO TLB: mapped [mem 0x0000000061272000-0x0000000065272000] (64MB)
[    1.688435] snd_hda_intel 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040380
[    1.690540] snd_hda_intel 0000:00:1f.3: enabling device (0004 -> 0006)
[    3.610572] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[    3.721832] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC285: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
[    3.721836] snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    3.721837] snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
[    3.721839] snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0
[    3.721839] snd_hda_codec_realtek hdaudioC0D0:    inputs:
[    3.721840] snd_hda_codec_realtek hdaudioC0D0:      Mic=0x19
[    3.721841] snd_hda_codec_realtek hdaudioC0D0:      Internal Mic=0x12
[    3.774329] input: HDA Intel PCH Mic as /devices/pci0000:00/0000:00:1f.3/sound/card0/input15
[    3.774373] input: HDA Intel PCH Headphone as /devices/pci0000:00/0000:00:1f.3/sound/card0/input16
[    3.774407] input: HDA Intel PCH HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input17
[    3.774435] input: HDA Intel PCH HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input18
[    3.774459] input: HDA Intel PCH HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input19
[    3.774483] input: HDA Intel PCH HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input20
[    3.774504] input: HDA Intel PCH HDMI/DP,pcm=10 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input21

Trying …

sudo hdajackretask

… gives me …

I then tried on Pin ID 0x19

(check) Override
Apply now

After reboot, I started up Google Meet again. The Aftershockz mic still is not an option.

If I again check:

$ sudo hdajackretask

… the Override is enabled for Pin ID 0x19.

The Bluetooth mic is now working … in a strange way. It seems to need to be woken up!

If I start Skype … Tools … Audio & Video Settings … , the dropdown menu includes:

  • Monitor of OpenComm by AfterShokz


In Skype, if I

  • Make a free test call

… then … we can see in the KDE Audio Volume settings,

  • Bluetooth Input (OpenComm by Aftershokz)


This is strange. It’s a workaround, to start up Skype, so that I can use Google Meet!

Searching on “alsa ALC285”, I found on

I wonder if that’s a fix that will eventually solve this issue.

Additional suggestions are welcomed.

Does going to pipewire help?

Sorry, I’m not familiar with Pipewire. What do you suggest that I do?