Headphone audio stopped working

Hello,

I’ve had a lot of trouble with getting audio to my headphones with Manjaro over the past year.
I’ve also learned a lot about pulseaudio and the way the software works.

Usually I can fix the problems by doing the following:

  • Open alsamixer and activate the headphones (from Mute to unmute) and reboot
  • Remove the ~/.config/pulse/cookie file and reboot
  • Check if the correct audio device is selected and/or set profile to Analog Stereo Duplex

However today, after a big update and changing to kernel 5.8, I cannot get the headphones to work.

What I’ve tried:

  • All of the above
  • Move the ~/.config/pulse directory to ~/.config/pulse.old
  • Install the jack2 package which replaced jack
  • Switched back to kernel 5.7

Nothing seems to give me audio on my headphones, the speakers work fine.

This is the alsa --upload: http://alsa-project.org/db/?f=295956a18002bc381e843e17f9ed7bfaa48485ed

Please help :slight_smile:

Hi!

What DE are you using? Sometimes pulseaudio jack detection doesn’t work properly and needs to be set manually. If the DE doesn’t provide a good interface for that, pavucontrol is usually the best option to toggle settings.

Oh sorry, I forgot to mention that. I use KDE.

I’ve read about pavucontrol, but TBH, I like the way the audio control is implemented in KDE.

And this seems to be a recent issue, as the headphones are detected correctly, I can also see this in alsamixer.
The applications and devices also register and switch to the headphones correctly.

I just don’t hear any sound coming out of the headphones.
I’ve tested the headphones on a different device of course, which work fine.

I’ve installed pavucontrol just to check if it helps.

I can see the real time audio being sent to the headphones, as the bar is showing the sound variation of my music:

image

But still, nothing can be heard…

I have the same problem after update as OP - headphones produce no audio despite being detected and unmuted, laptop speakers work fine.

I have done similar ways as OP: inspected alsamixer and it was not muted, checked if the audio device profile was set to Analog Stereo Duplex (which it was), swtiched branch to testing, tried to install kernel 5.8 (didn’t solve the issue), tried even reinstalling - that seemed to fix the problem (installation came with kernel 5.6), but after pacman -Syu update headphones sound is gone, as previously described.

Here’s alsa --upload: http://alsa-project.org/db/?f=84c795c021f530797d82b7dc896fe5e6163b63dc

This might be either ALSA or something related with kernel, but I’m not sure.

Well, that’s strange! I just checked and it works perfectly on my laptop. Have you tried unplugging and replugging while the stream is playing? Sometimes, when I suspend the system without the phones, and then plug the phones before resuming, I need to do that. I don’t think this will solve your problem, but it’s just a remote hypothesis.

Another cause may be the kernel combined with your hardware. It wouldn’t hurt to try another kernel (older).

Lastly, you could try to downgrade pulseaudio from your cache:

ls -la /var/cache/pacman/pkg | grep pulseaudio will show which pulseaudio components you have installed and which versions.

Hey mbb,

I tried the different kernels and that did not work.

I tried downgrading pulseaudio:
sudo pacman -U /var/cache/pacman/pkg/pulseaudio-13.0-3-x86_64.pkg.tar.zst

Sadly, after a reboot, still no difference…

I think that there is no newer pulseaudio version released than 13.0.3, am I right?

I think so. It could be a different component (a dependency or a module), but I don’t know pulseaudio that well.

When you boot, this isn’t the profile selected?

alsa-info data all looks ok

please post response for

cat /etc/alsa/conf.d/99-pulseaudio-default.conf

alsa-info used to show the file /etc/asound.conf added by Manjaro to make Pulseaudio default
but it does not detect the new configuration file since it was moved to new location

if file /etc/alsa/conf.d/99-pulseaudio-default.conf is not found, install pulseaudio-alsa

if audio is still not working, please post response to

sudo dmesg | grep snd

and

pacmd dump
1 Like

Not trying to hijack the thread, just bumping it. I am having similar issues after the update. I have an Asus Laptop with the same model as @Outer_Mind. @pidz-b is using an almost similar model.

```
alsa-info.sh --upload
```  

Output

Pulseaudio v14 has been expected for some months, but still not ready
PulseAudio 14.0 release blockers

there is a release-candidate package pulseaudio-git v13.99 in AUR, but i would not expect it to work any better than current version

I missed this post:

The results of your request:

cat /etc/alsa/conf.d/99-pulseaudio-default.conf
# Default to PulseAudio

pcm.!default {
    type pulse
    fallback "sysdefault"
    hint {
        show on
        description "Default ALSA Output (currently PulseAudio Sound Server)"
    }
}

ctl.!default {
    type pulse
    fallback "sysdefault"
}
sudo dmesg | grep snd
[    2.641905] snd_hda_intel 0000:00:1f.3: enabling device (0000 -> 0002)
[    2.648777] snd_hda_intel 0000:01:00.1: enabling device (0000 -> 0002)
[    2.648857] snd_hda_intel 0000:01:00.1: Disabling MSI
[    2.648862] snd_hda_intel 0000:01:00.1: Handle vga_switcheroo audio client
[    2.719758] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC295: line_outs=1 (0x17/0x0/0x0/0x0/0x0) type:speaker
[    2.719761] snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    2.719763] snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
[    2.719764] snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0
[    2.719766] snd_hda_codec_realtek hdaudioC0D0:    inputs:
[    2.719767] snd_hda_codec_realtek hdaudioC0D0:      Headset Mic=0x19
[    2.719769] snd_hda_codec_realtek hdaudioC0D0:      Internal Mic=0x12
[   34.113433] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD data byte 1
[   34.114139] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD data byte 2
pacmd dump
### Configuration dump generated at Fri Aug 21 11:05:42 2020

load-module module-device-restore
load-module module-stream-restore
load-module module-card-restore
load-module module-augment-properties
load-module module-switch-on-port-available
load-module module-udev-detect
load-module module-alsa-card device_id="1" name="pci-0000_01_00.1" card_name="alsa_card.pci-0000_01_00.1" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties="module-udev-detect.discovered=1"
load-module module-alsa-card device_id="0" name="pci-0000_00_1f.3" card_name="alsa_card.pci-0000_00_1f.3" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties="module-udev-detect.discovered=1"
load-module module-jackdbus-detect channels=2
load-module module-bluetooth-policy
load-module module-bluetooth-discover
load-module module-bluez5-discover
load-module module-dbus-protocol
load-module module-native-protocol-unix
load-module module-gsettings
load-module module-default-device-restore
load-module module-rescue-streams
load-module module-always-sink
load-module module-intended-roles
load-module module-suspend-on-idle
load-module module-console-kit
load-module module-systemd-login
load-module module-position-event-sounds
load-module module-role-cork
load-module module-filter-heuristics
load-module module-filter-apply
load-module module-x11-publish display=:0
load-module module-x11-xsmp display=:0 session_manager=local/pidz-b:@/tmp/.ICE-unix/1621,unix/pidz-b:/tmp/.ICE-unix/1621
load-module module-cli-protocol-unix

set-sink-volume alsa_output.pci-0000_01_00.1.hdmi-stereo 0x10000
set-sink-mute alsa_output.pci-0000_01_00.1.hdmi-stereo no
suspend-sink alsa_output.pci-0000_01_00.1.hdmi-stereo yes
set-sink-volume alsa_output.pci-0000_00_1f.3.analog-stereo 0x000
set-sink-mute alsa_output.pci-0000_00_1f.3.analog-stereo yes
suspend-sink alsa_output.pci-0000_00_1f.3.analog-stereo yes

set-source-volume alsa_output.pci-0000_01_00.1.hdmi-stereo.monitor 0x10000
set-source-mute alsa_output.pci-0000_01_00.1.hdmi-stereo.monitor no
suspend-source alsa_output.pci-0000_01_00.1.hdmi-stereo.monitor yes
set-source-volume alsa_output.pci-0000_00_1f.3.analog-stereo.monitor 0x10000
set-source-mute alsa_output.pci-0000_00_1f.3.analog-stereo.monitor no
suspend-source alsa_output.pci-0000_00_1f.3.analog-stereo.monitor yes
set-source-volume alsa_input.pci-0000_00_1f.3.analog-stereo 0x2893
set-source-mute alsa_input.pci-0000_00_1f.3.analog-stereo no
suspend-source alsa_input.pci-0000_00_1f.3.analog-stereo yes

set-card-profile alsa_card.pci-0000_01_00.1 output:hdmi-stereo
set-card-profile alsa_card.pci-0000_00_1f.3 output:analog-stereo+input:analog-stereo

set-default-sink alsa_output.pci-0000_00_1f.3.analog-stereo
set-default-source alsa_input.pci-0000_00_1f.3.analog-stereo

### EOF

Pulsaudio output sink for analog-stereo (headphones/speaker) is muted

set-sink-mute alsa_output.pci-0000_00_1f.3.analog-stereo yes

Mute can be turned off in GUI controls, or with this command:

pacmd set-sink-mute alsa_output.pci-0000_00_1f.3.analog-stereo no

Hehe, I forgot to put the headphone in the jack.

[    2.641905] snd_hda_intel 0000:00:1f.3: enabling device (0000 -> 0002)
[    2.648777] snd_hda_intel 0000:01:00.1: enabling device (0000 -> 0002)
[    2.648857] snd_hda_intel 0000:01:00.1: Disabling MSI
[    2.648862] snd_hda_intel 0000:01:00.1: Handle vga_switcheroo audio client
[    2.719758] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC295: line_outs=1 (0x17/0x0/0x0/0x0/0x0) type:speaker
[    2.719761] snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    2.719763] snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
[    2.719764] snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0
[    2.719766] snd_hda_codec_realtek hdaudioC0D0:    inputs:
[    2.719767] snd_hda_codec_realtek hdaudioC0D0:      Headset Mic=0x19
[    2.719769] snd_hda_codec_realtek hdaudioC0D0:      Internal Mic=0x12
[   34.113433] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD data byte 1
[   34.114139] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD data byte 
pacmd dump
### Configuration dump generated at Fri Aug 21 13:04:09 2020

load-module module-device-restore
load-module module-stream-restore
load-module module-card-restore
load-module module-augment-properties
load-module module-switch-on-port-available
load-module module-udev-detect
load-module module-alsa-card device_id="1" name="pci-0000_01_00.1" card_name="alsa_card.pci-0000_01_00.1" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties="module-udev-detect.discovered=1"
load-module module-alsa-card device_id="0" name="pci-0000_00_1f.3" card_name="alsa_card.pci-0000_00_1f.3" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties="module-udev-detect.discovered=1"
load-module module-jackdbus-detect channels=2
load-module module-bluetooth-policy
load-module module-bluetooth-discover
load-module module-bluez5-discover
load-module module-dbus-protocol
load-module module-native-protocol-unix
load-module module-gsettings
load-module module-default-device-restore
load-module module-rescue-streams
load-module module-always-sink
load-module module-intended-roles
load-module module-suspend-on-idle
load-module module-console-kit
load-module module-systemd-login
load-module module-position-event-sounds
load-module module-role-cork
load-module module-filter-heuristics
load-module module-filter-apply
load-module module-x11-publish display=:0
load-module module-x11-xsmp display=:0 session_manager=local/pidz-b:@/tmp/.ICE-unix/1621,unix/pidz-b:/tmp/.ICE-unix/1621
load-module module-cli-protocol-unix

set-sink-volume alsa_output.pci-0000_00_1f.3.analog-stereo 0xb0a4
set-sink-mute alsa_output.pci-0000_00_1f.3.analog-stereo no
suspend-sink alsa_output.pci-0000_00_1f.3.analog-stereo no
set-sink-volume alsa_output.pci-0000_01_00.1.hdmi-stereo 0x10000
set-sink-mute alsa_output.pci-0000_01_00.1.hdmi-stereo no
suspend-sink alsa_output.pci-0000_01_00.1.hdmi-stereo yes

set-source-volume alsa_output.pci-0000_00_1f.3.analog-stereo.monitor 0x10000
set-source-mute alsa_output.pci-0000_00_1f.3.analog-stereo.monitor no
suspend-source alsa_output.pci-0000_00_1f.3.analog-stereo.monitor no
set-source-volume alsa_input.pci-0000_00_1f.3.analog-stereo 0x2893
set-source-mute alsa_input.pci-0000_00_1f.3.analog-stereo no
suspend-source alsa_input.pci-0000_00_1f.3.analog-stereo yes
set-source-volume alsa_output.pci-0000_01_00.1.hdmi-stereo.monitor 0x10000
set-source-mute alsa_output.pci-0000_01_00.1.hdmi-stereo.monitor no
suspend-source alsa_output.pci-0000_01_00.1.hdmi-stereo.monitor yes

set-card-profile alsa_card.pci-0000_01_00.1 output:hdmi-stereo
set-card-profile alsa_card.pci-0000_00_1f.3 output:analog-stereo+input:analog-stereo

set-default-sink alsa_output.pci-0000_00_1f.3.analog-stereo
set-default-source alsa_input.pci-0000_00_1f.3.analog-stereo

### EOF

If you don’t mind, I’m also going to post results of three commands, as requested to OP by nikgnomic

cat /etc/alsa/conf.d/99-pulseaudio-default.conf 
# Default to PulseAudio

pcm.!default {
    type pulse
    fallback "sysdefault"
    hint {
        show on
        description "Default ALSA Output (currently PulseAudio Sound Server)"
    }
}

ctl.!default {
    type pulse
    fallback "sysdefault"
}


sudo dmesg | grep snd
[    5.870893] snd_hda_intel 0000:00:1f.3: enabling device (0000 -> 0002)
[    7.411330] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[    7.562820] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC295: line_outs=1 (0x17/0x0/0x0/0x0/0x0) type:speaker
[    7.562827] snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    7.562834] snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
[    7.562838] snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0
[    7.562842] snd_hda_codec_realtek hdaudioC0D0:    inputs:
[    7.562848] snd_hda_codec_realtek hdaudioC0D0:      Headset Mic=0x19
[    7.562853] snd_hda_codec_realtek hdaudioC0D0:      Internal Mic=0x12


pacmd dump
### Configuration dump generated at Fri Aug 21 20:35:39 2020

load-module module-device-restore
load-module module-stream-restore
load-module module-card-restore
load-module module-augment-properties
load-module module-switch-on-port-available
load-module module-udev-detect
load-module module-alsa-card device_id="0" name="pci-0000_00_1f.3" card_name="alsa_card.pci-0000_00_1f.3" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties="module-udev-detect.discovered=1"
load-module module-jackdbus-detect channels=2
load-module module-bluetooth-policy
load-module module-bluetooth-discover
load-module module-bluez5-discover
load-module module-dbus-protocol
load-module module-native-protocol-unix
load-module module-gsettings
load-module module-default-device-restore
load-module module-rescue-streams
load-module module-always-sink
load-module module-intended-roles
load-module module-suspend-on-idle
load-module module-console-kit
load-module module-systemd-login
load-module module-position-event-sounds
load-module module-role-cork
load-module module-filter-heuristics
load-module module-filter-apply
load-module module-x11-publish display=:0
load-module module-x11-xsmp display=:0 session_manager=local/outermind-gl503vd:@/tmp/.ICE-unix/1035,unix/outermind-gl503vd:/tmp/.ICE-unix/1035
load-module module-cli-protocol-unix

set-sink-volume alsa_output.pci-0000_00_1f.3.analog-stereo 0x9998
set-sink-mute alsa_output.pci-0000_00_1f.3.analog-stereo no
suspend-sink alsa_output.pci-0000_00_1f.3.analog-stereo no

set-source-volume alsa_output.pci-0000_00_1f.3.analog-stereo.monitor 0x10000
set-source-mute alsa_output.pci-0000_00_1f.3.analog-stereo.monitor no
suspend-source alsa_output.pci-0000_00_1f.3.analog-stereo.monitor no
set-source-volume alsa_input.pci-0000_00_1f.3.analog-stereo 0x3560
set-source-mute alsa_input.pci-0000_00_1f.3.analog-stereo no
suspend-source alsa_input.pci-0000_00_1f.3.analog-stereo no

set-card-profile alsa_card.pci-0000_00_1f.3 output:analog-stereo+input:analog-stereo

set-default-sink alsa_output.pci-0000_00_1f.3.analog-stereo
set-default-source alsa_input.pci-0000_00_1f.3.analog-stereo

### EOF

Any updates?

I’ve installed updates today, but still no difference after a reboot

Look here.

1 Like