[Stable Update] 2020-08-16 - Kernels, Plasma, KDE Framework, Systemd, Pamac, VirtualBox, Firefox

How exactly do you fix it? Normally conf files should not be overwritten by an update.
Depends on the package though. If you put something in a file that is overwritten with an update then it get’s lost of course (so maybe there is an alternative way to fix your issue)

select right device (for me it’s 1 HD-Audio Generic)
then spam right arrow until you are at “Channel” column.
and then up-down until 6ch

sudo alsactl store

Update went fine via tty as always , on KDE , 5.4 with Nvidia , grub re-install did not due to brain fart . Note to self , never mess with system before coffee ! :grin: Coffee made and consumed , grub and grubby self sorted , Timeshift is a wonderful thing to have . All’s well that ends well . :flushed:

Not sure why it overwrites it every time, maybe try storing the settings in the .config dir of users home folder instead. that should not be be overwritten:

1 Like

Update went smoothly in TTY. (XFCE, latest LTS kernel, 5.4)
I have a minor issue though. After the update, the systray icons left and right click actions are the same on the XFCE panel. My left clicks brings up the same menu as my right clicks did before.
The change is a minor annoyance with Transmission and Redshift-gtk icon. Interestingly OBS icon is unaffected.

After this update, sound stopped going through the jack port on ASUS laptops: when headphones are connected, they are detected and the sound switches to them as usual, but there is actually no sound. Any manipulations in pavucontrol and alsamixer do not give any result.

The problem is described here and here, and for some reason specifically ASUS laptops.

1 Like

pipewire-media-session locks at 100% cpu with the current update, whenever a device with a mixer is disconnected. This seems to be the same problem reported on Fedora: 1861733 – Full CPU load from pipewire-media-session

It’s reportedly fixed in newer versions of pipewire, so would appreciate that being fast-tracked to stable.

Needed this as well, on my Desktop manjaro. Cool, thanks! :+1:

I am having this exact same issue… only in english lol

I looked at the post mentioned in the following comment Package installation says FILENAME exists in filesystem; "Failed to commit transaction (conflicting files)" - Frequently Asked Questions - Manjaro Linux Forum and I can confirm the files in question are owned by plasma-desktop 5.19.3-1 but… idk what I should do with that info… delete the files? is that safe? :sweat_smile:

I had issues on both MBR and UEFI systems (one machine of each). Followed @lectrode’s lead to resolve the MBR machine. All good.
Had a minor stumper on the UEFI system.
Following the instruction Wiki page

led to a boot failure. The missing piece on my system was BIOS/boot setup settings.
I rebooted, and just checked into possible BIOS settings, and found the culprit on the 2nd try.

UEFI Hard Disk Drive BBS Priorities

menu under boot, I selected
Boot Option #1 [manjaro]
which seems to have not been selected before…

Other Boot Menu BIOS settings are:
Boot Mode Select [UEFI]
Fast Boot Function [Disabled]
Boot from USB device [Enabled]

Saved, exited BIOS, and the reboot completed the fix (and the stable update).

Anybody else with UEFI system trouble, this BIOS update bit hope this helps…

I second that. Bluetooth has become pretty buggy. Audio devices are a hit or miss. I reverted to 5.4LTS.

After this update, the webcam is not working :frowning: Checked with both google-meet and zoom. [Thought of posting it here in case others are facing this issue too. Will open a different thread to ask for help.]

Only if you want to enable Secure Boot option.

Updated grub and found myself in grub rescue. In my case I dual boot from Windows (internal SSD) and Manjaro from a removable drive. The default grub update will not work and found this way to do the update after 3 days of trying to fix grub [SOLVED]Issue with installation on Removable USB / Installation / Arch Linux Forums

In my case –removable was the trick, I hope someone finds this useful :wink:

On another note how do you know if your grub version is 2.04-11?
When I type: grub-install --version
All I get is: 2.04~manjaro


You should try one of the three fix ways; it’s up to you which one follow:
“The best way”, “The faster way”, “The I don’t care way”, in order from safest to riskiest.
Some times ago, I’ve had the same problem, with far more conflicts than yours and, fortunately, I solved with the best and safest (but challenging) way. :stuck_out_tongue_winking_eye:

It happens with any method of suspend, I doubt it is any malicious software, also sometime when I resume the session, the libre office document has the last paragraph repeated as if I have typed it twice. It is a very strange bug?

And with Jitsi meet? :wink:

I haven’t upgraded the packages and haven’t re-installed grub, yet.

I’m trying to find out if there are going to be problems for people with MBR and full disk LUKS encryption (I don’t have a separate un-encrypted /boot partition. The whole system is in one LUKS encrypted partition, which is sda1 in my case). :fearful:

I don’t know if re-installing grub to /sda will mess with the grub screen where one enters his passphrase to decrypt the root partition and load the system.

Could you please tell me if you MBR machine is also using full disk encryption and you also don’t have a separate boot partition? :crossed_fingers:

I’ve opened a thread here: https://forum.manjaro.org/t/reinstall-grub-bios-fully-encrypted-luks-partitions-will-this-work/6415
and I hope someone can help me with this before I start upgrading the packages and re-installing grub. I hope I find an answer before the next package update arrives… :smile:


Update without problems on 2 machines, XFCE, kernel 5.7.14. After update i did “pacman -Syyu” and “grub-install --recheck --no-rs-codes”. All went fine.
Thanks to the team for the great work.

Bye, Klaus

I have already updated 6 computers (KDE) within the past few days without any problem. How ever, I have a test computer (KDE) that for some reason this 2020-09-16 update won’t show up no matter what I do.
I’ve tried the following:
sudo pacman -Syu and the result (there is nothing to do).
sudo pacman -Syyu, same thing (there is nothing to do).
Any idea why the update is not showing up?