Getting locked out for "3 incorrect attemts" even though there were 2 and the password was correct

This happens to me at least twice a week now, it started happening about 3 weeks ago. I open my laptop and enter my password, it says it’s incorrect. I type it in again and it locks me out for 3 incorrect attempts. After it happened a few times I started feeling that it might be a bug so today I paid extra attention. The second time I typed in my password, I clicked the eye icon to see what I had typed in and it was the correct password. I double and triple-checked every character before hitting Enter but when I submitted it, it told me it was the wrong password and that I’m locked out after “3 incorrect attempts”, even though I now know for a fact I entered the correct password and only tried it twice, not three times.

Do you happen to have a fingerprint reader on your palmrest which you do not use?
On my T490 its this, its active despite not beein setup and thus enters wrong logins it seems. Deactivating the fingerprint reader helped me and at least one more user here on the forum.

That’s interesting. I do have one, it doesn’t work well with the OS (Manjaro seems to be catered to fingerprint readers where you swipe your finger, not ones where you place and hold it) so I turned it off in settings (Users -> Fingerprint login = Disabled). Is there something beyond that that I should do to deactivate it?

Thats not a manjaro problem but with the input system for linux in general - e.g. all distros have that problem currently.

Yes - disable it in the UEFI/BIOS as this is what I (we) did to fix (work around) this - disabling in the settings alone did not truely dissable it.

Okay, that sounds like it could work. The only thing I’m worried about is that my BIOS settings seem to randomly reset themselves to default every now and then but I’m probably just gonna have to wait for the motherboard manufacturer to do something about that. I’m gonna give it a shot and see what happens, thanks!

What make and model of laptop do you have?? I mean it sounds like a weak/empty CMOS battery at first. Usually - UEFI dont reset themselves out of nowhere (not in my experience though)

Acer Aspire 5. I know that it gets reset every time after I “reset” (not sure if that’s the right term) the battery, I have to do that every now and then because this piece of crap refuses to boot and resetting the battery usually helps. But it sometimes happens even without me doing that.

I went through the BIOS and I can’t find anything about a fingerprint reader. I tried attaching pictures of the BIOS in case I missed something but I’m getting an error: “Sorry, you can’t embed media items in a post.”

Ok, to me that confirms that the internal CMOS battery is dead (a small button cell) that normaly keeps the UEFI settings and the system clock running if there is no power (e.g. no AC and no BAT)
This also can be the source of your startup problems as a whole.

Can be that ACER did not include a UEFI setting to do that - in that case I only think that looking at PAM (plugable authentification module) can help by removing the part for fingerprint auth, but I have not looked into PAM at all so cant help there.

This is due to your forum rank - new users cant add images to posts to prevent spam and many other means of abusive and obstrusive things people want to do…

Okay, that sounds like it could be the problem but I’m not that experienced with hardware. I know how to add more RAM or an extra SSD but I really have no clue where to find the CMOS battery or how to fix it.

I guess there could also be something we could do software-wise, because this only started happening a few weeks ago. There could have been some OS update that screwed this up, do you think downgrading something could work?

Or is there someplace where I could report this as a bug so the devs could start looking into it?

if you can add RAM and replace a SSD you can do that as well:


Have a look there - its just as simple as opening the machine and replacing a battery like in a clock =)

Not screwed - support for fingerprint readers was whidely added to linux thus now they can caus trouble as they finally work. As said, either look into removing the parts that enable fingerprint reading (some lib intput something I guess!) or modify PAM to not recognise fingerprints. But be carefull - if you mess up PAM you can lock yourself out of your system for good.

exactly happened to me its the fingerprint reader I think